Bug 515324 - RFE: Add /etc/nrpe.d include dir
Summary: RFE: Add /etc/nrpe.d include dir
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: nrpe
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Peter Lemenkov
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 580023 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-03 18:05 UTC by Ruben Kerkhof
Modified: 2010-06-18 09:39 UTC (History)
4 users (show)

Fixed In Version: 2.12-11.el4
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-03 19:01:51 UTC


Attachments (Terms of Use)
Add an include dir for config files to nrpe (527 bytes, patch)
2009-08-03 18:05 UTC, Ruben Kerkhof
no flags Details | Diff

Description Ruben Kerkhof 2009-08-03 18:05:35 UTC
Created attachment 356070 [details]
Add an include dir for config files to nrpe

Description of problem:

We manage nrpe with puppet, and find it easier to manage if we separate all the check_commands in their own file.

Enabling the include_dir directive and dropping our files in /etc/nrpe.d makes this work.

I've attached a patch against the devel branch which makes this possible. Would you mind including this?

Comment 1 Peter Lemenkov 2009-08-03 18:32:11 UTC
Looks ok for me, and it doesn't breaks existing functionality.

If Mike McGrath haven't any objections, then I'll apply it to all branches.

Comment 2 Fedora Update System 2009-09-24 16:38:48 UTC
nrpe-2.12-11.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/nrpe-2.12-11.el5

Comment 3 Fedora Update System 2009-09-24 16:38:53 UTC
nrpe-2.12-11.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/nrpe-2.12-11.fc10

Comment 4 Fedora Update System 2009-09-24 16:38:58 UTC
nrpe-2.12-11.el4 has been submitted as an update for Fedora EPEL 4.
http://admin.fedoraproject.org/updates/nrpe-2.12-11.el4

Comment 5 Fedora Update System 2009-09-24 16:39:03 UTC
nrpe-2.12-11.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/nrpe-2.12-11.fc11

Comment 6 Fedora Update System 2009-09-25 20:12:44 UTC
nrpe-2.12-11.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update nrpe'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-9945

Comment 7 Fedora Update System 2009-09-25 20:13:15 UTC
nrpe-2.12-11.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update nrpe'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-9948

Comment 8 Fedora Update System 2009-09-26 01:28:44 UTC
nrpe-2.12-11.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update nrpe'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/EL-5/FEDORA-EPEL-2009-0519

Comment 9 Fedora Update System 2009-09-26 01:29:02 UTC
nrpe-2.12-11.el4 has been pushed to the Fedora EPEL 4 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update nrpe'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/EL-4/FEDORA-EPEL-2009-0521

Comment 10 Fedora Update System 2009-10-03 19:01:46 UTC
nrpe-2.12-11.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2009-10-03 19:09:07 UTC
nrpe-2.12-11.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2009-10-16 19:34:06 UTC
nrpe-2.12-11.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2009-10-16 19:36:17 UTC
nrpe-2.12-11.el4 has been pushed to the Fedora EPEL 4 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Peter Lemenkov 2010-06-18 09:39:23 UTC
*** Bug 580023 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.