Bug 515339 - (WW) intel(0): Disabling Xv because no adaptors could be initialized.
Summary: (WW) intel(0): Disabling Xv because no adaptors could be initialized.
Keywords:
Status: CLOSED DUPLICATE of bug 502913
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: IntelKMS
TreeView+ depends on / blocked
 
Reported: 2009-08-03 19:00 UTC by Wesley Tanaka
Modified: 2018-04-11 08:58 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-07 23:17:15 UTC
Type: ---


Attachments (Terms of Use)
Xorg.log exhibiting bug (44.27 KB, text/plain)
2009-08-03 19:00 UTC, Wesley Tanaka
no flags Details

Description Wesley Tanaka 2009-08-03 19:00:50 UTC
Created attachment 356072 [details]
Xorg.log exhibiting bug

Description of problem: Xv/XVideo does not work in Fedora 11
Version-Release number of selected component (if applicable): xorg-x11-drv-intel-2.7.0-7.fc11.i586
How reproducible: Every time

Steps to Reproduce:
1. Boot machine
  
Actual results:

This in log file:
(WW) intel(0): Disabling Xv because no adaptors could be initialized.

xvinfo reports no adaptors

xv-reliant applications do not work


Expected results:

Xv works


Additional info:

This happens regardless of whether XAA is specified in xorg.conf or if nothing is specified which defaults to UXA.  Xv works after rebooting with the "nomodeset" kernel command line parameter.

This sounds similar to https://bugzilla.redhat.com/show_bug.cgi?id=485823 but based on dates and version numbers might not be the same thing.

Comment 1 Filippo Racca 2009-08-06 01:44:08 UTC
Got the same problem. Updating to:

-kernel-2.6.31-0.132.rc5.git3.fc12
-xorg-x11-drv-intel-2.8.0-3.fc12.i686
-xorg-x11-server-Xorg-1.6.99-27.20090804.fc12

from rawhide doesn't help. Actually it gets worse because the intel 2.8 driver requires KMS to work. So you can't use nomodeset.

Device:
00:02.0 VGA compatible controller [0300]: Intel Corporation 82852/855GM Integrated Graphics Device [8086:3582] (rev 02) (prog-if 00 [VGA controller])
	Subsystem: Mitac Device [1071:8080]
	Flags: bus master, fast devsel, latency 0, IRQ 9
	Memory at b0000000 (32-bit, prefetchable) [size=128M]
	Memory at f0000000 (32-bit, non-prefetchable) [size=512K]
	I/O ports at e000 [size=8]
	Expansion ROM at <unassigned> [disabled]
	Capabilities: [d0] Power Management version 1
	Kernel driver in use: i915
	Kernel modules: i915

Error message in xorg.0.log:
(WW) intel(0): Disabling Xv because no adaptors could be initialized.

Comment 2 Matěj Cepl 2009-08-07 23:17:15 UTC

*** This bug has been marked as a duplicate of bug 502913 ***


Note You need to log in before you can comment on or make changes to this bug.