Bug 515349 - Include 3g modem models on udev-extras rules
Summary: Include 3g modem models on udev-extras rules
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 516998
TreeView+ depends on / blocked
 
Reported: 2009-08-03 19:54 UTC by Javier Alejandro Castro
Modified: 2009-12-05 04:46 UTC (History)
2 users (show)

Fixed In Version: 145-14.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-07 19:37:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Javier Alejandro Castro 2009-08-03 19:54:04 UTC
Description of problem:

ZTE MF622 does not work out-of-the-box on F11, rawhide.

Version-Release number of selected component (if applicable):

0.5.20090302git.fc11

How reproducible:

Always

Steps to Reproduce:
1. Buy ZTE MF622
2. Install F11, install udev-extras
3. Plug in ZTE MF622
  
Actual results:

Remains as a CD device

Expected results:

Change its mode thourgh modem-modeswitch from CD to modem

Additional info:

For my modem, the change would be modify file /lib/udev/rules.d/61-option-modem-modeswitch.rules adding a line with:

ATTRS{idVendor}=="19d2", ATTRS{idProduct}=="2000", RUN+="modem-modeswitch -v 0x%s{idVendor} -p 0x%s{idProduct} -t option-zerocd"

I suggest: Would be nice to include all available modem models from file /etc/usb_modeswitch.conf included in package usb_modeswitch.rpm

Comment 1 Harald Hoyer 2009-08-04 10:04:12 UTC
udev-extras got merged in udev and is obsoleted, please update udev

Comment 2 Javier Alejandro Castro 2009-08-04 12:25:29 UTC
as requested by halard, please update udev to contain rules for 3g modems

Comment 3 Javier Alejandro Castro 2009-11-07 19:37:42 UTC
Yes! Now it works fine. Thanks!

Comment 4 Fedora Update System 2009-11-27 21:47:53 UTC
udev-145-14.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 5 Dan Williams 2009-12-05 04:46:07 UTC
So this change causes problems for ZTE devices like the MF626 and the 2.6.31 kernel (bug #533716).  It's also the wrong approach since the modeswitch command for Option NV devices is not the correct command for ZTE devices.

The correct way to switch these devices is using usb_modeswitch, not the Option-specific rules from modem-modeswitch.


Note You need to log in before you can comment on or make changes to this bug.