Bug 533716 - NetworkManager does not recognise GSM modem ZTE MF636
NetworkManager does not recognise GSM modem ZTE MF636
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
: 545638 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-08 13:34 EST by Need Real Name
Modified: 2010-04-20 01:55 EDT (History)
7 users (show)

See Also:
Fixed In Version: 0.3-1.git20100119.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-05 19:07:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output for zte mf626 (49.60 KB, application/octet-stream)
2009-12-01 17:57 EST, robledo
no flags Details

  None (edit)
Description Need Real Name 2009-11-08 13:34:12 EST
My modem is not supported by Fedora rawhide. I have installed and run usb_modeswitch. It now shows:

# lsusb
Bus 002 Device 005: ID 19d2:0031 ONDA Communication S.p.A. 

I have also added a new fdi file and rebooted:

# cat /usr/share/hal/fdi/information/20thirdparty/20-zte-mf636.fdi
<!-- -*- SGML -*- -->
<deviceinfo version="0.2">
   <device>
<!-- ZTE MF636 HSDPA USB dongle -->
      <match key="@info.parent:usb.vendor_id" int="0x19d2">
         <match key="@info.parent:usb.product_id" int="0x0031">
            <match key="@info.parent:usb.interface.number" int="3">
            <append key="modem.command_sets" type="strlist">GSM-07.07</append>
            <append key="modem.command_sets" type="strlist">GSM-07.05</append>
            <append key="info.capabilities" type="strlist">modem</append>
            </match>
         </match>
      </match>
   </device>
</deviceinfo>

Unfortunately it does not seem to be detected by NetworkManager.
Comment 1 Bug Zapper 2009-11-16 10:19:28 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 robledo 2009-11-25 09:10:13 EST
I have found that with modem ZTE MF626, F12 automatically mounts a usb-mass-storage device, and if ejected (while keeping the usb-modem connected), the modem is recognized, and connections are possible.

Pls see output in bug report
https://bugzilla.redhat.com/show_bug.cgi?id=541314
Comment 3 Dan Williams 2009-12-01 03:59:09 EST
lsof, can you attach some 'dmesg' output from right when you plug the device in, through when it's modeswitched, through when NM fails to recognize the device?  I'd like to see if it's correctly modeswitched or not.
Comment 4 robledo 2009-12-01 04:54:29 EST
Dan, if you need output for the ZTE MF 626 (not 636), let me know.  Same issue.  Pls give precise instructions on how to "dmesg", however.
Comment 5 Need Real Name 2009-12-01 17:36:03 EST
It's not modeswitched, I have to wrong the usb_modeswitch utility manually with a custom config file. I will post the output before and after tomorrow. Before the modeswitch the virtual cdrom is mounted.
Comment 6 Need Real Name 2009-12-01 17:49:55 EST
s/wrong/run/;
Comment 7 robledo 2009-12-01 17:57:20 EST
Created attachment 375229 [details]
dmesg output for zte mf626


attached output from dmesg > ztemf626.log, when 1) attached usb modem ZTE MF 626, 2) eject mass-storage device, leading to 3) recognition of mf 626 modem in NW, to 4) establish the 3G connection (disable wifi), and then 5) disconnect the 3G connection, and finally 6) try to reconnect the 3G connection. 
hope it helps
Comment 8 Need Real Name 2009-12-02 03:53:42 EST
I plug in the usb stick:

# dmesg -c
usb 2-2: new high speed USB device using ehci_hcd and address 5
usb 2-2: New USB device found, idVendor=19d2, idProduct=2000
usb 2-2: New USB device strings: Mfr=2, Product=1, SerialNumber=0
usb 2-2: Product: ZTE CDMA Technologies MSM
usb 2-2: Manufacturer: ZTE, Incorporated
usb 2-2: configuration #1 chosen from 1 choice
scsi7 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 5
usb-storage: waiting for device to settle before scanning
usb-storage: device scan complete
scsi 7:0:0:0: CD-ROM            ZTE      USB SCSI CD-ROM  2.31 PQ: 0 ANSI: 0
sr0: scsi3-mmc drive: 0x/52x cd/rw xa/form2 cdda tray
sr 7:0:0:0: Attached scsi CD-ROM sr0
sr 7:0:0:0: Attached scsi generic sg1 type 5
ISO 9660 Extensions: Microsoft Joliet Level 1
ISOFS: changing to secondary root
SELinux: initialized (dev sr0, type iso9660), uses genfs_contexts

# lsusb 
Bus 002 Device 005: ID 19d2:2000 ONDA Communication S.p.A. 

# usb_modeswitch 

Looking for target devices ...
 No devices in target mode or class found
Looking for default devices ...
 Found default devices (1)
Accessing device 005 on bus 002 ...
Using endpoints 0x01 (out) and 0x81 (in)
Inquiring device details; driver will be detached ...
Looking for active driver ...
 OK, driver found ("usb-storage")
 OK, driver "usb-storage" detached

Received inquiry data (detailed identification)
-------------------------
  Vendor String: ZTE     
   Model String: USB SCSI CD-ROM
Revision String: 2.31
-------------------------

Device description data (identification)
-------------------------
Manufacturer: ZTE, Incorporated
     Product: ZTE CDMA Technologies MSM
  Serial No.: not provided
-------------------------
Setting up communication with interface 0 ...
Trying to send the message to endpoint 0x01 ...
 OK, message successfully sent
-> Run lsusb to note any changes. Bye.

# dmesg -c
scsi 7:0:0:0: rejecting I/O to dead device
usb 2-2: usbfs: process 10564 (usb_modeswitch) did not claim interface 0 before use
usb 2-2: USB disconnect, address 5
usb 2-2: new high speed USB device using ehci_hcd and address 6
usb 2-2: New USB device found, idVendor=19d2, idProduct=0031
usb 2-2: New USB device strings: Mfr=2, Product=1, SerialNumber=3
usb 2-2: Product: ZTE CDMA Technologies MSM
usb 2-2: Manufacturer: ZTE, Incorporated
usb 2-2: SerialNumber: 1234567890ABCDEF
usb 2-2: configuration #1 chosen from 1 choice
option 2-2:1.0: GSM modem (1-port) converter detected
usb 2-2: GSM modem (1-port) converter now attached to ttyUSB0
option 2-2:1.1: GSM modem (1-port) converter detected
usb 2-2: GSM modem (1-port) converter now attached to ttyUSB1
scsi8 : SCSI emulation for USB Mass Storage devices
option 2-2:1.3: GSM modem (1-port) converter detected
usb 2-2: GSM modem (1-port) converter now attached to ttyUSB2
usb-storage: device found at 6
usb-storage: waiting for device to settle before scanning
option: option_instat_callback: error -71
option: option_instat_callback: error -71
option: option_instat_callback: error -71
option: option_instat_callback: error -71
usb-storage: device scan complete
scsi 8:0:0:0: Direct-Access     ZTE      MMC Storage      322  PQ: 0 ANSI: 2
sd 8:0:0:0: Attached scsi generic sg1 type 0
sd 8:0:0:0: [sdb] Attached SCSI removable disk
option: option_instat_callback: error -71
option: option_instat_callback: error -71
option: option_instat_callback: error -71
option: option_instat_callback: error -71

# lsusb
Bus 002 Device 006: ID 19d2:0031 ONDA Communication S.p.A.
Comment 9 Dan Williams 2009-12-02 16:44:50 EST
Can you do the following for me?

1) service NetworkManager stop
2) killall -TERM modem-manager
3) modem-manager --debug
4) service NetworkManager start   (in another window)
5) unplug and replug your device, try to reproduce the problem where the modem is not seen by NM
6) when you reproduce the problem, attach/paste the modem-manager output here and we can see what's going on with modem detection
Comment 10 Need Real Name 2009-12-02 17:04:41 EST
First I deleted that custom fdi file then I rebooted and followed your instructions.

I got this:

# modem-manager --debug
** Message: Loaded plugin Generic
** Message: Loaded plugin Option
** Message: Loaded plugin Sierra
** Message: Loaded plugin MotoC
** Message: Loaded plugin Nokia
** Message: Loaded plugin Novatel
** Message: Loaded plugin ZTE
** Message: Loaded plugin Huawei
** Message: Loaded plugin Gobi
** Message: Loaded plugin Option High-Speed
** Message: Loaded plugin Ericsson MBM

I plug in the modem and nothing happens. So I run umount /media/*
Nothing happens, so I run usb_modeswitch then this happens:

** Message: (ttyUSB2) opening serial device...
** (modem-manager:2319): DEBUG: (ttyUSB2): probe requested by plugin 'ZTE'
** Message: (ttyUSB0) opening serial device...
** (modem-manager:2319): DEBUG: (ttyUSB0): probe requested by plugin 'ZTE'
** Message: (ttyUSB1) opening serial device...
** (modem-manager:2319): DEBUG: (ttyUSB1): probe requested by plugin 'ZTE'
** (modem-manager:2319): DEBUG: (ttyUSB2): --> 'AT+GCAP<CR>'
** (modem-manager:2319): DEBUG: (ttyUSB2): <-- 'AT+GCAP<CR><CR><LF>+GCAP: +CGSM,+DS,+ES<CR><LF><CR><LF>OK<CR><LF>'
** (modem-manager:2319): DEBUG: (ttyUSB0): --> 'AT+GCAP<CR>'
Comment 11 Need Real Name 2009-12-02 17:05:48 EST
By the way with wvdial it works fine. For the init strings I use (from wvdial.conf):

Init1 = at+cfun=1
Init2 = at+cgdcont=1,"ip","PROVIDER"
Comment 12 Dan Williams 2009-12-02 17:32:26 EST
Is that all the MM logs you have?  You might want to wait 10 seconds or so for the modem to completely finish probing.  If it actually never finishes, or takes a long time to finish, then we should gdb modem-manager to figure out why its hanging there.
Comment 13 Need Real Name 2009-12-02 17:52:56 EST
Those are all the logs. Nothing happens unless I run usb_modeswitch (do you want me to run it?)

What do you mean when you say "try to reproduce the problem where the modem
is not seen by NM". Do you mean just plug in the modem and wait?
Comment 14 Dan Williams 2009-12-02 18:16:07 EST
Yes, please run usb_modeswitch and report the MM logs.(In reply to comment #13)
> Those are all the logs. Nothing happens unless I run usb_modeswitch (do you
> want me to run it?)

Yes; the modem is not usable until its switched to modem mode.

> What do you mean when you say "try to reproduce the problem where the modem
> is not seen by NM". Do you mean just plug in the modem and wait?  

Yeah.
Comment 15 Need Real Name 2009-12-03 15:13:40 EST
Okay then to answer your question:

(In reply to comment #12)
> Is that all the MM logs you have?  You might want to wait 10 seconds or so for
> the modem to completely finish probing.  If it actually never finishes, or
> takes a long time to finish, then we should gdb modem-manager to figure out why
> its hanging there.  

It never finishes. strace says it's doing nothing. I'll run it from within strace and post the result.
Comment 16 Dan Williams 2009-12-04 14:42:51 EST
Ok, thanks.  Basically, it looks like something in the kernel or the device is not responding or making the port hang.  You should get more output from ModemManager, including messages about sending AT+GCAP to ttyUSB1.  If the probe times out (it'll send 4 AT+GCAP requests to each port) then you should also see a message about "Closing serial port X" too.
Comment 17 Dan Williams 2009-12-04 23:23:21 EST
Actually, give this a try:

Remove the line that contains '19d2' from /lib/udev/rules.d/61-option-modem-modeswitch.rules, then unplug your device, and replug it.  Make sure you still have usb_modeswitch set up to flip the device to modem mode.  modem-manager should then be able to use the device.
Comment 18 Need Real Name 2009-12-07 03:30:49 EST
Okay I did that and reloaded the udev rules.

I got this:

** Message: Loaded plugin Ericsson MBM
** Message: (ttyUSB2) opening serial device...
** (modem-manager:9418): DEBUG: (ttyUSB2): probe requested by plugin 'ZTE'
** Message: (ttyUSB0) opening serial device...
** (modem-manager:9418): DEBUG: (ttyUSB0): probe requested by plugin 'ZTE'
** Message: (ttyUSB1) opening serial device...
** (modem-manager:9418): DEBUG: (ttyUSB1): probe requested by plugin 'ZTE'
** (modem-manager:9418): DEBUG: (ttyUSB2): --> 'AT+GCAP<CR>'
** (modem-manager:9418): DEBUG: (ttyUSB2): <-- 'AT+GCAP<CR><CR><LF>+GCAP: +CGSM,+DS,+ES<CR><LF><CR><LF>OK<CR><LF>'
** (modem-manager:9418): DEBUG: (ttyUSB0): --> 'AT+GCAP<CR>'
** (modem-manager:9418): DEBUG: (ttyUSB1): --> 'AT+GCAP<CR>'

Similar to before. NetworkManager doesn't seem to see the modem. I am expecting a 3G menu to appear and for me to be able to click on my connection (that doesn't happen).

Normal wvdial works.
Comment 19 Dan Williams 2009-12-07 13:24:16 EST
(In reply to comment #18)
> Okay I did that and reloaded the udev rules.

Did you unplug/replug the ZTE device too after fixing the rules?
Comment 20 Need Real Name 2009-12-07 16:11:41 EST
Yes I did.
Comment 21 Dan Williams 2009-12-08 02:04:43 EST
Ok, kernel bugs.  There's one or two fixes in the tty layer in 2.6.31.7 and 2.6.32 that could have an impact on this, so we may just have to see how 2.6.31.7 does.
Comment 22 Dan Williams 2010-01-02 00:22:32 EST
Can you try the packages here?

http://koji.fedoraproject.org/koji/buildinfo?buildID=149089

They fix a specific issue with unresponsive serial ports that could be blocking ModemManager in your case.
Comment 23 Stian Ellingsen 2010-01-02 18:24:34 EST
I've been having exactly the same problem. With ModemManager-0.2.997-5.git20100101 (the build mentioned above), NetworkManager recognizes my ZTE MF636, and I can connect normally, so this bug is fixed to me.
Comment 24 Need Real Name 2010-01-02 18:31:49 EST
Nothing happens unfortunately.

# modem-manager --debug
** Message: Loaded plugin Generic
** Message: Loaded plugin Option
** Message: Loaded plugin Sierra
** Message: Loaded plugin MotoC
** Message: Loaded plugin Nokia
** Message: Loaded plugin Novatel
** Message: Loaded plugin ZTE
** Message: Loaded plugin Huawei
** Message: Loaded plugin Gobi
** Message: Loaded plugin Option High-Speed
** Message: Loaded plugin Ericsson MBM
# dmesg
usb 2-2: new high speed USB device using ehci_hcd and address 2
usb 2-2: New USB device found, idVendor=19d2, idProduct=2000
usb 2-2: New USB device strings: Mfr=2, Product=1, SerialNumber=0
usb 2-2: Product: ZTE CDMA Technologies MSM
usb 2-2: Manufacturer: ZTE, Incorporated
usb 2-2: configuration #1 chosen from 1 choice
Initializing USB Mass Storage driver...
scsi4 : SCSI emulation for USB Mass Storage devices
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.
usb-storage: device found at 2
usb-storage: waiting for device to settle before scanning
CE: hpet increasing min_delta_ns to 15000 nsec
usb-storage: device scan complete
scsi 4:0:0:0: CD-ROM            ZTE      USB SCSI CD-ROM  2.31 PQ: 0 ANSI: 0
sr0: scsi3-mmc drive: 0x/52x cd/rw xa/form2 cdda tray
Uniform CD-ROM driver Revision: 3.20
sr 4:0:0:0: Attached scsi CD-ROM sr0
sr 4:0:0:0: Attached scsi generic sg1 type 5
ISO 9660 Extensions: Microsoft Joliet Level 1
ISOFS: changing to secondary root
SELinux: initialized (dev sr0, type iso9660), uses genfs_contexts

I waited 60 seconds, nothing happened. So I ran usb_modeswitch. I got this:

** Message: Loaded plugin Ericsson MBM

** Message: (ttyUSB1) opening serial device...
** (modem-manager:19489): DEBUG: (ttyUSB1): probe requested by plugin 'ZTE'
** Message: (ttyUSB0) opening serial device...
** (modem-manager:19489): DEBUG: (ttyUSB0): probe requested by plugin 'ZTE'
** Message: (ttyUSB2) opening serial device...
** (modem-manager:19489): DEBUG: (ttyUSB2): probe requested by plugin 'ZTE'
** (modem-manager:19489): DEBUG: (ttyUSB1): --> 'ATE0+CPMS?<CR>'
** (modem-manager:19489): DEBUG: (ttyUSB1): --> 'ATE0+CPMS?<CR>'
** (modem-manager:19489): DEBUG: (ttyUSB0): --> 'ATE0+CPMS?<CR>'
** (modem-manager:19489): DEBUG: (ttyUSB2): --> 'ATE0+CPMS?<CR>'
** (modem-manager:19489): DEBUG: (ttyUSB2): <-- 'ATE0+CPMS?<CR><CR><LF>+CPMS: "SM",0,20,"SM",0,20,"ME",10,23<CR><LF><CR><LF>OK<CR><LF>'
** (modem-manager:19489): DEBUG: (ttyUSB1): --> 'ATE0+CPMS?<CR>'
** (modem-manager:19489): DEBUG: (ttyUSB0): --> 'ATE0+CPMS?<CR>'
** (modem-manager:19489): DEBUG: (ttyUSB2): --> 'AT+GCAP<CR>'
** (modem-manager:19489): DEBUG: (ttyUSB2): <-- '<CR><LF>+GCAP: +CGSM,+DS,+ES<CR><LF><CR><LF>OK<CR><LF>'
** (modem-manager:19489): DEBUG: (ttyUSB1): --> 'ATE0+CPMS?<CR>'
** (modem-manager:19489): DEBUG: (ttyUSB0): --> 'ATE0+CPMS?<CR>'
** (modem-manager:19489): DEBUG: (ttyUSB1): --> 'AT+GCAP<CR>'
** (modem-manager:19489): DEBUG: (ttyUSB0): --> 'ATE0+CPMS?<CR>'
** Message: (ttyUSB2) closing serial device...
** (modem-manager:19489): DEBUG: (ttyUSB0): --> 'AT+GCAP<CR>'
** Message: (ZTE): GSM modem /sys/devices/pci0000:00/0000:00:1d.7/usb2/2-2 claimed port ttyUSB2
** (modem-manager:19489): DEBUG: Added modem /sys/devices/pci0000:00/0000:00:1d.7/usb2/2-2
** (modem-manager:19489): DEBUG: Exported modem /sys/devices/pci0000:00/0000:00:1d.7/usb2/2-2 as /org/freedesktop/ModemManager/Modems/0
** (modem-manager:19489): DEBUG: (ttyUSB1): --> 'AT+GCAP<CR>'
** (modem-manager:19489): DEBUG: (ttyUSB0): --> 'AT+GCAP<CR>'
** (modem-manager:19489): DEBUG: (ttyUSB1): --> 'AT+GCAP<CR>'
** (modem-manager:19489): DEBUG: (ttyUSB0): --> 'AT+GCAP<CR>'
** (modem-manager:19489): DEBUG: (ttyUSB1): --> 'ATI<CR>'
** (modem-manager:19489): DEBUG: (ttyUSB0): --> 'ATI<CR>'
** Message: (ttyUSB1) closing serial device...
** Message: (ttyUSB0) closing serial device...

# dmesg
usb 2-2: usbfs: process 19720 (usb_modeswitch) did not claim interface 0 before use
scsi 4:0:0:0: rejecting I/O to dead device
usb 2-2: USB disconnect, address 2
usb 2-2: new high speed USB device using ehci_hcd and address 3
usb 2-2: New USB device found, idVendor=19d2, idProduct=0031
usb 2-2: New USB device strings: Mfr=2, Product=1, SerialNumber=3
usb 2-2: Product: ZTE CDMA Technologies MSM
usb 2-2: Manufacturer: ZTE, Incorporated
usb 2-2: SerialNumber: 1234567890ABCDEF
usb 2-2: configuration #1 chosen from 1 choice
scsi5 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 3
usb-storage: waiting for device to settle before scanning
usbcore: registered new interface driver usbserial
USB Serial support registered for generic
usbcore: registered new interface driver usbserial_generic
usbserial: USB Serial Driver core
USB Serial support registered for GSM modem (1-port)
option 2-2:1.0: GSM modem (1-port) converter detected
usb 2-2: GSM modem (1-port) converter now attached to ttyUSB0
option 2-2:1.1: GSM modem (1-port) converter detected
usb 2-2: GSM modem (1-port) converter now attached to ttyUSB1
option 2-2:1.3: GSM modem (1-port) converter detected
usb 2-2: GSM modem (1-port) converter now attached to ttyUSB2
usbcore: registered new interface driver option
option: v0.7.2:USB Driver for GSM modems
usb-storage: device scan complete
scsi 5:0:0:0: Direct-Access     ZTE      MMC Storage      322  PQ: 0 ANSI: 2
sd 5:0:0:0: Attached scsi generic sg1 type 0
sd 5:0:0:0: [sdb] Attached SCSI removable disk

The device shows up under "Mobile broadband" now :)

I actually have two modems on this box: the zte modem as a usb stick and the built-in modem (bug 533266). Both show up now.

Clicking on the zte modem gives me a connection failed message, but that's probably my network manager config. I will test more soon, hopefully tomorrow.

Versions:
 kernel 2.6.31.9-174.fc12.x86_64
 ModemManager-0.2.997-5.git20100101.fc12
 NetworkManager-vpnc-0.7.996-4.git20090921.fc12.x86_64
 NetworkManager-gnome-0.7.997-2.git20091214.fc12.x86_64
 NetworkManager-0.7.997-2.git20091214.fc12.x86_64
 NetworkManager-pptp-0.7.996-4.git20090921.fc12.x86_64
 NetworkManager-openvpn-0.7.996-4.git20090923.fc12.x86_64
 NetworkManager-glib-0.7.997-2.git20091214.fc12.x86_64
Comment 25 Fedora Update System 2010-01-02 19:43:30 EST
ModemManager-0.2.997-5.git20100101.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/ModemManager-0.2.997-5.git20100101.fc12
Comment 26 Fedora Update System 2010-01-03 16:02:54 EST
ModemManager-0.2.997-5.git20100101.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ModemManager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-0121
Comment 27 Need Real Name 2010-01-03 16:08:23 EST
For this to work out of the box, something needs to call usb_modeswitch. Is this planned?
Comment 28 Dan Williams 2010-01-18 17:06:29 EST
(In reply to comment #27)
> For this to work out of the box, something needs to call usb_modeswitch. Is
> this planned?    

Upstream usb_modeswitch now has nicely generated udev rules files to automatically switch any known devices.  So that would be handled by the usb_modeswitch package.
Comment 29 Dan Williams 2010-01-18 17:07:06 EST
*** Bug 545638 has been marked as a duplicate of this bug. ***
Comment 30 Fedora Update System 2010-01-19 18:36:12 EST
ModemManager-0.3-1.git20100119.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/ModemManager-0.3-1.git20100119.fc12
Comment 31 Fedora Update System 2010-01-20 19:10:19 EST
ModemManager-0.3-1.git20100119.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ModemManager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-0847
Comment 32 Jhonny Oliveira 2010-02-02 13:24:51 EST
OK, I just couldn't wait for modemmanager to come out as a stable update. I've updated as described in the previous comment (31), and now my GSM modem ZTE MF636 is being recognized as it should. I've only noticed that, after ejecting, it takes a little longer to become available in NetworkManager than my previous GSM modems.

As for having to "eject" the device in order to have it recognized as a modem, I don't see much of an issue in here, actually the device is also a mass-store device...
Comment 33 Fedora Update System 2010-02-05 19:07:32 EST
ModemManager-0.3-1.git20100119.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 34 Need Real Name 2010-02-15 16:53:37 EST
Just to add my 2 cents.. this works! But ejecting doesn't make it work, I have to run usb_modeset manually, which means it doesn't work out of the box :/
Comment 35 Dan Williams 2010-02-15 21:37:32 EST
(In reply to comment #34)
> Just to add my 2 cents.. this works! But ejecting doesn't make it work, I have
> to run usb_modeset manually, which means it doesn't work out of the box :/    

Interesting; my MF626 and MF622 work with a simple eject, but never assume that things will stay the same :)   Thanks for testing!
Comment 36 Alfredo Ferrari 2010-03-02 16:11:24 EST
I have a ZTE MF636, vedor=19d2, product=0033. It doesn't show up in NetworkManager with Fedora 12 fully up-to-date as of today (March 2nd). My vendor/product id does not show up both in /etc/usb_modeswitch or in
/lib/udev/rules.d/61-option-modem-modeswitch.rules. I set up usb_modeswitch so as to switch the device and /dev/ttyUSB0-3 appear, however NetworkManager stubbornly refuses to "see" the device whatever I do. Please note that this is a MF636 with id 0033. I would appreciate any hint, please let me know which further useful infos/logs I can provide
Comment 37 Dipak Dudhabhate 2010-04-20 01:55:26 EDT
I am also not able to use USB modem from Huawei. It is a Huawei EC1261 HSIA device.

Following are the o/p of dmesg after device put in port

#dmesg
usb 2-2: USB disconnect, address 3
usb 2-2: new full speed USB device using uhci_hcd and address 4
usb 2-2: New USB device found, idVendor=12d1, idProduct=1446
usb 2-2: New USB device strings: Mfr=1, Product=2, SerialNumber=4
usb 2-2: Product: HUAWEI Mobile
usb 2-2: Manufacturer: HUAÿWEI TECHNOLOGIES
usb 2-2: SerialNumber: ÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿ
usb 2-2: configuration #1 chosen from 1 choice
scsi6 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 4
usb-storage: waiting for device to settle before scanning
usb-storage: device scan complete
scsi 6:0:0:0: CD-ROM            HUAWEI   Mass Storage     2.31 PQ: 0 ANSI: 0
sr2: scsi-1 drive
sr 6:0:0:0: Attached scsi CD-ROM sr2
sr 6:0:0:0: Attached scsi generic sg2 type 5
ISO 9660 Extensions: Microsoft Joliet Level 1
ISOFS: changing to secondary root
SELinux: initialized (dev sr2, type iso9660), uses genfs_contexts


and o/p after #modprobe usbserial vendor=0x12d1 product=0x1446

it runs successfully and then

# wvdialconf 
Editing `/etc/wvdial.conf'.

Scanning your serial ports for a modem.

ttyS0<*1>: ATQ0 V1 E1 -- failed with 2400 baud, next try: 9600 baud
ttyS0<*1>: ATQ0 V1 E1 -- failed with 9600 baud, next try: 115200 baud
ttyS0<*1>: ATQ0 V1 E1 -- and failed too at 115200, giving up.
Modem Port Scan<*1>: S1   S2   S3   


Sorry, no modem was detected!  Is it in use by another program?
Did you configure it properly with setserial?

Please read the FAQ at http://open.nit.ca/wiki/?WvDial

If you still have problems, send mail to <wvdial-list@lists.nit.ca>.

Note You need to log in before you can comment on or make changes to this bug.