Bug 515667 - login.defs/SYS_UID_MIN should be 200
login.defs/SYS_UID_MIN should be 200
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: shadow-utils (Show other bugs)
11
All Linux
high Severity medium
: ---
: ---
Assigned To: Peter Vrabec
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-05 05:56 EDT by Mark McLoughlin
Modified: 2009-08-12 16:53 EDT (History)
4 users (show)

See Also:
Fixed In Version: 4.1.4.1-5.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 515779 (view as bug list)
Environment:
Last Closed: 2009-08-12 16:53:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mark McLoughlin 2009-08-05 05:56:15 EDT
Since setup-2.8.7, the 100-200 range is used for uidgid reservations and 107 is reserved for qemu. See:

  * Tue Jul 21 2009 Ondrej Vasik <ovasik@redhat.com> 2.8.7-1
  - increase threshold for uidgid reservations to 200
  - reserve uidgid pair 107:107 for qemu (libvirt,#511957)
  - reflect threshold in profile and bashrc, do inform about
    uidgid file existence there

However, 'useradd -r' and 'groupadd -r' still allocate out of the 100-500 range.

We have a report of openvpn using gid 107 on a tester's system.
Comment 1 Fedora Update System 2009-08-05 10:17:59 EDT
shadow-utils-4.1.4.1-5.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/shadow-utils-4.1.4.1-5.fc11
Comment 2 Mark McLoughlin 2009-08-05 13:34:41 EDT
Removing from F12VirtTarget; using bug #515779 for F-12 tracking
Comment 3 Fedora Update System 2009-08-07 00:54:28 EDT
shadow-utils-4.1.4.1-5.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update shadow-utils'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-8306
Comment 4 Fedora Update System 2009-08-12 16:52:41 EDT
shadow-utils-4.1.4.1-5.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.