Bug 515779 - login.defs/SYS_UID_MIN should be 200
Summary: login.defs/SYS_UID_MIN should be 200
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: shadow-utils (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
high
medium
Target Milestone: ---
Assignee: Peter Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On: F12VirtBlocker
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-05 17:33 UTC by Mark McLoughlin
Modified: 2009-08-07 15:22 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 515667
Environment:
Last Closed: 2009-08-07 15:22:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mark McLoughlin 2009-08-05 17:33:57 UTC
+++ This bug was initially created as a clone of Bug #515667 +++

Since setup-2.8.7, the 100-200 range is used for uidgid reservations and 107 is reserved for qemu. See:

  * Tue Jul 21 2009 Ondrej Vasik <ovasik@redhat.com> 2.8.7-1
  - increase threshold for uidgid reservations to 200
  - reserve uidgid pair 107:107 for qemu (libvirt,#511957)
  - reflect threshold in profile and bashrc, do inform about
    uidgid file existence there

However, 'useradd -r' and 'groupadd -r' still allocate out of the 100-500 range.

We have a report of openvpn using gid 107 on a tester's system.

Fixed by:

* Wed Aug 05 2009 Peter Vrabec <pvrabec@redhat.com> 2:4.1.4.1-6
- increase threshold for uid/gid reservations to 200 (#515667)

Comment 1 Mark McLoughlin 2009-08-07 15:22:58 UTC
Tagged in f12-alpha now

https://fedorahosted.org/rel-eng/ticket/2053


Note You need to log in before you can comment on or make changes to this bug.