Bug 51567 - gcc 2.96-85 cannot compile the regex part of the boost library
gcc 2.96-85 cannot compile the regex part of the boost library
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
:
: 63960 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-12 09:25 EDT by Peter Klotz
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-05 14:45:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cregex.ii as requested (88.76 KB, application/octet-stream)
2001-08-17 17:51 EDT, Peter Klotz
no flags Details

  None (edit)
Description Peter Klotz 2001-08-12 09:25:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.8 i686)

Description of problem:
gcc 2.96-85 reports an internal compiler error when executing the command
make -f gcc.mak in order to compile the regex part of the boost C++ library
1.23.0 (www.boost.org).

How reproducible:
Always

Steps to Reproduce:
1.extract boost_1_23_0.tar.gz
2.go to the directory boost_1_23_0/libs/regex/build
3.execute the command make -f gcc.mak
	

Actual Results:  [root@localhost build]# make -f gcc.mak
g++  -o gcc/boost_regex/c_regex_traits.o -c -O2
-I/root/software/stlport/STLport-4.5b8/stlport -I../../../ 
../src/c_regex_traits.cpp
g++  -o gcc/boost_regex/c_regex_traits_common.o -c -O2
-I/root/software/stlport/STLport-4.5b8/stlport -I../../../ 
../src/c_regex_traits_common.cpp
g++  -o gcc/boost_regex/cpp_regex_traits.o -c -O2
-I/root/software/stlport/STLport-4.5b8/stlport -I../../../ 
../src/cpp_regex_traits.cpp
g++  -o gcc/boost_regex/cregex.o -c -O2
-I/root/software/stlport/STLport-4.5b8/stlport -I../../../ 
../src/cregex.cpp
../../../boost/regex.hpp: In function `iterator
boost::re_detail::re_is_set_member (iterator, iterator,
boost::re_detail::re_set_long *, const boost::reg_expression<charT,
traits_type, Allocator> &) [with iterator =
boost::re_detail::mapfile_iterator, charT = char, traits_type =
boost::regex_traits<char>, Allocator =
boost::re_detail::jm_def_alloc]':
../../../boost/regex/detail/regex_match.hpp:545:   instantiated from
`boost::re_detail::query_match_aux (iterator, iterator,
boost::match_results<iterator, Allocator> &, const
boost::reg_expression<charT, traits, Allocator2> &, unsigned int,
boost::re_detail::_priv_match_data<iterator, Allocator> &, iterator *)
[with iterator = boost::re_detail::mapfile_iterator, Allocator =
boost::re_detail::jm_def_alloc, charT = char, traits =
boost::regex_traits<char>, Allocator2 = boost::re_detail::jm_def_alloc]'
../../../boost/regex/detail/regex_match.hpp:1093:   instantiated from
`boost::re_detail::reg_grep2 (Predicate, I, I, const
boost::reg_expression<charT, traits,
Allocator2> &, unsigned int, A2) [with Predicate = boost::re_detail::pred4,
I = boost::re_detail::mapfile_iterator, charT = char, traits =
boost::regex_traits<char>, A = boost::re_detail::jm_def_alloc, A2 =
boost::re_detail::jm_def_alloc]'
../../../boost/regex/detail/regex_match.hpp:1752:   instantiated from
`boost::regex_grep (Predicate, iterator, iterator, const
boost::reg_expression<charT, traits, Allocator2> &, unsigned int) [with
Predicate = boost::re_detail::pred4, iterator =
boost::re_detail::mapfile_iterator, charT = char, traits =
boost::regex_traits<char>, Allocator = boost::re_detail::jm_def_alloc]'
../src/cregex.cpp:383:   instantiated from here
../../../boost/regex.hpp:241: Internal compiler error in scan_region,
at except.c:2809
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make: *** [gcc/boost_regex/cregex.o]Error 1

Additional info:
Comment 1 Jakub Jelinek 2001-08-17 15:13:33 EDT
Can you provide a preprocessed testcase (ie. add -save-temps and attach here
cregex.ii)?
Comment 2 Peter Klotz 2001-08-17 17:51:35 EDT
Created attachment 28353 [details]
cregex.ii as requested
Comment 3 Peter Klotz 2001-08-17 17:59:55 EDT
In the initial bug report I used STLport 4.5b8 (www.stlport.org) to compile 
the regex library but the Internal Compiler Error also occurs if the 
preinstalled GNU STL is used instead.
Comment 4 Jakub Jelinek 2001-08-23 10:06:35 EDT
Should be fixed in gcc-c++-2.96-97.
Comment 5 Jakub Jelinek 2002-04-23 05:35:31 EDT
*** Bug 63960 has been marked as a duplicate of this bug. ***
Comment 6 Vladimir Makarov 2004-10-05 14:45:56 EDT
gcc-2.96 is too old.  Its release cycle was finished long ago.  Also
Jakub wrote about fixing the bug in gcc-2.96-97.  Therefore I am
closing the case.  If  it is still important we could reopen it.

Note You need to log in before you can comment on or make changes to this bug.