Bug 63960 - Compiling boost regex packages crashes compiler
Compiling boost regex packages crashes compiler
Status: CLOSED DUPLICATE of bug 51567
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-04-22 14:37 EDT by Richard Munroe
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-22 14:37:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Munroe 2002-04-22 14:37:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9.4) Gecko/20011130
Netscape6/6.2.1

Description of problem:
[root@linux build]# make -fgcc.mak
mkdir -p gcc
mkdir -p gcc/boost_regex
g++  -o gcc/boost_regex/c_regex_traits.o -c -O2 -I../../../ 
../src/c_regex_traits.cpp
g++  -o gcc/boost_regex/c_regex_traits_common.o -c -O2 -I../../../ 
../src/c_regex_traits_common.cpp
g++  -o gcc/boost_regex/cpp_regex_traits.o -c -O2 -I../../../ 
../src/cpp_regex_traits.cpp
g++  -o gcc/boost_regex/cregex.o -c -O2 -I../../../  ../src/cregex.cpp
../../../boost/regex.hpp: In function `iterator 
boost::re_detail::re_is_set_member (iterator, iterator, const 
boost::re_detail::re_set_long *, const boost::reg_expression<charT, 
traits_type, Allocator> &) [with iterator = 
boost::re_detail::mapfile_iterator, charT = char, traits_type = 
boost::regex_traits<char>, Allocator = allocator<char>]':
../../../boost/regex/detail/regex_match.hpp:600:   instantiated from
`boost::re_detail::query_match_aux (iterator, iterator,
boost::match_results<iterator, Allocator> &, const boost::reg_expression<charT,
traits, Allocator2> &, unsigned int,
boost::re_detail::_priv_match_data<iterator, Allocator> &, iterator *) [with
iterator = boost::re_detail::mapfile_iterator, Allocator = allocator<char>,
charT = char, traits = boost::regex_traits<char>, Allocator2 = allocator<char>]'
../../../boost/regex/detail/regex_match.hpp:1177:   instantiated from
`boost::re_detail::reg_grep2 (Predicate, I, I, const
boost::reg_expression<charT, traits, Allocator2> &, unsigned int, A2) [with
Predicate = boost::re_detail::pred4, I = boost::re_detail::mapfile_iterator,
charT = char, traits = boost::regex_traits<char>, A = allocator<char>, A2 =
allocator<char>]'
../../../boost/regex/detail/regex_match.hpp:1836:   instantiated from
`boost::regex_grep (Predicate, iterator, iterator, const
boost::reg_expression<charT, traits, Allocator2> &, unsigned int) [with
Predicate = boost::re_detail::pred4, iterator =
boost::re_detail::mapfile_iterator, charT = char, traits =
boost::regex_traits<char>, Allocator = allocator<char>]'
../src/cregex.cpp:387:   instantiated from here
../../../boost/regex.hpp:244: Internal compiler error in scan_region, 
at except.c:2809
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make: *** [gcc/boost_regex/cregex.o] Error 1
[root@linux build]# g++ -v
Reading specs from /usr/lib/gcc-lib/i386-redhat-linux/2.96/specs
gcc version 2.96 20000731 (Red Hat Linux 7.1 2.96-85)
[root@linux build]# 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. See description, above.
2.
3.
	

Expected Results:  The package should have compiled correctly.

Additional info:

The boost package being compiled is in the boost 1.27.0 release.
Comment 1 Jakub Jelinek 2002-04-23 05:35:36 EDT
gcc-2.96-85 is way too old.
Upgrade to at least RHL 7.2's gcc or even better some more recent one
(like gcc-2.96-110).

*** This bug has been marked as a duplicate of 51567 ***

Note You need to log in before you can comment on or make changes to this bug.