Bug 515819 - Root password textbox no longer has default focus
Root password textbox no longer has default focus
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
: 516876 (view as bug list)
Depends On:
Blocks: AnacondaUI
  Show dependency treegraph
 
Reported: 2009-08-05 15:58 EDT by James Laska
Modified: 2013-09-02 02:37 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-23 14:17:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Laska 2009-08-05 15:58:56 EDT
Description of problem:

When entering step rootpw, the password textbox no longer has focus.  

Have the fixes for git commit a177c85ddf988e813b3d56ce05ca631ef328c234 been reverted or do they no longer apply?

Version-Release number of selected component (if applicable):

 * anaconda-12.7

How reproducible:

 * Seems every time, virt, bare-metal etc...

Steps to Reproduce:
1. Proceed through a normal installation, accepting all defaults

Actual results:

 * Upon entering the root password step, the first password text-box does not have focus.

Expected results:

 * The first password text-box has focus, and the user can begin typing the password upon entering that step in anaconda

Additional info:

 * I wouldn't normally file this, only it seems there was intent to correct this behavior recently.  If this is no longer the expectation upon entering that screen, that's okay.
Comment 1 Radek Vykydal 2009-08-06 04:11:54 EDT
See also similar
https://bugzilla.redhat.com/show_bug.cgi?id=494135#c8
concerning hostname entry focus which has probably the same cause. The focus worked well in F11 (both for hostname with patch in the before-mentioned bug, and for password entry).
Comment 2 Andy Lindeberg 2009-08-06 10:40:48 EDT
Radek: The hostname focus might be correct in being on the Next button. Since it is possible to use what is already provided, it's good default-user-UI to allow pressing enter to continue.
Comment 3 Radek Vykydal 2009-08-07 05:10:35 EDT
Andy, first, the change of behaviour is not intentional, and not by change in code (which is to have focus on entry box), it just happened (entry box stopped to be receiving map-event which trigger grabbing of focus for some reason) after f11. Second, I think that you don't have password provided usually, so it is better to have focus on entry and allow to enter it just by starting to type (without having to change the focus with Tab). If you have password provided (interactive mode, going back), you just press Enter two times which is ok.
Comment 4 Andy Lindeberg 2009-08-11 14:52:50 EDT
*** Bug 516876 has been marked as a duplicate of this bug. ***
Comment 5 Andy Lindeberg 2009-08-11 14:54:17 EDT
Yes, for the password screen, focus should be on the text box. But the hostname screen provides a default that will work for a default user, and the focus there is fine being on the Next button.
Comment 6 Radek Vykydal 2009-08-21 05:32:28 EDT
(In reply to comment #5)
Sorry for my bad reading - you were talking about hostname, not password in comment #2. For the hostname, pressing enter will continue even with focus on entry box.

Chris has pushed a patch (3e102bc0a7ffd3ca4eb5cff354688732f443f872) which should fix this bug. It will go in anaconda 12.17.
Comment 7 Bug Zapper 2009-11-16 06:16:04 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.