Bug 494135 - hostname dialog in graphical install does not activate with <Enter>
hostname dialog in graphical install does not activate with <Enter>
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
: Reopened
: 504993 507027 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-04 18:34 EDT by John Reiser
Modified: 2010-02-23 13:46 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-23 13:46:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2009-04-04 18:34:45 EDT
Description of problem: In graphical install, the dialog box for setting hostname ("Please name this computer..." [default localhost.localdomain]) does not activate upon <Enter>; the Next button must be pressed.  This is irksome and inconsistent with other install dialogs.  For instance, <Enter> does activate the dialog for setting root password.


Version-Release number of selected component (if applicable):
anaconda-11.5.0.40

How reproducible: always


Steps to Reproduce:
1. interactive graphical install from DVD
2.
3.
  
Actual results: Activating the dialog for setting the hostname ("Please name this computer...") requires [Next] button; keyboard <Enter> is not good enough.


Expected results: <Enter> should activate any dialog that already contains enough user-supplied information.


Additional info:
Comment 1 David Cantrell 2009-05-05 20:44:57 EDT
Good point.  It annoys me to and I redid that screen in anaconda in the first place.  :)

How about this:

@@ -42,6 +42,9 @@ class NetworkWindow(InstallWindow):
         self.icon = self.xml.get_widget("icon")
         self.hostnameEntry = self.xml.get_widget("hostnameEntry")
         self.hostnameEntry.set_text(self.hostname)
+        self.hostnameEntry.connect("activate",
+                                   lambda w: self.ics.setGrabNext(1))
+        self.hostnameEntry.grab_focus()
 
         # load the icon
         gui.readImageFromFile("network.png", image=self.icon)

The hostname entry field will have focus when you get to that screen, rather than the Next button.  You can type over the hostname or just accept the default by pressing Enter.  Pressing Enter in the entry field will advance you to the ever fun and ever changing timezone selection map.
Comment 2 David Cantrell 2009-05-06 14:30:44 EDT
Will be fixed in anaconda-11.5.0.50-1.fc11 and later.
Comment 3 John Reiser 2009-06-23 10:31:24 EDT
In Fedora 11 release anaconda-11.5.0.59, the graphical hostname dialog now activates on <Enter>.  Thank you.

However, keyboard focus was lost!  The "localhost.localdomain" has light-gray reverse video instead of light-blue reverse video.  Thus I must re-establish keyboard focus, such as with mouse Button1 (or perhaps some <Tab>s) before I can activate or replace the default.

Please restore default keyboard focus (and including default selection of entire default "localhost.localdomain"), so that all I have to do is type "myhost.mydomain" followed by <Enter> in order to specify the hostname.
Comment 4 Chris Lumens 2009-06-29 10:01:34 EDT
*** Bug 507027 has been marked as a duplicate of this bug. ***
Comment 5 David Cantrell 2009-06-30 17:21:32 EDT
*** Bug 504993 has been marked as a duplicate of this bug. ***
Comment 6 Radek Vykydal 2009-07-20 07:52:59 EDT
This should be fixed in version 12.0-1 of anaconda.
Thanks for the bug report.
Comment 7 John Reiser 2009-07-21 16:40:48 EDT
The problem persists in today's boot.iso for i386 (206569472 bytes, md5sum f066e89053884caa46981b6012bda2ff).  Namely: in the graphical hostname dialog the input field does not have keyboard focus, and the default text "localhost.localdomain" is not selected (which would be indicated using reverse video with blue background.)  Instead, it is necessary to type one <Tab>; then everything is just the way it should have been to start with (the input field has focus, the default text is selected and highlighted with blue reverse video.)

The same problem is present in the graphcial dialog to set the initial root password.  No input field has keyboard focus, but typing a <Tab> gives focus to the first input field.  Please set the keyboard focus to the first input field.  PLEASE?

Anaconda announces itself as version "12.3" which seems to be later than "12.0-1".  "Rawhide report: 20090721 changes" says:

   anaconda-12.3-1.fc12
   --------------------
   * Mon Jul 20 2009 David Cantrell <dcantrell@redhat.com> - 12.3-1
Comment 8 Radek Vykydal 2009-07-23 15:29:59 EDT
I was able to test the patch only with f11 where it worked. Now in rawhide (12.3) I can see that the entry widget stopped receiving map-event signal so the callback to grab focus is not called. This is also why password entry behaviour (not changed in this bug fix) broke. There are some other X or wm oddities in 12.3, so I'd wait a bit if their eventual general fix will bring the fix back.
Comment 9 Radek Vykydal 2009-08-21 05:32:14 EDT
Chris has pushed a patch (3e102bc0a7ffd3ca4eb5cff354688732f443f872) which should fix this bug. It will go in anaconda 12.17.

Note You need to log in before you can comment on or make changes to this bug.