Bug 515906 - 'Edit' fails
'Edit' fails
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
: 517242 (view as bug list)
Depends On: 517257
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-06 06:50 EDT by Tim Waugh
Modified: 2009-08-14 15:03 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-14 15:03:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2009-08-06 06:50:56 EDT
Description of problem:
Selecting an interface and clicking 'Edit' has no visible effect.

.xsession-errors contains:
** (nm-connection-editor:1546): WARNING **: Caught error: Method "ObtainAuthorization" with signature "suu" on interface "org.freedesktop.PolicyKit.AuthenticationAgent" doesn't exist

Version-Release number of selected component (if applicable):
NetworkManager-gnome-0.7.995-1.git20090804.fc12.x86_64
PolicyKit-0.9-6.fc11.x86_64

How reproducible:
100%

Steps to Reproduce:
1.System->Preferences->Network Connections
2.Select 'System eth0'
3.Click Edit
Comment 1 Adam Williamson 2009-08-11 23:04:23 EDT
Works fine here, but Jonathan Kamens confirms this report on test-list. Not sure what's going on there. Same versions of NM and PK here.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Tim Waugh 2009-08-12 06:23:56 EDT
How about:

polkit-0.93-3.fc12.x86_64
Comment 3 Tim Waugh 2009-08-12 08:00:53 EDT
This is with a fresh install, and has been verified twice now: first in a virtual kvm instance and now on bare metal.
Comment 4 Adam Williamson 2009-08-12 14:34:45 EDT
same polkit package here too. :/ not disputing the veracity of the report, just wondering what factor makes it work on my lived-in system and not your  fresh one.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Kjartan Maraas 2009-08-13 05:33:46 EDT
I'm seeing the same here and my system has been upgraded via yum update through several development cycles now.
Comment 6 Kjartan Maraas 2009-08-13 05:35:13 EDT
[kmaraas@nc6400 gtk+]$ rpm -q polkit
polkit-0.93-3.fc12.i686
[kmaraas@nc6400 gtk+]$ rpm -q polkit-gnome
polkit-gnome-0.93-3.fc12.i686
Comment 7 Niels Haase 2009-08-13 06:48:05 EDT
*** Bug 517242 has been marked as a duplicate of this bug. ***
Comment 8 J. Randall Owens 2009-08-13 17:28:05 EDT
Same polkits with the Test Day image, and might be worth mentioning, there's also a lack of anything happening and the same .xsession-errors message when clicking "Delete".
Comment 9 Dan Williams 2009-08-14 15:02:15 EDT
Turns out this is due to dbus-glib 0.82 changing behavior, causing things that use PolicyKit-gnome to fail to authenticate.  Fixed in:

http://koji.fedoraproject.org/koji/buildinfo?buildID=127293
Comment 10 Dan Williams 2009-08-14 15:03:54 EDT
See https://fedorahosted.org/rel-eng/ticket/2119 for status of tagging this update into rawhide.

Note You need to log in before you can comment on or make changes to this bug.