Bug 51604 - Multiple owned files
Summary: Multiple owned files
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ircii   
(Show other bugs)
Version: 7.3
Hardware: i386
OS: Linux
high
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 51582
TreeView+ depends on / blocked
 
Reported: 2001-08-12 20:28 UTC by Peter Bowen
Modified: 2007-03-27 03:47 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-13 19:07:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Peter Bowen 2001-08-12 20:28:36 UTC
This file is owned by two packages.  Only one of them should own it.

/usr/share/pixmaps/gnome-irc.png (one of ['gnome-core', 'ircii'] should own
it, but they all do currently)

Comment 1 Havoc Pennington 2001-08-13 16:23:38 UTC
Simplest short-term solution is probably "ircii requires gnome-core and owned by
gnome-core"

Comment 2 Peter Bowen 2001-08-13 17:31:36 UTC
This would be bad, IMO.  ircii is a purely command line client that has no deps
on X or GNOME.  I would suggest that ircii should not own this file, as it seems
to be a generic gnome icon for IRC programs.  I am going to reassign it to ircii
so that the maintainer can drop this file from the package.

Comment 3 Havoc Pennington 2001-08-13 17:48:36 UTC
If ircii uses the icon, but doesn't contain the icon, it must depend on the
package which does contain the icon, which is gnome-core. If ircii doesn't
depend on gnome-core, then it will have to own this icon, but then gnome-core
would depend on ircii, which is even worse than the other way around.

The real solution is to rename or eliminate all uses of the icon in one of the
packages, but that's a more elaborate solution than I want to do in a Red Hat
patch especially at this point in the release cycle.

Comment 4 Sean Dilda 2001-08-13 18:12:51 UTC
Actually, I recommend that patch, as it would be a zero-line patch.  ircii is a
text program that does not use the png file.  The png file is only used by gnome
to represent ircii, but ircii doesn't actually use the png file itself.

It looks like the real solution is to just remove the icon from ircii.

Comment 5 Havoc Pennington 2001-08-13 19:03:56 UTC
If ircii only uses the icon for a .desktop file, then it's probably no big deal
if the icon doesn't exist (gnome-core isn't installed). So fair enough, let's
just remove the icon from ircii. 



Comment 6 Glen Foster 2001-08-13 19:07:18 UTC
We (Red Hat) should really try to fix this before next release.

Comment 7 Preston Brown 2001-08-13 20:18:35 UTC
not packaged in 4.4Z-7 and later.



Note You need to log in before you can comment on or make changes to this bug.