Bug 51582 - Many files are owned by multiple packages
Summary: Many files are owned by multiple packages
Status: CLOSED DUPLICATE of bug 62759
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: basesystem (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On: 51581 51584 51586 51587 51589 51590 51591 51592 51594 51595 51597 51598 51599 51600 51601 51602 51603 51604 51605 51606 51607 52003 52004 53014 53015
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-12 18:26 UTC by Peter Bowen
Modified: 2014-03-17 02:22 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-05 05:50:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Python script that checks for ownership problems (7.34 KB, text/plain)
2001-08-12 18:42 UTC, Peter Bowen
no flags Details
Complete list of files owned by more than one RPM in beta3 (19.07 KB, text/plain)
2001-08-12 18:45 UTC, Peter Bowen
no flags Details
Stripped down script that only looks for duplicate files (5.72 KB, text/plain)
2001-09-01 20:59 UTC, Peter Bowen
no flags Details

Description Peter Bowen 2001-08-12 18:26:56 UTC
I'm opening this to be a tracking bug for all the other bugs filed because
of the a test program that I wrote to do certain checks on the RPM
database.  I appologize to the owner of the basesystem component, but I
didn't have a better place to but this bug.

Comment 1 Peter Bowen 2001-08-12 18:42:24 UTC
Created attachment 27455 [details]
Python script that checks for ownership problems

Comment 2 Peter Bowen 2001-08-12 18:45:00 UTC
Created attachment 27456 [details]
Complete list of files owned by more than one RPM in beta3

Comment 3 Bill Nottingham 2001-08-13 04:34:06 UTC
FWIW, it's not necessarily a bug for a file to be owned by multiple packages.

Comment 4 Peter Bowen 2001-08-13 14:50:58 UTC
I am aware that it is not a bug for a file to be owned by multiple packages. I
only filed bugs against those packages which I thought were incorrect.  The ones
that are not problems are:

kernel and kernel-BOOT sharing /sbin/installkernel
Any of the XFree86 3.3.6 ones

Additionally, I have been told that the /etc/rc?.d symlinks are supposed to be
owned by two packages.  But I think that most of these are caused by simple spec
file errors.

Comment 5 Bill Nottingham 2001-08-13 14:52:20 UTC
Actually, /sbin/installkernel being multiply owned by the kernel packages is
a bug. :)  We need to find somewhere else to put it....

Comment 6 Peter Bowen 2001-08-13 15:13:42 UTC
When I talked to Arjan over the weekend, he said that it wasn't a bug.  Can you
open another bug on this issue and make it block this one, if you want it fixed?
This bug has too many deps to make adding comments a pleasant task :(

Comment 7 Mike A. Harris 2001-08-19 22:57:20 UTC
The XFree86 bug report was NOTABUG.  The manpages are included in
each package to which they have relevance.  There is no requirement
for installing all servers, so if the page is only included in a single
package, then if the other package is installed, you don't have the
matching manpage.  That is why the manpages are included in each
subpackage that is relevant.

Comment 8 Peter Bowen 2001-09-01 20:55:08 UTC
About half of these have been fixed as of RC2.  It would be very nice if all
these could be fixed before release.  I am attaching a stripped down script that
will quickly find these bugs so that there will not be more of these bugs in the
future.

Comment 9 Peter Bowen 2001-09-01 20:59:35 UTC
Created attachment 30556 [details]
Stripped down script that only looks for duplicate files

Comment 10 Peter Bowen 2002-04-06 16:49:49 UTC
Marking duplicate of 62759 with is for Hampton.  This was for Fairfax bugs.

*** This bug has been marked as a duplicate of 62759 ***


Note You need to log in before you can comment on or make changes to this bug.