Bug 51621 - smb printers, very confusing setup
smb printers, very confusing setup
Status: CLOSED DUPLICATE of bug 43905
Product: Red Hat Linux
Classification: Retired
Component: printconf (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2001-08-13 04:44 EDT by giulioo
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-12-18 18:08:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description giulioo 2001-08-13 04:44:05 EDT
Description of problem:
The setup of smb printers seems to be very counter-intuitive, and prone to 

How reproducible:

Steps to Reproduce:
Use printconf from within gnome to setup an smb printer.
Wizard asks for "share"; until now, everytime I've heard "share" I thought 
to the printer share, so I typed it, wondering where I could insert the 
netbios name of the windows pc....

Actual Results:
Printer does not work, because for "share" the wizard wants this:
This is the only way I could make it work after looking at 
what /usr/share/printconf/util/smbprint does.
I think noone will use the correct syntax at the first try.

Expected Results:
Wizard should have 2 fields:
Netbios name of the pc:
Netbios name of the printer share:
and use this info to build the correct syntax

Additional info:

smbprint uses -N which means "no password", but it uses the password if 
you type it. I don't know if this may cause further problems.

Maybe consider the syntax
where if variables are blank it's considered an anonymous login.
Comment 1 Tim Waugh 2002-01-10 07:56:18 EST
This seems to be a duplicate of bug #43905.

*** This bug has been marked as a duplicate of 43905 ***

Note You need to log in before you can comment on or make changes to this bug.