Bug 516225 - metacity fullscreens all windows in Sugar
metacity fullscreens all windows in Sugar
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Søren Sandmann Pedersen
Fedora Extras Quality Assurance
:
: 510910 (view as bug list)
Depends On:
Blocks: FedoraOnXO
  Show dependency treegraph
 
Reported: 2009-08-07 10:51 EDT by Tomeu Vizoso
Modified: 2014-06-18 05:11 EDT (History)
6 users (show)

See Also:
Fixed In Version: metacity-2.27.0-9.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 16:32:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 586600 None None None Never

  None (edit)
Description Tomeu Vizoso 2009-08-07 10:51:45 EDT
Sugar activities run as windows covering the whole screen, without decorations. Metacity tries to workaround old clients that don't know how to request fullscreen by fullscreen'ing these windows automatically. This is bad for Sugar activities because they want to be fullscreened only when they request so.

Upstream has accepted a patch that adds a command line switch to disable this workaround, but no release has happened as of yet, and we would like to start testing the next version of Sugar on Rawhide, which will use metacity.

Can we get a new metacity build including this patch?

http://git.gnome.org/cgit/metacity/commit/?id=b625ec30d99b

Thanks!
Comment 1 Tomeu Vizoso 2009-08-27 04:26:30 EDT
Ping, we cannot test sugar on rawhide because of this, could the patch be added while we wait for upstream to do a new tarball? I have already pinged the maintainer without success.
Comment 2 Peter Robinson 2009-08-27 05:36:50 EDT
Matthias, can you possibly help with this or is it OK if I commit this?
Comment 3 Peter Robinson 2009-09-02 16:32:47 EDT
Commited to rawhide as metacity-2.27.0-9.fc12
Comment 4 Simon Schampijer 2009-09-02 17:49:07 EDT
Awesome! Thanks very very much!
Comment 5 Peter Robinson 2009-09-06 12:26:54 EDT
*** Bug 510910 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.