This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 516378 - rpmlint still gives errors like "no-buildroot-tag"
rpmlint still gives errors like "no-buildroot-tag"
Status: CLOSED DUPLICATE of bug 515185
Product: Fedora
Classification: Fedora
Component: rpmlint (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Ville Skyttä
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-09 02:47 EDT by Ankur Sinha (FranciscoD)
Modified: 2009-08-09 05:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-09 05:05:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ankur Sinha (FranciscoD) 2009-08-09 02:47:19 EDT
User-Agent:       Opera/9.80 (X11; Linux x86_64; U; en) Presto/2.2.15 Version/10.00

with reference to https://fedoraproject.org/wiki/Packaging/Guidelines#BuildRoot_tag ,

rpmlint should not be showing errors.

Reproducible: Always

Steps to Reproduce:
1. make a spec
2. do not add the lines as per above mentioned link
3. run rpmlint on the spec and src rpms etc
Actual Results:  
fupt.spec: E: no-cleaning-of-buildroot %install
You should clean $RPM_BUILD_ROOT in the %clean section and just after the
beginning of %install section. Use "rm -Rf $RPM_BUILD_ROOT".

fupt.spec: E: no-buildroot-tag
The BuildRoot tag isn't used in your spec. It must be used in order to allow
building the package as non root on some systems.

fupt.src: E: no-cleaning-of-buildroot %install
You should clean $RPM_BUILD_ROOT in the %clean section and just after the
beginning of %install section. Use "rm -Rf $RPM_BUILD_ROOT".

fupt.src: E: no-buildroot-tag
The BuildRoot tag isn't used in your spec. It must be used in order to allow
building the package as non root on some systems.


fupt.src: E: no-cleaning-of-buildroot %install
You should clean $RPM_BUILD_ROOT in the %clean section and just after the
beginning of %install section. Use "rm -Rf $RPM_BUILD_ROOT".

fupt.src: E: no-buildroot-tag
The BuildRoot tag isn't used in your spec. It must be used in order to allow
building the package as non root on some systems.


Expected Results:  
no errors should be there.
Comment 1 Ville Skyttä 2009-08-09 05:05:29 EDT

*** This bug has been marked as a duplicate of bug 515185 ***

Note You need to log in before you can comment on or make changes to this bug.