This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 516765 - dlopen: /usr/lib/xorg/modules/drivers/openchrome_drv.so: undefined symbol: resVgaShared
dlopen: /usr/lib/xorg/modules/drivers/openchrome_drv.so: undefined symbol: re...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-openchrome (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Xavier Bachelot
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12Blocker/F12FinalBlocker 510207
  Show dependency treegraph
 
Reported: 2009-08-11 08:52 EDT by Jonathan Kamens
Modified: 2009-08-27 22:13 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-27 22:13:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2009-08-11 08:52:58 EDT
Upgrading to current xorg-x11-server-Xorg in rawhide causes this error to be printed when attempting to start the server with the openchrome driver: "dlopen: /usr/lib/xorg/modules/drivers/openchrome_drv.so: undefined symbol: resVgaShared".  Downgrading to older xorg-x11-server-Xorg fixes the problem.

I'm filing this bug under openchrome rather than Xorg because I suspect what's wrong here is that openchrome needs to be recompiled to take into account changes in Xorg.
Comment 1 Jonathan Kamens 2009-08-25 11:11:31 EDT
Hello!?  Openchrome has been broken for at least two weeks now.  We're in the middle of an alpha cycle!  People with openchrome display adapters can't test F12 alpha!  You can't release F12 with openchrome broken!  Please fix!
Comment 2 Xavier Bachelot 2009-08-25 11:38:38 EDT
Sorry for the late answer, took a couple weeks vacation.
I guess a rebuild is not enough and the driver probably needs to be patched. I'll take a look asap. Feel free to beat me to it, patches welcome.
Comment 3 Xavier Bachelot 2009-08-25 16:21:04 EDT
Should be fixed with http://koji.fedoraproject.org/koji/taskinfo?taskID=1633383

Note You need to log in before you can comment on or make changes to this bug.