Bug 51700 - Vncserver and Xvnc do not load because of default font 'fixed' error maybe XFree86-4.1 incompatibility
Vncserver and Xvnc do not load because of default font 'fixed' error maybe XF...
Status: CLOSED DUPLICATE of bug 51316
Product: Red Hat Raw Hide
Classification: Retired
Component: vnc (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-13 21:15 EDT by Cameron Jay Erens
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-19 19:15:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cameron Jay Erens 2001-08-13 21:15:49 EDT
Description of Problem:
13/08/01 19:55:44 Xvnc version 3.3.3r2+tight1.1p9
13/08/01 19:55:44 Copyright (C) AT&T Laboratories Cambridge.
13/08/01 19:55:44 All Rights Reserved.
13/08/01 19:55:44 See http://www.uk.research.att.com/vnc for information on VNC
13/08/01 19:55:44 Desktop name 'X' (Presario:1)
13/08/01 19:55:44 Protocol version supported 3.3
13/08/01 19:55:44 Listening for VNC connections on TCP port 5901
13/08/01 19:55:44 Listening for HTTP connections on TCP port 5801
13/08/01 19:55:44   URL http://Presario:5801
 
Fatal server error:
could not open default font 'fixed'

When I first got this error I thought that it must have been that I didn't have 
xfs started, but indeed, I did.  In fact, I get the same error while in X and in 
the console, with xfs started.  If I stop xfs I get a sort of permission denied 
error in addition to the default font 'fixed' error.

How Reproducible:

Every time.

Steps to Reproduce:

1. Install the vnc-server package from RawHide and the XFree86-4.1 Rawhide 
packages as well.

2. Run vncserver

3. look at ~/.vnc/yourhostname:displaynumber.log
It should yeild the same error as mine.
 
Actual Results:


Expected Results:

The vncserver script should have sucessfully started Xvnc, not yielding an error 
message.

Additional Information:

I am using the XFree86-4.1.0-0.9.11 rpm's from Rawhide.  I have tried using 
several versions of TightVNC:
RedHat-7.1's vnc-server package, two packages from tightvnc.com, and, 
currently, the Rawhide vnc-server-3.3.3r2-18 RPM.  I end up getting the same 
error from all of them when I run Xnvc with the correct parameters. This error is 
the same I get when looking at a logfile generated by the vncserver script too.
Comment 1 Bill Nottingham 2001-08-13 22:03:22 EDT
mharris: 99% this is a dupe of 51033, 50189.
Comment 2 Tim Waugh 2001-08-24 09:31:45 EDT

*** This bug has been marked as a duplicate of 51316 ***
Comment 3 Mike A. Harris 2001-08-24 10:10:55 EDT
Bill:  Yep, there are numerous dupes... Rather than spending any amount
of time flagging them, now that it is fixed, I was going to build the
new RPM first, then put it on people, and then flag all dupes and close.
There are some other bugs like that too..  I usually leave some dupes
open hoping people will see them and not dupe them even more. ;o)

Note You need to log in before you can comment on or make changes to this bug.