Bug 517235 - Cannot import YUM repository with SHA-256 Repository Checksum Type
Summary: Cannot import YUM repository with SHA-256 Repository Checksum Type
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Spacewalk
Classification: Community
Component: WebUI
Version: 0.6
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Shannon Hughes
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: space07
TreeView+ depends on / blocked
 
Reported: 2009-08-13 07:30 UTC by Marcus Moeller
Modified: 2012-03-06 09:02 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-17 15:00:43 UTC


Attachments (Terms of Use)

Description Marcus Moeller 2009-08-13 07:30:46 UTC
Description of problem:

It's not possible to import a YUM repository with SHA-256 Checksum Type (e.g. Fedora 11) using neither the WebUI nor spacewalk-repo-sync.

Version-Release number of selected component (if applicable):
0.6 (release)

How reproducible:

Steps to Reproduce:
1. create a channel with fedora-11-i386-os as channel and repository label2.
2. spacewalk-repo-sync --url=ftp://mirror.switch.ch/mirror/fedora/linux/releases/11/Everything/i386/os/ --channel=fedora-11-i386-os --label=fedora-11-i386-os --type=yum

Actual results:

Traceback (most recent call last):
  File "/usr/bin/spacewalk-repo-sync", line 71, in ?
    sys.exit(abs(main() or 0))
  File "/usr/bin/spacewalk-repo-sync", line 65, in main
    sync.main()
  File "/usr/share/rhn/satellite_tools/reposync.py", line 89, in main
    self.import_packages(self.plugin.list_packages())
  File "/usr/share/rhn/satellite_tools/repo_plugins/yum_src.py", line 42, in list_packages
    sack.populate(repo, 'metadata', None, 0)
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 167, in populate
    db_fn = repo._retrieveMD(mydbtype)
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 1254, in _retrieveMD
    cache=self.http_caching == 'all')
  File "/usr/lib/python2.4/site-packages/yum/yumRepo.py", line 692, in _getFile
    raise Errors.NoMoreMirrorsRepoError, errstr
yum.Errors.NoMoreMirrorsRepoError: failure: repodata/35d817e2bac701525fa72cec57387a2e3457bf32642adeee1e345cc180044c86-primary.sqlite.bz2 from fedora-11-i386-os-fedora-11-i386-os: [Errno 256] No more mirrors to try.

Expected results:
Packages should be imported into the channel.

Comment 1 Marcus Moeller 2009-08-17 15:00:43 UTC
Seems to be resolved after installing python-hashlib.

Maybe this should be added as dependency in spacewalk-backend-tools.

Best Regards
Marcus


Note You need to log in before you can comment on or make changes to this bug.