Bug 517255 - network settings can't recognize ipv6 address
Summary: network settings can't recognize ipv6 address
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: rawhide
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Dan Winship
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-13 09:31 UTC by Caspar Zhang
Modified: 2009-10-15 15:09 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-05 15:29:16 UTC
Type: ---


Attachments (Terms of Use)

Description Caspar Zhang 2009-08-13 09:31:22 UTC
Description of problem:

When I tried to add a new IPv6 connection, I typed my IPv6 address and prefix in ``IPv6 Settings'' tab, however, address like "fe80::223:aeff:fe9d:8464" can't be recognized, the command line gave the error message: "nma_gconf_connection_changed: Invalid connection /system/networking/connections/2: 'NMSettingIP6Config' / 'address' invalid: 2"

Version-Release number of selected component (if applicable):

NetworkManager-0.7.995-1.git20090804.fc12.i686

How reproducible:

100%

Steps to Reproduce:
0. start nm-applet in command line (in order to see debug message)
1. right-click the ``Edit Connection'' in nm-applet and Add a new connection
2. go to IPv6 Settings tab, select method to manual
3. Add an IPv6 Address and Prefix, press ``apply'' button, see the command line result.
  
Actual results:

the connection couldn't be added, the command line said it couldn't recognize the ipv6 address.

Expected results:

NetworkManager should recognize IPv6 address and the connection should be added successfully.

Additional info:

::1 can be added successfully. Other IPv6 addresses can't.

Comment 1 Niels Haase 2009-08-13 13:25:36 UTC
This bug has been triaged

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 2 Dan Williams 2009-08-13 16:30:41 UTC
Looks like adding a prefix works; but /sbin/ip can apparently autodetect the prefix which maybe we should be doing too.  Perhaps if the 'prefix' field is empty we autodetect it and set the prefix automatically when the user commits the IP address value?

Comment 3 Dan Winship 2009-08-13 16:59:40 UTC
Fix available via: http://koji.fedoraproject.org/koji/taskinfo?taskID=1603713. Try it out?

dcbw: this isn't about prefix; you can't even save the config if you don't type in a prefix. This is "if you type an IPv6 address that's longer than 15 characters, you can click Apply, but it won't get saved".

also, as mentioned on irc, you can't autodetect prefixes anyway

Comment 4 Qian Cai 2009-08-26 14:04:01 UTC
Caspar,

Would you mind trying out the new version that Dan mentioned above to see if it solves the problem for you?

Comment 5 Caspar Zhang 2009-08-27 02:31:58 UTC
(In reply to comment #3)
> Fix available via: http://koji.fedoraproject.org/koji/taskinfo?taskID=1603713.
> Try it out?

I'm sorry I could't find any rpms in the URL you given. Maybe it's not built correctly yet?

Comment 6 Dan Winship 2009-08-27 12:45:20 UTC
it was a scratch build... I guess it must automatically delete the packages after a week or something.

The fix has already been committed upstream, so it will be in the next real NM build. Looks like dcbw tried to build yesterday but failed because of breakage in another package. I'll update this bug when there's a build available.

Comment 7 Jimmy Rentz 2009-10-03 23:39:50 UTC
I have a similar problem.  
I am trying to add a manual IPV6 address 2001:XXXX:XXXX:XXXX:XXXX/64 in the same manner.  I see a bunch of "Invalid setting IPv5 Settings" messages and nothing gets saved like above.
I am running NetworkManager.x86_64 1:0.7.996-3.git20090928

Comment 8 Jimmy Rentz 2009-10-04 00:32:44 UTC
Okay, it looks like my problem is Bug 523288.  I unchecked available to all users and all the manual address saves fine.

Comment 9 Dan Williams 2009-10-05 15:29:16 UTC
Caspar, they should be in F12 now.  Can you confirm that the address entry now works for you?  'yum upgrade NetworkManager' should do it.

Jimmy, lets follow your sin bug 523288, thanks!

Comment 10 Caspar Zhang 2009-10-12 02:53:44 UTC
(In reply to comment #9)
> Caspar, they should be in F12 now.  Can you confirm that the address entry now
> works for you?  'yum upgrade NetworkManager' should do it.

Yes, it seems that IPv6 could be recognized and set up. I tested it in NetworkManager-0.7.996-4.git20091002.fc12.i686

Comment 11 Zbysek MRAZ 2009-10-15 08:21:21 UTC
Could be the IPv6 address shown in the Connection information, when you right click on the icon? Is it possible?

Comment 12 Caspar Zhang 2009-10-15 08:34:00 UTC
No, I failed to disable IPv4 address so that in Connection information, it still shows IPv4 address in `IP Address` field.

I can see IPv6 address by ifconfig.

Comment 13 Zbysek MRAZ 2009-10-15 13:39:37 UTC
Should be new bug filed for this?

Comment 14 Dan Winship 2009-10-15 15:09:52 UTC
(In reply to comment #11)
> Could be the IPv6 address shown in the Connection information, when you right
> click on the icon? Is it possible?  

There is a bug filed upstream about this: https://bugzilla.gnome.org/show_bug.cgi?id=593818


Note You need to log in before you can comment on or make changes to this bug.