Bug 517398 - missing directory error in cron mail
Summary: missing directory error in cron mail
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: cronie
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Marcela Mašláňová
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 517594 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-13 18:37 UTC by Tim Waugh
Modified: 2009-08-14 21:24 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-14 12:45:48 UTC


Attachments (Terms of Use)

Description Tim Waugh 2009-08-13 18:37:38 UTC
Description of problem:
Cron mail every hour:

==>
/etc/cron.hourly/0anacron:

anacron: Can't chdir to /var/spool/anacron: No such file or directory
<==

Version-Release number of selected component (if applicable):
cronie-anacron-1.4-3.fc12.x86_64

Should that directory just be created at build time and listed in the RPM manifest?

Comment 1 Marcela Mašláňová 2009-08-14 12:45:48 UTC
Should be fixed in cronie-1.4.1

Comment 2 Tim Waugh 2009-08-14 13:07:45 UTC
When I upgrade to that I get:

# rpm -Fvh cronie-*
Preparing...                ########################################### [100%]
   1:cronie                 ########################################### [ 50%]
touch: cannot touch `/var/spool/anacron/cron.daily': No such file or directory
touch: cannot touch `/var/spool/anacron/cron.weekly': No such file or directory
touch: cannot touch `/var/spool/anacron/cron.monthly': No such file or directory
warning: %post(cronie-1.4.1-1.fc12.x86_64) scriptlet failed, exit status 1
   2:cronie-anacron         ########################################### [100%]

Expected?

Comment 3 Tomas Mraz 2009-08-14 14:02:34 UTC
It should be fixed in cronie-1.4.1-2.fc12. The commands belong to cronie-anacron %post script and not to the cronie %post script.

Comment 4 Tim Waugh 2009-08-14 14:13:57 UTC
Yes, works fine with 1.4.1-2.fc12.  Thanks.

Comment 5 Orion Poplawski 2009-08-14 21:24:29 UTC
*** Bug 517594 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.