Bug 517550 - Packaging issues with gnustep-make
Summary: Packaging issues with gnustep-make
Keywords:
Status: CLOSED DUPLICATE of bug 523018
Alias: None
Product: Fedora
Classification: Fedora
Component: gnustep-make
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Axel Thimm
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-14 15:23 UTC by Charles Lopes
Modified: 2009-09-13 17:30 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 523018
Environment:
Last Closed: 2009-09-13 17:30:21 UTC
Type: ---


Attachments (Terms of Use)
Changes to gnustep-make.spec (2.36 KB, patch)
2009-08-14 15:23 UTC, Charles Lopes
no flags Details | Diff

Description Charles Lopes 2009-08-14 15:23:56 UTC
Created attachment 357467 [details]
Changes to gnustep-make.spec

I have found some issues with version 2.0.8-2 of gnustep-make:

* The LOCAL and SYSTEM domains are the same. By default a "make install" will use the LOCAL domain (/usr/local) but with this package the installation will end up under /usr (the SYSTEM domain). This is a deviation from upstream introduced by some mangling in the spec file.

* Variable GNUSTEP_SYSTEM_DOC is set to /usr/share/doc/gnustep-make-doc-2.0.8. This will cause other GNUstep software installed with this version of gnustep-make to install their respective documentation in that directory. This is another mangling introduced in the spec file.

* gnustep-make installs info pages whose name is far too generic: faq.info, filesystem.info, machines.info, userfaq.info. Installing these should be avoided until they get renamed upstream.

* The spec file is broken when build without docs because there is still a "%files doc" section. It should be within a if statement.

I am attaching a diff file with proposed changes to the spec file.

Comment 1 Michel Alexandre Salim 2009-09-13 17:30:21 UTC
I've fixed most (all?) of this in my 2.2.0 -- making this bug a duplicate of that. Charles, thanks for the inputs -- please carry on the discussion over there.

*** This bug has been marked as a duplicate of bug 523018 ***


Note You need to log in before you can comment on or make changes to this bug.