Bug 517560 - Brightness flickering in rawhide
Brightness flickering in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
: 517803 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-14 13:21 EDT by Tom "spot" Callaway
Modified: 2013-01-10 03:01 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-05 15:39:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tom "spot" Callaway 2009-08-14 13:21:34 EDT
Description of problem:

As described here (http://mjg59.livejournal.com/114159.html), I am now seeing slight brightness flickering in X with rawhide (it does not occur in runlevel 3 until I start X):

xorg-x11-drv-intel-2.8.0-3.fc12.x86_64
kernel-2.6.31-0.125.4.2.rc5.git2.fc12.x86_64

Hardware is Lenovo T500 (running on Intel video) with WUXGA+ screen.

[spot@pterodactyl ~]$ xrandr 
Screen 0: minimum 320 x 200, current 1920 x 1200, maximum 8192 x 8192
VGA1 disconnected (normal left inverted right x axis y axis)
LVDS1 connected 1920x1200+0+0 (normal left inverted right x axis y axis) 331mm x 207mm
   1920x1200      60.0*+   50.0  
   1600x1200      85.0     75.0     70.0     65.0     60.0  
   1400x1050      74.8     60.0  
   1280x1024      85.0     75.0     60.0  
   1280x960       85.0     60.0  
   1152x864       75.0  
   1024x768       85.0     75.0     70.1     60.0  
   832x624        74.6  
   800x600        85.1     72.2     75.0     60.3     56.2  
   640x480        85.0     72.8     75.0     59.9  
   720x400        85.0  
   640x400        85.1  
   640x350        85.1  
DP1 disconnected (normal left inverted right x axis y axis)
Comment 1 Kyle McMartin 2009-08-14 13:37:28 EDT
Reassigning to kernel like the livejournal says, boss. :-)

Can you try booting with "i915.powersave=0" that should at least sort out the problems until things are happy and fixed again.

regards, Kyle
Comment 2 Dominick Grift 2009-08-21 05:03:23 EDT
*** Bug 517803 has been marked as a duplicate of this bug. ***
Comment 3 Matěj Cepl 2009-11-05 14:53:50 EST
I would guess, that bug which is workarounded by i915.powersave=0 argument is not general kernel one. I can reproduce here as well.
Comment 4 Matthew Garrett 2009-11-05 15:39:29 EST
The relevant code was disabled. If you see screen flickering with rawhide, please open a separate bug.

Note You need to log in before you can comment on or make changes to this bug.