Bug 517573 - SuSE Linux Enterprise Server 10 Install
Summary: SuSE Linux Enterprise Server 10 Install
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: fwbackups
Version: rawhide
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Stewart Adam
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-14 18:46 UTC by Daniel
Modified: 2009-08-17 18:55 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-17 18:55:00 UTC
Type: ---


Attachments (Terms of Use)

Description Daniel 2009-08-14 18:46:28 UTC
fwbackups is a great solution! I tested it on Fedora, and works neat. However..

I must install it on SLES10 SP2 x86, in fact it is done, but there is an error (when running de app) I haven't been able to solve.

===================
Here is what I have:
===================
Linux sles10 2.6.16.60-0.21-smp #1 SMP i686 i386 GNU/Linux

LSB Version: core-2.0-noarch:core-3.0-noarch:core-2.0-ia32:core-3.0-ia32:desktop-3.1-ia32:desktop-3.1-noarch:graphics-2.0-ia32:graphics-2.0-noarch:graphics-3.1-ia32:graphics-3.1-noarch
Description:    SUSE Linux Enterprise Server 10 SP2 (i586)
Release:        10

Processor: GenuineIntel
cpu family: 6, model: 15
model name      : Intel(R) Core(TM)2 Duo CPU     T7250  @ 2.00GHz
cpu MHz         : 800.000

======================
Here is what I've done:
======================
[1] In order to cover dependency list:
    * PyGTK
    * Paramiko
    * gnome-doc-utils
    * libnotify (python-notify)
    * cron

    These are included with the distro:
    * python-gtk-2.8.2-21.2
    * gnome-doc-utils-0.5.3-15.2
    * libnotify-0.3.2-15.4 (didn't find python-notify)
    * cron-4.1-45.22

    These I had to download from "rpm.pbone.net":
    * python-crypto-2.0.1-15.3
    * python-paramiko-1.7.1-8.1

    Also installed (included with distro):
    * mysql-5.0.26-12.18
    * mysql-client-5.0.26-12.18
    * All -devel rpms

[2] Got "fwbackups-1.43.3rc3.tar.bz2" from http://downloads.diffingo.com/fwbackups/.

[3] Read README file.
[4] ./configure --prefix=/usr (with no errors)
[5] make (with no errors)
[6] make install (with no errors)

[7] Run /usr/bin/fwbackups, and get the following error:

fwbackups bug report written saved at ...
Traceback (most recent call last):
  File "/usr/share/fwbackups/fwbackups-runapp.pyw", line 2729, in ?
    MainApp = fwbackupsApp(verbose, minimized)
  File "/usr/share/fwbackups/fwbackups-runapp.pyw", line 151, in __init__
    self.runSetup(minimized=minimized)
  File "/usr/share/fwbackups/fwbackups-runapp.pyw", line 326, in runSetup
    self._setupTrayIcon()
  File "/usr/share/fwbackups/fwbackups-runapp.pyw", line 401, in _setupTrayIcon
    self.trayicon = gtk.status_icon_new_from_pixbuf(pix)
AttributeError: 'module' object has no attribute 'status_icon_new_from_pixbuf'

Any clue?

Comment 1 Daniel 2009-08-17 04:23:19 UTC
Stewart Adam (s.adam@diffingo.com) answered me this:

"You've set up everything perfectly but I think the problem is that gtk.StatusIcon, which fwbackups uses to create the tray icon, is only available in PyGTK 2.10 and newer. I'm try to change the code to simply disable the tray icon features when gtk.StatusIcon isn't available."

And the (very fast) solution was:

"If you clone the fwbackups git repository (git://github.com/firewing1/fwbackups.git) and then run:
$ ./autogen.sh --prefix=/usr

You should be able to run "fwbackups-runappy.pyw" from within the "src"
folder directly to see if the change works. If so, the usual "make
install" will install it onto your system."

There is an error when run ./autogen.sh, so you cannot install at all, but if you just copy or make a softlink of fwbackups-runappy.pyw to /usr/share/fwbackups, it works like a charm!

Comment 2 Daniel 2009-08-17 16:44:09 UTC
There is a step I forgot to mention above.. regarding dependency list.

[1.1] Didn't find rpm for intltool, but I was able to built it without any problem:

Download intltool-0.35.5.tar.bz2 from http://www.linuxfromscratch.org/blfs/view/6.3/general/intltool.html

    Untar it, ./configure; make; make install


This is just for anyone who needs to install fwbackups on SLES 10 (tested on SP1/SP2).

Comment 3 Stewart Adam 2009-08-17 18:55:00 UTC
Thanks for the report. Since the problem is in fwbackups's packaging and not the code, it doesn't affect Fedora so I'm going to close this as UPSTREAM.


Note You need to log in before you can comment on or make changes to this bug.