Bug 517603 - anaconda failed in get_table
Summary: anaconda failed in get_table
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-pyblock
Version: rawhide
Hardware: ppc
OS: Linux
medium
urgent
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: anaconda_trace_hash:b22a25efa5e0ab597...
: 517634 519427 519711 520258 528543 (view as bug list)
Depends On:
Blocks: F12Beta, F12BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2009-08-14 22:50 UTC by Geoff Levand
Modified: 2009-10-16 19:44 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-02 17:33:34 UTC


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (70.82 KB, text/plain)
2009-08-14 22:50 UTC, Geoff Levand
no flags Details
Attached traceback automatically from anaconda. (60.82 KB, text/plain)
2009-08-26 20:43 UTC, Geoff Levand
no flags Details

Description Geoff Levand 2009-08-14 22:50:18 UTC
The following was filed automatically by anaconda:
anaconda 12.14 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.6/site-packages/block/device.py", line 454, in get_table
    table = apply(_dm.table, tableParts, {})
  File "/usr/lib/python2.6/site-packages/block/device.py", line 337, in __init__
    table = self.get_table()
  File "/usr/lib/anaconda/storage/devices.py", line 2836, in setup
    self._pyBlockMultiPath = block.device.MultiPath(*parents)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1855, in populate
    mp.setup()
  File "/usr/lib/anaconda/storage/__init__.py", line 293, in reset
    self.devicetree.populate()
  File "/usr/lib/anaconda/storage/__init__.py", line 92, in storageInitialize
    storage.reset()
  File "/usr/lib/anaconda/dispatch.py", line 204, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 127, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/text.py", line 548, in run
    anaconda.dispatch.gotoNext()
  File "/usr/bin/anaconda", line 981, in <module>
    anaconda.intf.run(anaconda)
ValueError: size must be positive

Comment 1 Geoff Levand 2009-08-14 22:50:22 UTC
Created attachment 357516 [details]
Attached traceback automatically from anaconda.

Comment 2 Joel Andres Granados 2009-08-17 09:28:56 UTC
You _were_ installing to a multipath device.  Or did anaconda confuse your storage setup with multipath?

Comment 3 Joel Andres Granados 2009-08-17 09:35:10 UTC
*** Bug 517634 has been marked as a duplicate of this bug. ***

Comment 4 Geoff Levand 2009-08-17 17:46:22 UTC
There is no multipath.  This failure was on a PS3 game console.  It has a standard block device /dev/ps3da, and a built-in USB card reader /dev/sd*.  I had no media in the card reader at the time.

-Geoff

Comment 5 Joel Andres Granados 2009-08-18 09:41:38 UTC
Can you pls go to tty2 and execute the following command:
`udev --query=all --name=ps3da`
and attache the output.

Comment 6 Geoff Levand 2009-08-18 20:56:14 UTC
Does this give you what you need?

# udev --query=all --name=ps3da
udev: command not found

# udevadm info --query=all --name=ps3da
P: /devices/ps3_system/sb_03/block/ps3da
N: ps3da
W: 30
S: block/252:0
E: UDEV_LOG=3
E: DEVPATH=/devices/ps3_system/sb_03/block/ps3da
E: MAJOR=252
E: MINOR=0
E: DEVNAME=/dev/ps3da
E: DEVTYPE=disk
E: ANACBIN=/usr/sbin
E: DEVLINKS=/dev/block/252:0

-Geoff

Comment 7 Joel Andres Granados 2009-08-19 10:04:12 UTC
(In reply to comment #6)
> Does this give you what you need?
> 
> # udev --query=all --name=ps3da
oops, sorry :)

I'm assuming that you executed this command while installing.  If not, pls repeat.

Comment 8 Geoff Levand 2009-08-19 19:59:55 UTC
> --- Comment #7 from Joel Andres Granados <jgranado@redhat.com>  2009-08-19 06:04:12 EDT ---
> I'm assuming that you executed this command while installing.  If not, pls
> repeat.

Yes, just after the error occurred I ran the command from tty2.

-Geoff

Comment 9 Peter Gückel 2009-08-26 03:01:20 UTC
(In reply to comment #2)
> You _were_ installing to a multipath device.  Or did anaconda confuse your
> storage setup with multipath?  

I suspect anaconda is confusing my storage setup, or not finding any at all. I have 2 sata drives and one pata (disabled in bios).

My output is also attached.

Comment 10 Peter Gückel 2009-08-26 03:32:19 UTC
I thought I could simply unplug the second drive and try again, but it didn't work: anaconda still thinks I have a multipath setup.

I am thus unable to install and test f12α.

Comment 11 Jens Petersen 2009-08-26 04:20:10 UTC
ditto been there... (hence still wondering how alpha got released ;)

Comment 12 Geoff Levand 2009-08-26 20:43:32 UTC
Created attachment 358769 [details]
Attached traceback automatically from anaconda.

Comment 13 Chris Lumens 2009-09-01 18:08:53 UTC
*** Bug 519427 has been marked as a duplicate of this bug. ***

Comment 14 Chris Lumens 2009-09-01 18:09:04 UTC
*** Bug 519711 has been marked as a duplicate of this bug. ***

Comment 15 Chris Lumens 2009-09-01 18:09:26 UTC
*** Bug 520258 has been marked as a duplicate of this bug. ***

Comment 16 Adam Williamson 2009-09-01 18:16:24 UTC
519427 includes several reports that the problem is an internal card reader. Petrus, I suspect if you unplug your internal card reader, install will work.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 17 Adam Williamson 2009-09-01 18:17:05 UTC
This appears to be affecting large numbers of people with internal USB media card readers in their systems; setting critical and blocking F12Beta.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 18 Peter Gückel 2009-09-01 23:35:00 UTC
(In reply to comment #16)
> 519427 includes several reports that the problem is an internal card reader.
> Petrus, I suspect if you unplug your internal card reader, install will work.
> 
Thanks for the tip. I was very excited to give f12α and had hoped a solution would appear before f12ß. I'll keep you updated as to how it goes.

Comment 19 Peter Gückel 2009-09-02 02:07:31 UTC
Update: it went!

I successfully installed f12α and did a round of updates. I removed the usb card reader that I had found in an alley - it had seemed like a great find, since I don't otherwise have one :-) I don't need it anyway.

Thanks! Now I can experiment with the new system.

Comment 20 Adam Williamson 2009-09-02 05:08:59 UTC
once you've got the install done, you can plug the card reader back in and it'll work fine. You only have to disconnect it to get through the install.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 21 Peter Gückel 2009-09-02 15:59:28 UTC
(In reply to comment #20)
> once you've got the install done, you can plug the card reader back in and
> it'll work fine. You only have to disconnect it to get through the install.
> 
Thanks. I'm going to toss it, since one of the slots is defective.

f12α is looking great, but there are a lot of dependency issues, preventing doing a full update. I had hoped I would be able to use it right away, but I cannot even get openoffice installed yet. With f11α, I did manage to move right in. Nevertheless, likely due to the inescapable maturity of kde, f12α looks to be more polished than previous αs. I will monitor the progress and shift as soon as it is ready to my needs.

I like that I no longer have to use ext3 for / (all my partitions are ext4 and I never have a separate /boot).

Comment 22 Hans de Goede 2009-09-02 17:33:34 UTC
Adam Williamson,

Thanks for the hint that it was usb card reader related. Having a way to reproduce
often is more then half the work of fixing a bug :) Thanks to this hint I've
been able to reproduce and fix this problem.

Some usb card readers, use multiple lun's per slot, and usb card readers usually report a fake disk serial, and some report the same fake serial for all slots.

This lead to us seeing multiple disks with the same serial, and thus assuming we had multiple paths to the same disk and thus trying to use multipath, after
which things went boom.

See this commit for my "elegant" workaround:
http://git.fedorahosted.org/git/?p=anaconda.git;a=commitdiff;h=ef63316f047549a6e17212a2ac42d7a0ec8e6e03

Closing (As I've verified that this fixes the usb cardreader backtrace).

Comment 23 Chris Lumens 2009-10-12 19:25:05 UTC
*** Bug 528543 has been marked as a duplicate of this bug. ***

Comment 24 Adam Williamson 2009-10-15 19:14:51 UTC
dropping common bugs keyword as this is fixed for beta.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 25 nieland.f 2009-10-16 19:44:32 UTC
so if i disable usb in my bios settings things shut by allright to install 
fedora? i try,d serveral times but halve way it freeses to deadt or no reply,s
from keybord 

regards f.nieland


Note You need to log in before you can comment on or make changes to this bug.