Bug 517635 - [indic] fc-match output is not matching to current locale
Summary: [indic] fc-match output is not matching to current locale
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: lohit-nepali-fonts
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Pravin Satpute
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 518161 520032 520033 520034 520035 520036 520037 520038 520039 520040 520041 520042 520043 520045 520046 520047 520049 520050 520051
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-15 13:11 UTC by A S Alam
Modified: 2013-07-03 00:53 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-12 04:50:16 UTC


Attachments (Terms of Use)

Description A S Alam 2009-08-15 13:11:06 UTC
Description of problem: 
in Nepali Envirnment (gnome-desktop), fc-match is showing following informating
---
$echo $LANG
ne_NP.UTF-8
$fc-match
lohit_hi.ttf: "Lohit Hindi" "Regular"
---

Version-Release number of selected component (if applicable):
lohit-nepali-fonts-2.4.0-2.fc12

How reproducible:
100%

Steps to Reproduce:
1. login to Gnome-desktop with Nepali Language
2. open gnome-terminal
3. type 'fc-match'
  
Actual results:
lohit_hi.ttf: "Lohit Hindi" "Regular"

Expected results:
lohit_ne.ttf: "Lohit Nepali" "Regular" or something for Nepali

Additional info:
I have file /usr/share/fonts/lohit/lohit_ne.tff on system

Comment 1 Pravin Satpute 2009-08-17 03:42:57 UTC
problem is happening with languages sharing same script, 
example, as_IN, bn_IN, mai_IN, mr_IN, 

same bug 497768 is filed for mai already, so closing this as a duplicate of that

*** This bug has been marked as a duplicate of bug 497768 ***

Comment 2 A S Alam 2009-08-17 04:13:54 UTC
ya, it is same issue, but need to work on different locale, so better to have
different bug for easy trace and verify.
Thanks

Comment 3 Parag Nemade 2009-08-28 06:10:14 UTC
We need fontconfig rules for all Indic Lohit fonts.

Comment 4 Bug Zapper 2009-11-16 11:28:08 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 5 Pravin Satpute 2009-12-21 05:23:37 UTC
we had some discussion earlier regarding this thing

so for querying fontconfig for default font exact way is 

$fc-match :lang=mr-in
$fc-match :lang=(langguage name)- (country code)


see bug #546490

Comment 6 Akira TAGOH 2009-12-21 06:33:42 UTC
First of all, the behaviour on fontconfig might be changed in the future. keep your eye on Bug#546490 as Pravin said at the above comment.

Speaking more technical thing, right now fontconfig doesn't apply the lang to the pattern-matching stage. basically it has been done in FcConfigSubstitute(). most applications using fontconfig is written like:

  FcConfigSubstitute(0, pat, FcMatchPattern);
  FcDefaultSubstitute(pat);

So the lang from current locale is applied after the pattern-matching is finished. as per our current rules, we are expecting to see the lang thing at the pattern-matching. thus, the lang available at the font-matching stage doesn't affect as expected at all.

upstream is aware of this issue but unfortunately no idea to fix that. see the thread in upstream list for more details what the problem is:
http://lists.freedesktop.org/archives/fontconfig/2009-November/003275.html

Comment 7 A S Alam 2010-02-09 02:43:29 UTC
with rawhide, following is fixed:
[aalam@blackhawk ~]$ LANG=mr_IN.UTF-8 fc-match
Samyak-Devanagari.ttf: "Samyak Devanagari" "Regular"
[aalam@blackhawk ~]$ LANG=hi_IN.UTF-8 fc-match
Samyak-Devanagari.ttf: "Samyak Devanagari" "Regular"
[aalam@blackhawk ~]$ LANG=mai_IN.UTF-8 fc-match
Samyak-Devanagari.ttf: "Samyak Devanagari" "Regular"

it is fixed in rawhide with following package:
samyak-devanagari-fonts-1.2.1-7.fc13.noarch
lohit-devanagari-fonts-2.4.3-5.fc13.noarch0

Is there any plan to build for f-12?

Comment 8 Pravin Satpute 2010-05-12 04:50:16 UTC
i think let it be for F-12, as Lohit Hindi and Lohit Nepali are same inside, so it will not make any difference in rendering


Note You need to log in before you can comment on or make changes to this bug.