Bug 517765 - Kernel dropped lirc input driver in 2.6.29.6-217.2.7.fc11.x86_64
Summary: Kernel dropped lirc input driver in 2.6.29.6-217.2.7.fc11.x86_64
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 11
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Jarod Wilson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 518790 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-16 23:22 UTC by Mithun Bhattacharya
Modified: 2009-08-30 05:00 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-30 05:00:20 UTC


Attachments (Terms of Use)

Description Mithun Bhattacharya 2009-08-16 23:22:32 UTC
Description of problem:
Updating to kernel 2.6.29.6-217.2.7.fc11.x86_64 dropped support for lirc_mceusb. This was working fine till 2.6.29.6-217.2.3.fc11.x86_64

Version-Release number of selected component (if applicable):
2.6.29.6-217.2.7.fc11.x86_64

How reproducible: Always


Steps to Reproduce:
1. Setup FC11 on a box with a MCE compatible IR sensor.
2. Install 2.6.29.6-217.2.3.fc11.x86_64 and confirm lircd works.
3. Update to kernel 2.6.29.6-217.2.7.fc11.x86_64
  
Actual results:
lircd starts but complains of missing /dev/lirc in /var/log/messages when irw is started

Expected results:
irw should connect fine with lircd and report the buttons being pressed.

Additional info:
I assume this is the actual cause since the older update had this folder

ls /lib/modules/2.6.29.6-217.2.7.fc11.x86_64/kernel/drivers/input/lirc
ls: cannot access /lib/modules/2.6.29.6-217.2.7.fc11.x86_64/kernel/drivers/input/lirc: No such file or directory

Comment 1 Mithun Bhattacharya 2009-08-16 23:29:38 UTC
FYI I don't see kernel/drivers/input/lirc in FC11 with 2.6.29.6-217.2.3.fc11 driver on a x86 install too. The previous rpm still installed on that box has the folder with the drivers inside it.

Comment 2 Jarod Wilson 2009-08-17 13:19:59 UTC
Yeah, when updating the lirc driver patch last time 'round, a critical piece was accidentally left out, resulting in the drivers not getting built. I've already got a new build underway to remedy this, but I'm not sure when it'll hit the updates repo...

http://koji.fedoraproject.org/koji/taskinfo?taskID=1609756

Comment 3 Anthony Messina 2009-08-18 00:00:14 UTC
I just installed the kernel (PAE) and firmware packages from Koji and they resolve the issue. Thank you.

Comment 4 Mithun Bhattacharya 2009-08-18 02:27:40 UTC
Thanks the Koji package worked for me too !!

Comment 5 Anthony Messina 2009-08-30 00:57:39 UTC
This is fixed in 2.6.29.6-217.2.16.fc11.x86_64

Comment 6 Jarod Wilson 2009-08-30 04:59:39 UTC
*** Bug 518790 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.