Bug 5178 - raid startup in rc.sysint does not reflect new raid tools
raid startup in rc.sysint does not reflect new raid tools
Status: CLOSED DUPLICATE of bug 2328
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
6.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-09-17 02:21 EDT by chris
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-09-17 12:35:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description chris 1999-09-17 02:21:00 EDT
rc.sysinit refers to the old 'raidadd' and 'raidrun'
programs which are no longer part of the raidtools package.
Instead, 'raidstart' is used to start the raid subsystem.

Consequently, the rc.sysinit file needs to be modified, such
as follows:

if [ -f /proc/mdstat -a -f /etc/raidtab -a -x
/sbin/raidstart ]; then
        action "Starting up RAID devices" raidstart -a
        rc=$?

        # A non-zero return means there were problems.
        if [ $rc -gt 0 ]; then
...etc
Comment 1 Bill Nottingham 1999-09-17 12:35:59 EDT
*** This bug has been marked as a duplicate of 2328 ***

Note You need to log in before you can comment on or make changes to this bug.