Bug 2328 - /etc/rc.d/rc.sysinit uses wrong raid tools command
/etc/rc.d/rc.sysinit uses wrong raid tools command
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
6.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: David Lawrence
:
: 2411 2604 3095 3248 4300 5178 5344 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-04-22 15:44 EDT by khera
Modified: 2008-05-01 11:37 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-05-10 17:58:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description khera 1999-04-22 15:44:35 EDT
On boot, rc.sysinit looks for raidadd, which does not exist
in the raidtools provided, raidtools-0.90-3.  The correct
command is raidstart, and the raidrun command no longer
exists, either, so that should be commented out.  This is
with initscripts-4.00-1.

Further, the raidtools RPM does not mention that even the
latest kernels 2.2.[56] need to be patched to work with
raidtools 0.90... this is a bit confusing to get things
working.  The comment implies that the 2.2.x kernels are
ready to roll with these raidtools, which is false.
Comment 1 Bill Nottingham 1999-05-10 12:28:59 EDT
*** Bug 2604 has been marked as a duplicate of this bug. ***

Looking at the man page for raidadd (from raidtools-0.90-3)
it is apparent that the /sbin/raidadd and /sbin/raidrun
commands are now obsolete.  The /sbin/raidstart command now
takes care of both functions.  In the /etc/rc.d/rc.sysinit
startup script, these two obsolete commands are referenced,
instead of /sbin/raidstart.  The script in it's current form
will not start raid devices on boot as it is intended.
Below is a (untested -- I haven't rebooted yet) patch
against rc.sysinit that should fix the problem.

---------- cut here --------
--- rc.sysinit.orig	Tue Apr 13 20:05:12 1999
+++ rc.sysinit	Thu May  6 00:47:42 1999
@@ -206,15 +206,10 @@
 fi

 # Add raid devices
-if [ -f /proc/mdstat -a -f /etc/raidtab -a -x /sbin/raidadd
]; then
-	action "Starting up RAID devices" raidadd -a
+if [ -f /proc/mdstat -a -f /etc/raidtab -a -x
/sbin/raidstart ]; then
+	action "Starting up RAID devices" raidstart -a

 	rc=$?

-	if [ $rc = 0 ]; then
-		raidrun -a
-		rc=$?
-	fi

 	# A non-zero return means there were problems.
 	if [ $rc -gt 0 ]; then


------- Additional Comments From iadonisi@colltech.com  05/06/99 13:54 -------
Oops.  Lines 7/8 and lines 10/11 got wrapped.  Paste them together and
the patch should apply.

------- Additional Comments From notting@redhat.com  05/07/99 15:01 -------


*** Bug 2634 has been marked as a duplicate of this bug. ***

The new raidtools (0.90) used in RH 6.0 do not contain
raidadd and raidrun any longer. However, there are still
calls to these programs in rc.sysinit:

if [ -f /proc/mdstat -a -f /etc/raidtab -a -x /sbin/raidadd
]; then
	action "Starting up RAID devices" raidadd -a
	rc=$?

	if [ $rc = 0 ]; then
		raidrun -a
		rc=$?
	fi
	(...)


In order to make the script work this should be changed to
the following:

if [ -f /proc/mdstat -a -f /etc/raidtab -a -x
/sbin/raidstart ]; then
	action "Starting up RAID devices" raidstart --all
	rc=$?
	(...)
Comment 2 Bill Nottingham 1999-05-10 14:36:59 EDT
*** Bug 2411 has been marked as a duplicate of this bug. ***

The obsoleted "raidrun" command is used in rc.sysinit to
start raid, in stead of the current "raidstart".
Comment 3 Bill Nottingham 1999-05-10 17:58:59 EDT
fixed in initscripts-4.17-1, which will be in next week's rawhide
release.
Comment 4 Jeff Johnson 1999-06-03 15:53:59 EDT
*** Bug 3095 has been marked as a duplicate of this bug. ***

Hi,

/etc/rc.d/rc.sysinit is still using raidadd and raidrun
which are no longer part of the raidtool package. The
system failed to startup if RAID devices are active.
Please correct rc.sysinit and use /sbin/raidstart instead.

regards,

Jean Louis Ntakpe
<ntakpe@ntakpe.com>
Comment 5 Jeff Johnson 1999-06-03 15:54:59 EDT
*** Bug 3248 has been marked as a duplicate of this bug. ***

/etc/rc.d/rc.sysinit in RAID section references raidadd and
raidrun which do not exist. The reference to raidadd should
be changed to raidstart and the reference to raidrun should
be removed.
Comment 6 Bill Nottingham 1999-08-02 11:45:59 EDT
*** Bug 4300 has been marked as a duplicate of this bug. ***

In /etc/rc.d/rc.sysinit, a test is made for the
executability of /sbin/raidadd, and raidrun, neither of
which exist.  The 6.0 code should refer to the executability
of /sbin/raidstart (and execute it with a '-a' flag), and
eliminate the 'if' clause that executes raidrun.
Comment 7 Pekka Savola 1999-08-03 05:49:59 EDT
I'd also like to point out that many people use auto-detected
raid arrays, with which raidstart/stop should not be run in
initialization scripts.
Comment 8 Bill Nottingham 1999-09-17 12:35:59 EDT
*** Bug 5178 has been marked as a duplicate of this bug. ***

rc.sysinit refers to the old 'raidadd' and 'raidrun'
programs which are no longer part of the raidtools package.
Instead, 'raidstart' is used to start the raid subsystem.

Consequently, the rc.sysinit file needs to be modified, such
as follows:

if [ -f /proc/mdstat -a -f /etc/raidtab -a -x
/sbin/raidstart ]; then
        action "Starting up RAID devices" raidstart -a
        rc=$?

        # A non-zero return means there were problems.
        if [ $rc -gt 0 ]; then
...etc
Comment 9 Bill Nottingham 1999-09-24 09:42:59 EDT
*** Bug 5344 has been marked as a duplicate of this bug. ***

/etc/rc.d/rc.sysinit uses the older raidadd and raidrun
commands. These commands are not included with the 6.0
distribution. In fact, they have replaced with the
newer raidstart program (in the raidtools package).

It is impossible to have raided filesystems mount at
boot time with the commands currently in rc.sysinit.

Note You need to log in before you can comment on or make changes to this bug.