Bug 51780 - Grub does not execute at boot when installed on 2-hard drive system
Grub does not execute at boot when installed on 2-hard drive system
Status: CLOSED DUPLICATE of bug 50800
Product: Red Hat Public Beta
Classification: Retired
Component: grub (Show other bugs)
roswell
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-14 21:39 EDT by Robert L. Cochran Jr.
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-14 21:39:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert L. Cochran Jr. 2001-08-14 21:39:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010725

Description of problem:
When installing grub as the boot loader on a system that has 2 hard drives,
hda and hdb, and Roswell is installed to hdb rather than to partitions on
hda, and user selects writing boot loader to the master boot record, grub
will not execute the first or subsequent time the system is booted or when
it is rebooted. In order to boot Roswell when  it is installed to hdb, one
has to use a boot floppy.  

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install Roswell to the secondary IDE drive of a computer with a primary
(master) IDE drive running Microsoft Windows 98 Second Edition.
2.Accept the default boot loader (Grub). 
3.Specify either DOS or Linux as the default boot label (it doesn't matter.)
4. Continue with installation.
	

Actual Results:  The (Roswell) beta installer would install all packages
normally, but at the final step where you are told installation is
complete, and to remove the floppy from the floppy drive and press Enter to
boot, one doesn't see the Grub boot loader come up as expected. Subsequent
attempts to boot from the hard drive do not bring up Grub. I can boot
successfully if I put the boot floppy in the floppy drive and reboot the
computer.

Expected Results:  I should have seen the Grub boot loader issue a screen
offering me the chance to boot into my preferred default OS.

Additional info:

If you try to install Roswell to a partition on the primary IDE drive
(hda), the grub loader installs normally and shows up as expected. In this
case Grub does not boot to the OS you selected as the default. It boots to
DOS (Windows 98) every time.
Comment 1 Jeremy Katz 2001-08-14 21:48:44 EDT

*** This bug has been marked as a duplicate of 50800 ***

Note You need to log in before you can comment on or make changes to this bug.