Bug 517810 - rpms unimportant requirements are the only reason to have cron and sendmail installed
Summary: rpms unimportant requirements are the only reason to have cron and sendmail i...
Keywords:
Status: CLOSED DUPLICATE of bug 500722
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Panu Matilainen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-17 09:59 UTC by Mads Kiilerich
Modified: 2009-08-17 11:00 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-17 11:00:20 UTC


Attachments (Terms of Use)

Description Mads Kiilerich 2009-08-17 09:59:10 UTC
Description of problem:

rpm requires crontabs because of /etc/cron.daily/rpm
crontabs requires /etc/cron.d which is provided by cronie
cronie requires /usr/sbin/sendmail

On a minimal installation (livecd) that is the only reason to have cron and sendmail installed. That is quite unfortunate for something as unimportant as this rpm cron job.


I do like having /var/log/rpm on servers - especially when it is version controlled or included in backups. 

But thinking of it I don't think this functionality should be in a low-level package such as rpm. rpm also doesn't log package installations to syslog. So perhaps the functionality is more suitable for yum?

IF this functionality belongs in rpm then rpm (or rpm-libs) should update the file every time a package is installed or removed. The overhead would probably be very very small, and the value of always having an updated file would make it much more useful. But of course, that also raises the question of why rpm -qa can't be used instead.

IMHO.


Version-Release number of selected component (if applicable):

rpm-4.7.1-1.fc11.i586

Comment 1 Mads Kiilerich 2009-08-17 10:08:07 UTC
I notice that several other packages with /etc/cron*/* files don't require crontabs.

AFAICS that is strictly speaking packaging errors, but I think it is a pragmatic "solution" which rpm could use too.

Perhaps /etc/cron* should be owned by the filesystem package instead ...

Comment 2 Panu Matilainen 2009-08-17 11:00:20 UTC
This has been fixed in rawhide by splitting the cron-related functionality to separate subpackage. For F11 this is a WONTFIX however: the packaging split is not an appropriate change in an update, and I'm not going to introduce deliberate packaging errors in the form of unowned directories.

*** This bug has been marked as a duplicate of bug 500722 ***


Note You need to log in before you can comment on or make changes to this bug.