Bug 51783 - DB_VERIFY_BAD: Database verification failed
DB_VERIFY_BAD: Database verification failed
Status: CLOSED DUPLICATE of bug 51308
Product: Red Hat Public Beta
Classification: Retired
Component: rpm (Show other bugs)
roswell
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-14 23:16 EDT by Joseph Fannin
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-14 23:16:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joseph Fannin 2001-08-14 23:16:13 EDT
After a while (I'm not sure what triggers it, exactly), rpm begins to
report the following message when installing or removing a package:

error: db3 error(-30985) from db->verify: DB_VERIFY_BAD: Database
verification failed

The message is the same each time, including the "-30985".  `rpm
--rebuilddb` will make the problem go away for a while, but it comes back.

I'm actually tracking Rawhide (rpm 4.0.3-0.88), but I've seen this reported
on the roswell-list as well; I'm seeing it here on two different machines.

I dunno how critical the bug itself is, but if RedHat ships an rpm that
spews these messages, it'll swamp tech support fora; database error
messages from rpm are scary.
Comment 1 Jeff Johnson 2001-08-15 09:33:20 EDT

*** This bug has been marked as a duplicate of 51308 ***
Comment 2 Joseph Fannin 2001-08-24 17:02:21 EDT
I don't have access to bug 51308 which this has been marked as a duplicate of.

I remember hearing that most of these "private" bugs are for internal builds or
something similar, which makes sense, I guess.

But this is really kind of ass-backwards, in that I have no way of tracking this
bug now, even to only see if it's been fixed now.  It reduces the effectiveness
of bugzilla, IMHO; though it's probably not so, it kind of feels as if I've been
brushed off.  "Yeah, we know about it, thanks."

I'm not too concerned about it in this case (though I am curious), but I think
something should be done about it.

Come to think of it, I'm going to file a bug against bugzilla.  ;-)

Note You need to log in before you can comment on or make changes to this bug.