Bug 517916 - Accessing /rhn/Login.do results in 404 error and java.lang.NoClassDefFoundError: javax/transaction/Synchronization
Summary: Accessing /rhn/Login.do results in 404 error and java.lang.NoClassDefFoundErr...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Spacewalk
Classification: Community
Component: Server
Version: 0.6
Hardware: i386
OS: Linux
low
high
Target Milestone: ---
Assignee: Jesus M. Rodriguez
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: space07
TreeView+ depends on / blocked
 
Reported: 2009-08-17 21:08 UTC by Magnus Glantz
Modified: 2012-03-06 09:02 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-05 21:45:23 UTC


Attachments (Terms of Use)
Tomcat debug log from rhn-satellite start (59.80 KB, application/octet-stream)
2009-08-18 08:03 UTC, Magnus Glantz
no flags Details

Description Magnus Glantz 2009-08-17 21:08:59 UTC
Description of problem:
After installation of Spacewalk 0.6 on FC 11 (all the latest packages updated) I get the following error message when accessing https://localhost/rhn/Login.do
--snipp--
HTTP Status 404 -

type Status report

message

description The requested resource () is not available.
Apache Tomcat/5.5.27
--snipp--

I tried upgrading all packages using the FC11 nightly build repo for Spacewalk without effect.

Version-Release number of selected component (if applicable):
spacewalk-backend-app-0.7.1-1.fc11.noarch
spacewalk-backend-applet-0.7.1-1.fc11.noarch
spacewalk-branding-0.6.8-1.fc11.noarch
spacewalk-grail-0.6.19-1.fc11.noarch
spacewalk-backend-0.7.1-1.fc11.noarch
spacewalk-monitoring-0.6.7-1.fc11.noarch
spacewalk-setup-0.6.21-1.fc11.noarch
spacewalk-backend-xml-export-libs-0.7.1-1.fc11.noarch
spacewalk-search-0.6.11-1.fc11.noarch
spacewalk-backend-server-0.7.1-1.fc11.noarch
spacewalk-sniglets-0.6.19-1.fc11.noarch
spacewalk-backend-xp-0.7.1-1.fc11.noarch
spacewalk-java-config-0.6.43-1.fc11.noarch
spacewalk-admin-0.6.3-1.fc11.noarch
spacewalk-selinux-0.6.13-1.fc11.noarch
spacewalk-backend-xmlrpc-0.7.1-1.fc11.noarch
spacewalk-backend-package-push-server-0.7.1-1.fc11.noarch
spacewalk-java-lib-0.6.43-1.fc11.noarch
spacewalk-monitoring-selinux-0.6.12-1.fc11.noarch
spacewalk-certs-tools-0.6.3-1.fc11.noarch
spacewalk-pxt-0.6.19-1.fc11.noarch
spacewalk-backend-config-files-common-0.7.1-1.fc11.noarch
spacewalk-backend-config-files-tool-0.7.1-1.fc11.noarch
spacewalk-html-0.6.19-1.fc11.noarch
spacewalk-doc-indexes-0.6.1-1.fc11.noarch
spacewalk-taskomatic-0.6.43-1.fc11.noarch
spacewalk-moon-0.6.19-1.fc11.noarch
spacewalk-0.6.4-1.fc11.noarch
spacewalk-backend-iss-export-0.7.1-1.fc11.noarch
spacewalk-schema-0.7.1-1.fc11.noarch
spacewalk-backend-iss-0.7.1-1.fc11.noarch
spacewalk-config-0.6.13-1.fc11.noarch
spacewalk-cypress-0.6.19-1.fc11.noarch
spacewalk-backend-sql-0.7.1-1.fc11.noarch
spacewalk-java-0.6.43-1.fc11.noarch
spacewalk-backend-config-files-0.7.1-1.fc11.noarch
spacewalk-repo-0.6-5.fc11.noarch
spacewalk-base-minimal-0.6.19-1.fc11.noarch
spacewalk-base-0.6.19-1.fc11.noarch
spacewalk-backend-tools-0.7.1-1.fc11.noarch
java-1.6.0-openjdk-1.6.0.0-27.b16.fc11.i586
java-1.6.0-openjdk-plugin-1.6.0.0-27.b16.fc11.i586
java-1.6.0-openjdk-devel-1.6.0.0-27.b16.fc11.i586
java-1.5.0-gcj-1.5.0.0-28.fc11.i586
java-1.6.0-openjdk-javadoc-1.6.0.0-27.b16.fc11.i586



How reproducible:
Install Spacewalk 0.6 on FC11 (i386), try and access https://hostname/rhn/Login.do after an successful installation.


Steps to Reproduce:
1. Install FC11
2. Install Spacewalk 0.6, Jpackage and Oracle-XE for FC11.
3. Try and access https://hostname/rhn/Login.do
  
Actual results:
I found the following mess in /var/log/tomcat5/catalina.out

Using CATALINA_BASE:   /usr/share/tomcat5
Using CATALINA_HOME:   /usr/share/tomcat5
Using CATALINA_TMPDIR: /usr/share/tomcat5/temp
Using JRE_HOME:       
Aug 17, 2009 10:48:09 PM org.apache.catalina.core.AprLifecycleListener lifecycleEvent
INFO: The Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.
0/jre/lib/i386/server:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/lib/i386:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/../lib/i386:/opt/oracle/lib:/usr/lib:/usr/java/packages/li
b/i386:/lib:/usr/lib
Aug 17, 2009 10:48:09 PM org.apache.coyote.http11.Http11BaseProtocol init
INFO: Initializing Coyote HTTP/1.1 on http-8080
Aug 17, 2009 10:48:09 PM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 616 ms
Aug 17, 2009 10:48:09 PM org.apache.catalina.users.MemoryUserDatabase save
WARNING: User database is not persistable - no write permissions on directory
Aug 17, 2009 10:48:09 PM org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
Aug 17, 2009 10:48:09 PM org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/5.5.27
Aug 17, 2009 10:48:09 PM org.apache.catalina.core.StandardHost start
INFO: XML validation disabled
Aug 17, 2009 10:48:09 PM org.apache.catalina.startup.HostConfig deployDescriptor
WARNING: A docBase /var/lib/tomcat5/webapps/rhn inside the host appBase has been specified, and will be ignored
Aug 17, 2009 10:48:09 PM org.apache.catalina.startup.DigesterFactory register
WARNING: Could not get url for /javax/servlet/resources/jsp_2_0.xsd
Aug 17, 2009 10:48:09 PM org.apache.catalina.startup.DigesterFactory register
WARNING: Could not get url for /javax/servlet/resources/web-jsptaglibrary_2_0.xsd
Aug 17, 2009 10:48:09 PM org.apache.catalina.loader.WebappClassLoader validateJarFile
INFO: validateJarFile(/usr/share/tomcat5/webapps/rhn/WEB-INF/lib/jspapi.jar) - jar not loaded. See Servlet Spec 2.3, section 9.7.2. Offending class: javax/servlet/jsp/JspPage.cl
ass
Aug 17, 2009 10:48:15 PM com.mchange.v2.log.MLog <clinit>
INFO: MLog clients using java 1.4+ standard logging.
Aug 17, 2009 10:48:15 PM com.mchange.v2.c3p0.C3P0Registry banner
INFO: Initializing c3p0-0.9.0 [built 28-May-2009 13:44:43 -0400; debug? false; trace: 5]
Aug 17, 2009 10:48:16 PM com.mchange.v2.c3p0.PoolBackedDataSource getPoolManager
INFO: Initializing c3p0 pool... com.mchange.v2.c3p0.PoolBackedDataSource@18baf36 [ connectionPoolDataSource -> com.mchange.v2.c3p0.WrapperConnectionPoolDataSource@553763 [ acqui
reIncrement -> 3, acquireRetryAttempts -> 30, acquireRetryDelay -> 1000, autoCommitOnClose -> false, automaticTestTable -> null, breakAfterAcquireFailure -> false, checkoutTimeo
ut -> 0, connectionTesterClassName -> com.mchange.v2.c3p0.impl.DefaultConnectionTester, factoryClassLocation -> null, forceIgnoreUnresolvedTransactions -> false, identityToken -
> 553763, idleConnectionTestPeriod -> 300, initialPoolSize -> 5, maxIdleTime -> 300, maxPoolSize -> 20, maxStatements -> 0, maxStatementsPerConnection -> 0, minPoolSize -> 5, ne
stedDataSource -> com.mchange.v2.c3p0.DriverManagerDataSource@a45a24 [ description -> null, driverClass -> null, factoryClassLocation -> null, identityToken -> a45a24, jdbcUrl -
> jdbc:oracle:thin:@localhost:1521:XE, properties -> {user=******, password=******} ], preferredTestQuery -> null, propertyCycle -> 300, testConnectionOnCheckin -> false, testCo
nnectionOnCheckout -> false, usesTraditionalReflectiveProxies -> false ], factoryClassLocation -> null, identityToken -> 18baf36, numHelperThreads -> 3 ]
2009-08-17 22:48:20,967 [main] ERROR org.apache.catalina.core.ContainerBase.[Catalina].[localhost].[/rhn] - Exception sending context initialized event to listener instance of c
lass com.redhat.rhn.webapp.RhnServletListener
java.lang.NoClassDefFoundError: javax/transaction/Synchronization
	at org.hibernate.impl.SessionImpl.<init>(SessionImpl.java:213)
	at org.hibernate.impl.SessionFactoryImpl.openSession(SessionFactoryImpl.java:473)
	at org.hibernate.impl.SessionFactoryImpl.openSession(SessionFactoryImpl.java:497)
	at org.hibernate.impl.SessionFactoryImpl.openSession(SessionFactoryImpl.java:505)
	at com.redhat.rhn.common.hibernate.ConnectionManager.getInternalSession(ConnectionManager.java:249)
	at com.redhat.rhn.common.hibernate.ConnectionManager.getSession(ConnectionManager.java:238)
	at com.redhat.rhn.common.hibernate.HibernateFactory.getSession(HibernateFactory.java:264)
	at com.redhat.rhn.manager.satellite.UpgradeCommand.store(UpgradeCommand.java:60)
	at com.redhat.rhn.webapp.RhnServletListener.executeUpgradeStep(RhnServletListener.java:121)
	at com.redhat.rhn.webapp.RhnServletListener.contextInitialized(RhnServletListener.java:115)
	at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:3764)
	at org.apache.catalina.core.StandardContext.start(StandardContext.java:4216)
	at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:760)
	at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:740)
	at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:544)
	at org.apache.catalina.startup.HostConfig.deployDescriptor(HostConfig.java:626)
	at org.apache.catalina.startup.HostConfig.deployDescriptors(HostConfig.java:553)
	at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:488)
	at org.apache.catalina.startup.HostConfig.start(HostConfig.java:1150)
	at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:311)
	at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:120)
	at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1022)
	at org.apache.catalina.core.StandardHost.start(StandardHost.java:736)
	at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1014)
	at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:443)
	at org.apache.catalina.core.StandardService.start(StandardService.java:448)
	at org.apache.catalina.core.StandardServer.start(StandardServer.java:700)
	at org.apache.catalina.startup.Catalina.start(Catalina.java:552)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:616)
	at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:295)
	at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:433)
Caused by: java.lang.ClassNotFoundException: javax.transaction.Synchronization
	at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1386)
	at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1232)
	at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:336)
	... 34 more
Aug 17, 2009 10:48:20 PM org.apache.catalina.core.StandardContext start
SEVERE: Error listenerStart
Aug 17, 2009 10:48:20 PM org.apache.catalina.core.StandardContext start
SEVERE: Context [/rhn] startup failed due to previous errors
Aug 17, 2009 10:48:21 PM org.apache.coyote.http11.Http11BaseProtocol start
INFO: Starting Coyote HTTP/1.1 on http-8080
Aug 17, 2009 10:48:21 PM org.apache.jk.common.ChannelSocket init
INFO: JK: ajp13 listening on /0.0.0.0:8009
Aug 17, 2009 10:48:21 PM org.apache.jk.server.JkMain start
INFO: Jk running ID=0 time=0/26  config=null
Aug 17, 2009 10:48:21 PM org.apache.catalina.storeconfig.StoreLoader load
INFO: Find registry server-registry.xml at classpath resource
Aug 17, 2009 10:48:21 PM org.apache.catalina.startup.Catalina start
INFO: Server startup in 12386 ms


Expected results:
No error messages, a login prompt to the Satellite.

Additional info:
I didn't encounter any noticable issues during installation.

# rhn-satellite status
router (pid 5684) is running...
sm (pid 5733) is running...
c2s (pid 5782) is running...
s2s (pid 5831) is running...

LSNRCTL for Linux: Version 10.2.0.1.0 - Production on 17-AUG-2009 23:00:06

Copyright (c) 1991, 2005, Oracle.  All rights reserved.

Connecting to (DESCRIPTION=(ADDRESS=(PROTOCOL=IPC)(KEY=EXTPROC_FOR_XE)))
STATUS of the LISTENER
------------------------
Alias                     LISTENER
Version                   TNSLSNR for Linux: Version 10.2.0.1.0 - Production
Start Date                17-AUG-2009 22:48:01
Uptime                    0 days 0 hr. 12 min. 5 sec
Trace Level               off
Security                  ON: Local OS Authentication
SNMP                      OFF
Default Service           XE
Listener Parameter File   /usr/lib/oracle/xe/app/oracle/product/10.2.0/server/network/admin/listener.ora
Listener Log File         /usr/lib/oracle/xe/app/oracle/product/10.2.0/server/network/log/listener.log
Listening Endpoints Summary...
  (DESCRIPTION=(ADDRESS=(PROTOCOL=ipc)(KEY=EXTPROC_FOR_XE)))
  (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=mglantz.csb)(PORT=1521)))
  (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=mglantz.csb)(PORT=9000))(Presentation=HTTP)(Session=RAW))
Services Summary...
Service "PLSExtProc" has 1 instance(s).
  Instance "PLSExtProc", status UNKNOWN, has 1 handler(s) for this service...
Service "XE" has 1 instance(s).
  Instance "XE", status READY, has 1 handler(s) for this service...
Service "XEXDB" has 1 instance(s).
  Instance "XE", status READY, has 1 handler(s) for this service...
Service "XE_XPT" has 1 instance(s).
  Instance "XE", status READY, has 1 handler(s) for this service...
The command completed successfully
osa-dispatcher (pid  5905) is running...
/etc/init.d/tomcat5 is already running (6001)
httpd (pid  6027) is running...
rhn-search is running (6074).
cobblerd (pid 6113) is running...
RHN Taskomatic is not running.

Comment 1 Magnus Glantz 2009-08-18 06:41:04 UTC
[root@mglantz ~]# java -version
java version "1.6.0_0"
OpenJDK Runtime Environment (IcedTea6 1.5) (fedora-27.b16.fc11-i386)
OpenJDK Server VM (build 14.0-b15, mixed mode)

All the java stuff I could find on my machine..
If it's possible I've ran into some kind of conflict between packages.

# rpm -qa|grep java|sort
ant-javamail-1.7.1-9.2.fc11.i586
eclipse-mylyn-java-3.1.0-3.fc11.noarch
geronimo-javaee-deployment-1.1-api-1.2-11.jpp6.fc10.noarch
geronimo-javamail-1.3.1-api-1.2-11.jpp6.fc10.noarch
geronimo-javamail-1.4-api-1.2-11.jpp6.fc10.noarch
java-1.5.0-gcj-1.5.0.0-28.fc11.i586
java-1.6.0-openjdk-1.6.0.0-27.b16.fc11.i586
java-1.6.0-openjdk-devel-1.6.0.0-27.b16.fc11.i586
java-1.6.0-openjdk-javadoc-1.6.0.0-27.b16.fc11.i586
java-1.6.0-openjdk-plugin-1.6.0.0-27.b16.fc11.i586
java_cup-0.10k-2.i586
javahelp2-2.0.05-7.fc11.noarch
libreadline-java-0.8.0-23.fc11.i586
mysql-connector-java-3.1.12-7.fc11.i586
spacewalk-java-0.6.43-1.fc11.noarch
spacewalk-java-config-0.6.43-1.fc11.noarch
spacewalk-java-lib-0.6.43-1.fc11.noarch
subversion-javahl-1.6.4-2.fc11.i586
tzdata-java-2009k-2.fc11.noarch

Comment 2 Jan Pazdziora 2009-08-18 06:53:44 UTC
Amending component to Server.

Comment 3 Magnus Glantz 2009-08-18 08:03:02 UTC
Created attachment 357750 [details]
Tomcat debug log from rhn-satellite start

Tomcat debug log from rhn-satellite start. 4.3 MB large when extracted.

Comment 4 Magnus Glantz 2009-08-18 09:34:42 UTC
At the end of the tomcat debug log, it seems like the rhn webapp fails to deploy. The below input loops on for ever.

DEBUG ContainerBackgroundProcessor[StandardEngine[Catalina]] org.apache.catalina.startup.HostConfig - Checking context[/rhn] redeploy resource /var/lib/tomcat5/webapps/rhn
DEBUG ContainerBackgroundProcessor[StandardEngine[Catalina]] org.apache.catalina.startup.HostConfig - Checking context[/rhn] redeploy resource /etc/tomcat5/Catalina/localhost/rhn.xml
DEBUG ContainerBackgroundProcessor[StandardEngine[Catalina]] org.apache.catalina.startup.HostConfig - Checking context[/rhn] reload resource /etc/tomcat5/Catalina/localhost/rhn.xml
DEBUG ContainerBackgroundProcessor[StandardEngine[Catalina]] org.apache.catalina.startup.HostConfig - Checking context[/rhn] reload resource /var/lib/tomcat5/webapps/rhn/WEB-INF/web.xml
DEBUG ContainerBackgroundProcessor[StandardEngine[Catalina]] org.apache.catalina.startup.HostConfig - Checking context[/rhn] reload resource /usr/share/tomcat5/conf/context.xml
DEBUG ContainerBackgroundProcessor[StandardEngine[Catalina]] org.apache.catalina.startup.HostConfig - Checking context[/rhn] redeploy resource /var/lib/tomcat5/webapps/rhn
DEBUG ContainerBackgroundProcessor[StandardEngine[Catalina]] org.apache.catalina.startup.HostConfig - Checking context[/rhn] redeploy resource /etc/tomcat5/Catalina/localhost/rhn.xml
DEBUG ContainerBackgroundProcessor[StandardEngine[Catalina]] org.apache.catalina.startup.HostConfig - Checking context[/rhn] reload resource /etc/tomcat5/Catalina/localhost/rhn.xml
DEBUG ContainerBackgroundProcessor[StandardEngine[Catalina]] org.apache.catalina.startup.HostConfig - Checking context[/rhn] reload resource /var/lib/tomcat5/webapps/rhn/WEB-INF/web.xml
DEBUG ContainerBackgroundProcessor[StandardEngine[Catalina]] org.apache.catalina.startup.HostConfig - Checking context[/rhn] reload resource /usr/share/tomcat5/conf/context.xml

Comment 5 Magnus Glantz 2009-08-21 21:10:25 UTC
I reinstalled with newest packages from the nightly build without effect.
(yum -y remove $(rpm -qa|grep spacewalk) tomcat5; yum -y install spacewalk)

I now noticed that when performing the installation I did get an error message at the end.:

--snipp--
* Restarting services.
    _,_ 
Tomcat failed to start properly or the installer ran out of tries.  Please check /var/log/tomcat5/catalina.out for errors.
Installation complete.
Visit https://mymachine.bogus to create the Spacewalk administrator account.
--snipp--

Comment 6 Magnus Glantz 2009-08-27 20:49:23 UTC
If it wasn't clear, the error messages displayed when checking catalina.out after the reinstallation was the same I got earlier.

Comment 7 Magnus Glantz 2009-08-30 11:07:58 UTC
Tried a new installation against 0.6.5 and Nightly Build repo, I now hit BZ 520257 ( https://bugzilla.redhat.com/show_bug.cgi?id=520257 ). Now waiting for that one to resolve.

Comment 8 Magnus Glantz 2009-08-31 11:21:46 UTC
520257 resolved. I'm still getting this issue. I'll continue troubleshooting.

Comment 9 Magnus Glantz 2009-08-31 12:17:24 UTC
I found a broken link that cuased this.

[root@mglantz lib]# ls -l /var/lib/tomcat5/webapps/rhn/WEB-INF/lib/jta.jar
lrwxrwxrwx 1 root root 23 2009-08-31 14:03 /var/lib/tomcat5/webapps/rhn/WEB-INF/lib/jta.jar -> /usr/share/java/jta.jar
[root@mglantz lib]# ls -l /usr/share/java/jta.jar
lrwxrwxrwx. 1 root root 28 2009-06-13 03:10 /usr/share/java/jta.jar -> geronimo/spec-jta-1.0.1B.jar
[root@mglantz lib]# ls -l /usr/share/java/geronimo/spec-jta-1.0.1B.jar 
lrwxrwxrwx 1 root root 23 2009-08-17 21:28 /usr/share/java/geronimo/spec-jta-1.0.1B.jar -> spec-jta-1.0.1B-1.2.jar
[root@mglantz lib]# ls -l /usr/share/java/geronimo/spec-jta-1.0.1B-1.2.jar 
lrwxrwxrwx 1 root root 34 2009-08-17 21:28 /usr/share/java/geronimo/spec-jta-1.0.1B-1.2.jar -> ../geronimo-jta-1.0.1B-api-1.2.jar
[root@mglantz lib]# ls -l /usr/share/java/geronimo-jta-1.0.1B-api-1.2.jar
ls: cannot access /usr/share/java/geronimo-jta-1.0.1B-api-1.2.jar: No such file or directory

When trying to quickly work around this with:
[root@mglantz lib]# cp /usr/share/java/geronimo-jta-1.0.1B-api-1.1.1.jar /usr/share/java/geronimo-jta-1.0.1B-api-1.2.jar

I got a new Tomcat mess.. Altough I was redirected to https://localhost/rhn/newlogin/CreateFirstUser.do;jsessionid=39729DBAC2A536EB1E03F0BA6524374D (but an empty screen was displayed)

I go find geronimo-jta-1.0.1B-api-1.2.jar and try it out for size, hopefully everything will play more nicely then.

Comment 10 Magnus Glantz 2009-08-31 16:22:19 UTC
[root@mglantz lib]# yum whatprovides /usr/share/java/geronimo/spec-jta-1.0.1B-1.2.jar
geronimo-specs-1.2-11.jpp6.fc10.noarch : Geronimo J2EE server J2EE specifications
Repo        : jpackage
Matched from:
Filename    : /usr/share/java/geronimo/spec-jta-1.0.1B-1.2.jar

So I suppose the geronimo-specs-1.2-11.jpp6.fc10.noarch package is the one that needs correction.

Comment 11 Magnus Glantz 2009-08-31 17:50:27 UTC
Latest change done to the geronimo-specs-1.2-11.jpp6.fc10.noarch package was 10 months ago.. Strange that I'm the only one getting this issue. Seems like it might be something else that has tampered with the jta link.

Can anyone else recreate the issue?

Comment 12 Magnus Glantz 2009-08-31 22:15:48 UTC
I'm not sure what happened.. but there is a lot of dead links found at /usr/share/java/geronimo. Mostly packages fetched from the jpackage repo.

I'm starting to think my FC11 installation is completely shot, if not anyone else is seeing this.

# yum whatprovides $(ls -l $(find /usr/share/java -type l ! -exec test -r {} \; -print)|awk '{ print $8 }')
Loaded plugins: downloadonly, refresh-packagekit
Importing additional filelist information
geronimo-ejb-2.1-api-1.2-11.jpp6.fc10.noarch : J2EE EJB v2.1 API
Repo        : jpackage
Matched from:
Filename    : /usr/share/java/ejb.jar

geronimo-ejb-3.0-api-1.2-11.jpp6.fc10.noarch : J2EE EJB v3.0 API
Repo        : jpackage
Matched from:
Filename    : /usr/share/java/ejb.jar

geronimo-specs-compat-1.0-2.M2.fc10.i386 : Compatibility package for geronimo-specs
Repo        : fedora
Matched from:
Filename    : /usr/share/java/ejb.jar

geronimo-specs-1.2-11.jpp6.fc10.noarch : Geronimo J2EE server J2EE specifications
Repo        : jpackage
Matched from:
Filename    : /usr/share/java/geronimo/spec-annotation-1.0-1.2.jar

geronimo-specs-1.2-11.jpp6.fc10.noarch : Geronimo J2EE server J2EE specifications
Repo        : jpackage
Matched from:
Filename    : /usr/share/java/geronimo/spec-annotation-1.0.jar

geronimo-specs-1.2-11.jpp6.fc10.noarch : Geronimo J2EE server J2EE specifications
Repo        : jpackage
Matched from:
Filename    : /usr/share/java/geronimo/spec-commonj-1.1-1.2.jar

geronimo-specs-1.2-11.jpp6.fc10.noarch : Geronimo J2EE server J2EE specifications
Repo        : jpackage
Matched from:
Filename    : /usr/share/java/geronimo/spec-commonj-1.1.jar

geronimo-specs-1.2-11.jpp6.fc10.noarch : Geronimo J2EE server J2EE specifications
Repo        : jpackage
Matched from:
Filename    : /usr/share/java/geronimo/spec-ejb-2.1-1.2.jar

geronimo-specs-1.2-11.jpp6.fc10.noarch : Geronimo J2EE server J2EE specifications
Repo        : jpackage
Matched from:
Filename    : /usr/share/java/geronimo/spec-ejb-2.1.jar

geronimo-specs-1.0-2.M2.fc10.i386 : Geronimo J2EE server J2EE specifications
Repo        : fedora
Matched from:
Filename    : /usr/share/java/geronimo/spec-ejb-2.1.jar

geronimo-specs-1.2-11.jpp6.fc10.noarch : Geronimo J2EE server J2EE specifications
Repo        : jpackage
Matched from:
Filename    : /usr/share/java/geronimo/spec-ejb-3.0-1.2.jar

geronimo-specs-1.2-11.jpp6.fc10.noarch : Geronimo J2EE server J2EE specifications
Repo        : jpackage
Matched from:
Filename    : /usr/share/java/geronimo/spec-ejb-3.0.jar

geronimo-specs-1.2-11.jpp6.fc10.noarch : Geronimo J2EE server J2EE specifications
Repo        : jpackage
Matched from:
Filename    : /usr/share/java/geronimo/spec-el-1.0-1.2.jar

geronimo-specs-1.2-11.jpp6.fc10.noarch : Geronimo J2EE server J2EE specifications
Repo        : jpackage
Matched from:
Filename    : /usr/share/java/geronimo/spec-el-1.0.jar

geronimo-specs-1.2-11.jpp6.fc10.noarch : Geronimo J2EE server J2EE specifications
Repo        : jpackage
Matched from:
Filename    : /usr/share/java/geronimo/spec-interceptor-3.0-1.2.jar

geronimo-specs-1.2-11.jpp6.fc10.noarch : Geronimo J2EE server J2EE specifications
Repo        : jpackage
Matched from:
Filename    : /usr/share/java/geronimo/spec-interceptor-3.0.jar

geronimo-specs-1.2-11.jpp6.fc10.noarch : Geronimo J2EE server J2EE specifications
Repo        : jpackage
Matched from:
Filename    : /usr/share/java/geronimo/spec-j2ee-connector-1.5-1.2.jar

geronimo-specs-1.2-11.jpp6.fc10.noarch : Geronimo J2EE server J2EE specifications
Repo        : jpackage
Matched from:
Filename    : /usr/share/java/geronimo/spec-j2ee-connector-1.5.jar

geronimo-specs-1.0-2.M2.fc10.i386 : Geronimo J2EE server J2EE specifications
Repo        : fedora
Matched from:
Filename    : /usr/share/java/geronimo/spec-j2ee-connector-1.5.jar

geronimo-specs-1.2-11.jpp6.fc10.noarch : Geronimo J2EE server J2EE specifications
Repo        : jpackage
Matched from:
Filename    : /usr/share/java/geronimo/spec-j2ee-deployment-1.1-1.2.jar

geronimo-specs-1.2-11.jpp6.fc10.noarch : Geronimo J2EE server J2EE specifications
Repo        : jpackage
Matched from:
Filename    : /usr/share/java/geronimo/spec-j2ee-deployment-1.1.jar

geronimo-specs-1.0-2.M2.fc10.i386 : Geronimo J2EE server J2EE specifications
Repo        : fedora
Matched from:
Filename    : /usr/share/java/geronimo/spec-j2ee-deployment-1.1.jar

geronimo-specs-1.2-11.jpp6.fc10.noarch : Geronimo J2EE server J2EE specifications
Repo        : jpackage
Matched from:
Filename    : /usr/share/java/geronimo/spec-j2ee-management-1.0-1.2.jar

geronimo-specs-1.2-11.jpp6.fc10.noarch : Geronimo J2EE server J2EE specifications
Repo        : jpackage
Matched from:
Filename    : /usr/share/java/geronimo/spec-j2ee-management-1.0.jar

geronimo-specs-1.0-2.M2.fc10.i386 : Geronimo J2EE server J2EE specifications
Repo        : fedora
Matched from:
Filename    : /usr/share/java/geronimo/spec-j2ee-management-1.0.jar

geronimo-specs-1.2-11.jpp6.fc10.noarch : Geronimo J2EE server J2EE specifications
Repo        : jpackage
Matched from:
Filename    : /usr/share/java/geronimo/spec-j2ee-management-1.1-1.2.jar

geronimo-specs-1.2-11.jpp6.fc10.noarch : Geronimo J2EE server J2EE specifications
Repo        : jpackage
Matched from:
Filename    : /usr/share/java/geronimo/spec-j2ee-management-1.1.jar

geronimo-specs-1.2-11.jpp6.fc10.noarch : Geronimo J2EE server J2EE specifications
Repo        : jpackage
Matched from:
Filename    : /usr/share/java/geronimo/spec-jacc-1.0-1.2.jar

geronimo-specs-1.2-11.jpp6.fc10.noarch : Geronimo J2EE server J2EE specifications
Repo        : jpackage
Matched from:
Filename    : /usr/share/java/geronimo/spec-jacc-1.0.jar

geronimo-specs-1.2-11.jpp6.fc10.noarch : Geronimo J2EE server J2EE specifications
Repo        : jpackage
Matched from:
Filename    : /usr/share/java/geronimo/spec-jacc-1.1-1.2.jar

geronimo-specs-1.2-11.jpp6.fc10.noarch : Geronimo J2EE server J2EE specifications
Repo        : jpackage
Matched from:
Filename    : /usr/share/java/geronimo/spec-jacc-1.1.jar

geronimo-specs-1.2-11.jpp6.fc10.noarch : Geronimo J2EE server J2EE specifications
Repo        : jpackage
Matched from:
Filename    : /usr/share/java/geronimo/spec-jaf-1.1-1.2.jar

geronimo-specs-1.2-11.jpp6.fc10.noarch : Geronimo J2EE server J2EE specifications
Repo        : jpackage
Matched from:
Filename    : /usr/share/java/geronimo/spec-jaf-1.1.jar

geronimo-specs-1.2-11.jpp6.fc10.noarch : Geronimo J2EE server J2EE specifications
Repo        : jpackage
Matched from:
Filename    : /usr/share/java/geronimo/spec-javaee-deployment-1.1-1.2.jar

geronimo-specs-1.2-11.jpp6.fc10.noarch : Geronimo J2EE server J2EE specifications
Repo        : jpackage
Matched from:
Filename    : /usr/share/java/geronimo/spec-javaee-deployment-1.1.jar

geronimo-specs-1.2-11.jpp6.fc10.noarch : Geronimo J2EE server J2EE specifications
Repo        : jpackage
Matched from:
Filename    : /usr/share/java/geronimo/spec-jms-1.1-1.2.jar

geronimo-specs-1.2-11.jpp6.fc10.noarch : Geronimo J2EE server J2EE specifications
Repo        : jpackage
Matched from:
Filename    : /usr/share/java/geronimo/spec-jms-1.1.jar

geronimo-specs-1.0-2.M2.fc10.i386 : Geronimo J2EE server J2EE specifications
Repo        : fedora
Matched from:
Filename    : /usr/share/java/geronimo/spec-jms-1.1.jar

geronimo-specs-1.2-11.jpp6.fc10.noarch : Geronimo J2EE server J2EE specifications
Repo        : jpackage
Matched from:
Filename    : /usr/share/java/geronimo/spec-jpa-3.0-1.2.jar

geronimo-specs-1.2-11.jpp6.fc10.noarch : Geronimo J2EE server J2EE specifications
Repo        : jpackage
Matched from:
Filename    : /usr/share/java/geronimo/spec-jpa-3.0.jar

geronimo-specs-1.2-11.jpp6.fc10.noarch : Geronimo J2EE server J2EE specifications
Repo        : jpackage
Matched from:
Filename    : /usr/share/java/geronimo/spec-jsp-2.0-1.2.jar

geronimo-specs-1.2-11.jpp6.fc10.noarch : Geronimo J2EE server J2EE specifications
Repo        : jpackage
Matched from:
Filename    : /usr/share/java/geronimo/spec-jsp-2.0.jar

geronimo-specs-1.2-11.jpp6.fc10.noarch : Geronimo J2EE server J2EE specifications
Repo        : jpackage
Matched from:
Filename    : /usr/share/java/geronimo/spec-jsp-2.1-1.2.jar

geronimo-specs-1.2-11.jpp6.fc10.noarch : Geronimo J2EE server J2EE specifications
Repo        : jpackage
Matched from:
Filename    : /usr/share/java/geronimo/spec-jsp-2.1.jar

geronimo-specs-1.2-11.jpp6.fc10.noarch : Geronimo J2EE server J2EE specifications
Repo        : jpackage
Matched from:
Filename    : /usr/share/java/geronimo/spec-jta-1.1-1.2.jar

geronimo-specs-1.2-11.jpp6.fc10.noarch : Geronimo J2EE server J2EE specifications
Repo        : jpackage
Matched from:
Filename    : /usr/share/java/geronimo/spec-jta-1.1.jar

geronimo-specs-1.2-11.jpp6.fc10.noarch : Geronimo J2EE server J2EE specifications
Repo        : jpackage
Matched from:
Filename    : /usr/share/java/geronimo/spec-servlet-2.4-1.2.jar

geronimo-specs-1.2-11.jpp6.fc10.noarch : Geronimo J2EE server J2EE specifications
Repo        : jpackage
Matched from:
Filename    : /usr/share/java/geronimo/spec-servlet-2.4.jar

geronimo-specs-1.2-11.jpp6.fc10.noarch : Geronimo J2EE server J2EE specifications
Repo        : jpackage
Matched from:
Filename    : /usr/share/java/geronimo/spec-servlet-2.5-1.2.jar

geronimo-specs-1.2-11.jpp6.fc10.noarch : Geronimo J2EE server J2EE specifications
Repo        : jpackage
Matched from:
Filename    : /usr/share/java/geronimo/spec-servlet-2.5.jar

geronimo-specs-1.2-11.jpp6.fc10.noarch : Geronimo J2EE server J2EE specifications
Repo        : jpackage
Matched from:
Filename    : /usr/share/java/geronimo/spec-stax-1.0-1.2.jar

geronimo-specs-1.2-11.jpp6.fc10.noarch : Geronimo J2EE server J2EE specifications
Repo        : jpackage
Matched from:
Filename    : /usr/share/java/geronimo/spec-stax-1.0.jar

geronimo-specs-1.2-11.jpp6.fc10.noarch : Geronimo J2EE server J2EE specifications
Repo        : jpackage
Matched from:
Filename    : /usr/share/java/geronimo/spec-ws-metadata-2.0-1.2.jar

geronimo-specs-1.2-11.jpp6.fc10.noarch : Geronimo J2EE server J2EE specifications
Repo        : jpackage
Matched from:
Filename    : /usr/share/java/geronimo/spec-ws-metadata-2.0.jar

geronimo-j2ee-connector-1.5-api-1.2-11.jpp6.fc10.noarch : J2EE Connector v1.5 API
Repo        : jpackage
Matched from:
Filename    : /usr/share/java/j2ee-connector.jar

geronimo-specs-compat-1.0-2.M2.fc10.i386 : Compatibility package for geronimo-specs
Repo        : fedora
Matched from:
Filename    : /usr/share/java/j2ee-connector.jar

geronimo-j2ee-deployment-1.1-api-1.2-11.jpp6.fc10.noarch : J2EE Deployment v1.1 API
Repo        : jpackage
Matched from:
Filename    : /usr/share/java/j2ee-deployment.jar

geronimo-specs-compat-1.0-2.M2.fc10.i386 : Compatibility package for geronimo-specs
Repo        : fedora
Matched from:
Filename    : /usr/share/java/j2ee-deployment.jar

geronimo-j2ee-management-1.1-api-1.2-11.jpp6.fc10.noarch : J2EE Management v1.1 API
Repo        : jpackage
Matched from:
Filename    : /usr/share/java/j2ee-management.jar

geronimo-j2ee-management-1.0-api-1.2-11.jpp6.fc10.noarch : J2EE Management v1.0 API
Repo        : jpackage
Matched from:
Filename    : /usr/share/java/j2ee-management.jar

geronimo-specs-compat-1.0-2.M2.fc10.i386 : Compatibility package for geronimo-specs
Repo        : fedora
Matched from:
Filename    : /usr/share/java/j2ee-management.jar

geronimo-jacc-1.0-api-1.2-11.jpp6.fc10.noarch : J2EE JACC v1.0 API
Repo        : jpackage
Matched from:
Filename    : /usr/share/java/jacc.jar

geronimo-specs-compat-1.0-2.M2.fc10.i386 : Compatibility package for geronimo-specs
Repo        : fedora
Matched from:
Filename    : /usr/share/java/jacc.jar

geronimo-jms-1.1-api-1.2-11.jpp6.fc10.noarch : J2EE JMS v1.1 API
Repo        : jpackage
Matched from:
Filename    : /usr/share/java/jms.jar

geronimo-specs-compat-1.0-2.M2.fc10.i386 : Compatibility package for geronimo-specs
Repo        : fedora
Matched from:
Filename    : /usr/share/java/jms.jar

Comment 13 Magnus Glantz 2009-09-01 08:26:34 UTC
Seems that all links points to -1.2.jar versions of the jars, and that the files in place is versioned -1.1.jar. I've reinstalled all related packages without effect. I'll have to solve it using manual labor.

Comment 14 Magnus Glantz 2009-09-04 09:46:24 UTC
I'm trying to recreate this on a new FC11 install.

Comment 15 Magnus Glantz 2009-09-05 21:45:23 UTC
Well, I very much doubt this was a Spacewalk bug. Closing as 'Notabug'.

Installed Spacewalk on a vanilla FC11 without any extras selected and that installed without any issues at all.

I seem to have gotten struck down by conflicts between Spacewalk/JPackage and Fedora repo packages previously installed by other applications. My machine was a development box, so it had quite many java related applications.

I'm not sure who all the packages that conflicted was, but here's two:
 tomcat6-jsp-2.1-api.noarch
 tomcat6-servlet-2.5-api.noarch

There was also issues with geronimo-* packages. I removed all but 
 geronimo-specs-poms
 geronimo-jta-1.1-api

..those are installed when you install Spacewalk.

I had some issue with some packages not removing faulty symlinks after 'yum remove' and had to manually remove files (checking what files was owned by what package)

After all this I was able to install Spacewalk without issue.

Lesson learned: try and install Spacewalk on a clean FC11. If you have lots of other java related packages installed, they may cause issues.


Note You need to log in before you can comment on or make changes to this bug.