Bug 517985 - s-c-s fails to request authentication from user and doesn't change anything (dbus involved, I guess)
s-c-s fails to request authentication from user and doesn't change anything (...
Status: CLOSED DUPLICATE of bug 500007
Product: Fedora
Classification: Fedora
Component: system-config-services (Show other bugs)
rawhide
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-18 05:54 EDT by Aioanei Rares
Modified: 2009-09-02 05:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 05:57:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aioanei Rares 2009-08-18 05:54:56 EDT
Description of problem:


Version-Release number of selected component (if applicable):

0.99.33

How reproducible:

everytime

Steps to Reproduce:
1.start s-c-s
2.try to disable/stop a service
3.
  
Actual results:

When trying to alter a setting, s-c-s should ask for the root password, but it doesn't and thus won't change anything on clicking disable/enable and/or start/stop.

Expected results:


Additional info:

If running from console as root, I get this :

su -c system-config-services 
Password: 
ERROR:dbus.proxies:Introspect error on :1.126:/org/fedoraproject/Config/Services/ServiceHerders/SysVServiceHerder/Services/iptables: dbus.exceptions.DBusException: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
ERROR:dbus.proxies:Introspect error on :1.126:/org/fedoraproject/Config/Services/ServiceHerders/SysVServiceHerder/Services/multipathd: dbus.exceptions.DBusException: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Traceback (most recent call last):
  File "/usr/bin/system-config-services", line 807, in on_serviceDisable_activate
    service.disable ()
  File "/usr/lib/python2.6/site-packages/slip/dbus/polkit.py", line 53, in enable_proxy_wrapper
    sessionbus = dbus.SessionBus ()
  File "/usr/lib/python2.6/site-packages/dbus/_dbus.py", line 219, in __new__
    mainloop=mainloop)
  File "/usr/lib/python2.6/site-packages/dbus/_dbus.py", line 108, in __new__
    bus = BusConnection.__new__(subclass, bus_type, mainloop=mainloop)
  File "/usr/lib/python2.6/site-packages/dbus/bus.py", line 125, in __new__
    bus = cls._new_for_bus(address_or_type, mainloop=mainloop)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.


If running from terminal as regular user, I get this :

system-config-services 
ERROR:dbus.proxies:Introspect error on :1.130:/org/fedoraproject/Config/Services/ServiceHerders/SysVServiceHerder/Services/iptables: dbus.exceptions.DBusException: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Traceback (most recent call last):
  File "/usr/bin/system-config-services", line 807, in on_serviceDisable_activate
    service.disable ()
  File "/usr/lib/python2.6/site-packages/slip/dbus/polkit.py", line 59, in enable_proxy_wrapper
    dbus_interface = "org.freedesktop.PolicyKit.AuthenticationAgent")
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 68, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.UnknownMethod: Method "ObtainAuthorization" with signature "suu" on interface "org.freedesktop.PolicyKit.AuthenticationAgent" doesn't exist
Comment 1 Nils Philippsen 2009-09-02 05:57:32 EDT

*** This bug has been marked as a duplicate of bug 500007 ***

Note You need to log in before you can comment on or make changes to this bug.