Bug 518066 - Not able to login to the Fedora 11 box
Not able to login to the Fedora 11 box
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
11
i586 Linux
urgent Severity high
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-18 13:11 EDT by sawrub
Modified: 2015-01-14 18:23 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-22 16:08:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sawrub 2009-08-18 13:11:44 EDT
Description of problem:
The GDM askes for password on selecting the user from the list,the password provided is accepted[No Authorization error given] but the login is not granted.
No idea that which update led to this problem, but it just started coming in yesterday.

Version-Release number of selected component (if applicable):


How reproducible:
All that i do is log-out and again try log-in to the system.which fails a couple of time.
Once the login is granted ,following are the logs under 'gnome-system-log > secure'

Aug 18 22:22:44 sawrub-xbox sshd[1527]: Server listening on 0.0.0.0 port 22.
Aug 18 22:22:44 sawrub-xbox sshd[1527]: Server listening on :: port 22.
Aug 18 22:22:56 sawrub-xbox pam: gdm-password[1770]: pam_unix(gdm-password:session): session opened for user sawrub by (uid=0)
Aug 18 22:23:03 sawrub-xbox pam: gdm-password[1770]: pam_unix(gdm-password:session): session closed for user sawrub
Aug 18 22:23:11 sawrub-xbox pam: gdm-password[2190]: pam_unix(gdm-password:session): session opened for user sawrub by (uid=0)
Aug 18 22:23:13 sawrub-xbox pam: gdm-password[2190]: pam_unix(gdm-password:session): session closed for user sawrub
Aug 18 22:23:19 sawrub-xbox pam: gdm-password[2499]: pam_unix(gdm-password:auth): authentication failure; logname= uid=0 euid=0 tty=:0 ruser= rhost=  user=sawrub
Aug 18 22:23:29 sawrub-xbox pam: gdm-password[2512]: pam_unix(gdm-password:session): session opened for user sawrub by (uid=0)
Aug 18 22:23:46 sawrub-xbox pam: gdm-password[2812]: pam_unix(gdm-password:session): session opened for user sawrub by (uid=0)
Aug 18 22:23:46 sawrub-xbox pam: gdm-fingerprint[2813]: pam_succeed_if(gdm-fingerprint:auth): error retrieving user name: Conversation error
Aug 18 22:23:55 sawrub-xbox pam: gdm-password[3105]: pam_unix(gdm-password:session): session opened for user sawrub by (uid=0)
Aug 18 22:24:18 sawrub-xbox su: pam_unix(su-l:session): session opened for user root by sawrub(uid=500)

Wrong password was passed in an attempt to see the GDM response in  that case logged at Aug 18 22:23:19.

Steps to Reproduce:
1. Start the fedora box.
2. Try to login using the password granted to a normal user.
  
Actual results:
The login screen will be greeted after a short delay at a blank [black] screen,on submitting the password.

Expected results:
The user should be granted with the desktop at the first attempt.

Additional info:
Will update on query.
Comment 1 sawrub 2009-08-18 13:15:26 EDT
Following are the all yum updates that i made.

Aug 16 11:20:23 Updated: xorg-x11-server-common-1.6.3-2.fc11.i586
Aug 16 11:20:24 Updated: xorg-x11-server-Xorg-1.6.3-2.fc11.i586
Aug 16 11:32:35 Updated: fontconfig-2.7.1-1.fc11.i586
Aug 16 11:32:35 Updated: ibus-libs-1.1.0.20090612-3.fc11.i586
Aug 16 11:32:36 Updated: check-0.9.6-4.fc11.i586
Aug 16 11:32:36 Updated: 1:cups-libs-1.4-0.rc1.15.fc11.i586
Aug 16 11:32:55 Updated: gnome-pilot-2.0.17-3.fc11.i586
Aug 16 11:32:56 Updated: apr-1.3.8-2.fc11.i586
Aug 16 11:33:01 Updated: 1:cups-1.4-0.rc1.15.fc11.i586
Aug 16 11:33:02 Updated: gtk-nodoka-engine-0.7.2-5.fc11.i586
Aug 16 11:33:02 Updated: hdparm-9.16-1.fc11.i586
Aug 16 11:33:03 Updated: xorg-x11-drv-evdev-2.2.4-1.fc11.i586
Aug 16 11:33:03 Updated: xorg-x11-drv-synaptics-1.1.3-1.fc11.i586
Aug 16 11:33:04 Updated: check-devel-0.9.6-4.fc11.i586
Aug 16 11:33:06 Updated: fontconfig-devel-2.7.1-1.fc11.i586
Aug 16 11:33:08 Updated: tzdata-java-2009k-2.fc11.noarch
Aug 16 11:33:12 Updated: tzdata-2009k-2.fc11.noarch
Aug 16 11:33:12 Updated: ibus-gtk-1.1.0.20090612-3.fc11.i586
Aug 16 11:33:28 Updated: ibus-1.1.0.20090612-3.fc11.i586

Aug 18 21:00:48 Updated: xorg-x11-server-common-1.6.3-3.fc11.i586
Aug 18 21:00:49 Updated: xorg-x11-server-Xorg-1.6.3-3.fc11.i586
Aug 18 21:29:57 Updated: pciutils-libs-3.1.3-1.fc11.i586
Aug 18 21:29:57 Updated: nss-softokn-freebl-3.12.3.99.3-2.11.4.fc11.i586
Aug 18 21:29:58 Updated: nss-3.12.3.99.3-2.11.4.fc11.i586
Aug 18 21:29:59 Updated: nss-tools-3.12.3.99.3-2.11.4.fc11.i586
Aug 18 21:29:59 Updated: pciutils-3.1.3-1.fc11.i586
Aug 18 21:30:36 Updated: gnome-settings-daemon-2.26.1-8.fc11.i586
Aug 18 21:30:37 Updated: gdb-6.8.50.20090302-37.fc11.i586
Aug 18 21:30:38 Updated: kernel-firmware-2.6.29.6-217.2.8.fc11.noarch
Aug 18 21:30:55 Installed: kernel-PAE-2.6.29.6-217.2.8.fc11.i686

And following is OS info
[sawrub@sawrub-xbox ~]$ uname -a
Linux sawrub-xbox 2.6.29.6-217.2.8.fc11.i686.PAE #1 SMP Sat Aug 15 01:07:59 EDT 2009 i686 i686 i386 GNU/Linux
Comment 2 sawrub 2009-08-19 11:25:09 EDT
i had to wait and try around 30 times before i was able to log-in.Please look into this.
Comment 3 bobpoljakov 2009-08-24 06:06:13 EDT
Something similar here.

I manually upgraded xorg-x11-server-Xorg and xorg-x11-server-common to version 1.6.3-4 and than downgraded to 1.6.3-3. I have the same problem, after the computer plays the login sound, the screen goes blank, and drops me back to gdm. After 3-6 tries, i can log in.
Comment 4 sawrub 2009-08-24 10:43:17 EDT
Guessing the problem due to update made to xorg from testing repos,i un-installed the xorg server as a whole and then installed a fresh one again through yum update.And now its back to normal.

Following is the list that i have :
[root@sawrub-xbox ~]# rpm -qa|grep xorg-x11-server
xorg-x11-server-devel-1.6.1.901-1.fc11.i586
xorg-x11-server-common-1.6.1.901-1.fc11.i586
xorg-x11-server-source-1.6.1.901-1.fc11.i586
xorg-x11-server-Xorg-1.6.1.901-1.fc11.i586
xorg-x11-server-utils-7.4-7.fc11.i586
[root@sawrub-xbox ~]# 

though the issue of screen getting blank at regular intervals is still there.
https://bugzilla.redhat.com/show_bug.cgi?id=501601
Comment 5 Fedora 2009-09-20 12:36:23 EDT
This appears to be a duplicate of 518748 which appears to be fixed in the latest Xorg update.
Comment 6 Fedora 2009-09-20 12:39:45 EDT
(In reply to comment #5)
> This appears to be a duplicate of 518748 which appears to be fixed in the
> latest Xorg update.  

That should be linked as bug 518748, you ignorant fool.
Comment 7 Sergey Rudchenko 2009-10-14 15:56:51 EDT
Thank you for the bug report.

Are you still experiencing the problem?

---

Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 8 sawrub 2009-10-16 08:39:30 EDT
No..once the Xorg was reverted back to the previous build .its all fine now.And since i don't have a test machine, hence have excluded Xorg from yum update.
Comment 9 sawrub 2009-10-16 08:46:58 EDT
On a long OFF for the next whole week so will be able to verify it after that if the updates are there.
Comment 10 Christopher Beland 2009-12-18 12:54:08 EST
Have you had the opportunity to test the updates?

---

Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 11 sawrub 2009-12-18 14:29:15 EST
yes presently i'm running following and the issue have not surfaced any more.

[root@mybox ~]# rpm -qa|grep xorg-x11-server
xorg-x11-server-utils-7.4-7.1.fc11.i586
xorg-x11-server-Xorg-1.6.4-0.1.fc11.i586
xorg-x11-server-common-1.6.4-0.1.fc11.i586
[root@mybox ~]#
Comment 12 Sergey Rudchenko 2009-12-22 16:08:35 EST
Seems to be resolved.

---

Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.