Bug 518748 - Update to xserver-xorg 1.6.3 blocks login with compiz enabled, and deadlocks the entire system after switching to console and back to X
Update to xserver-xorg 1.6.3 blocks login with compiz enabled, and deadlocks ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Regression
: 512693 522713 522742 522906 522959 523060 523157 524701 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-22 05:50 EDT by Vincenzo Ciancia
Modified: 2009-10-04 13:17 EDT (History)
44 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-21 10:27:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log file (58.55 KB, text/plain)
2009-09-10 09:00 EDT, xavier.loup
no flags Details
Xorg full backtrace using gdb (2.11 KB, text/plain)
2009-09-14 16:59 EDT, Michal Schmidt
no flags Details

  None (edit)
Description Vincenzo Ciancia 2009-08-22 05:50:15 EDT
Description of problem:

The most recent upgrade of the xorg server in fedora does not allow me to log in: the screen becomes black for a while, and then the login screen is presented again. This is with compiz enabled. Also, switching to a different console (e.g. CTRL+ALT+F2) and back to X deadlocks the system. I have an i965 video card

00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller [8086:27a2] (rev 03)
00:02.1 Display controller [0380]: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller [8086:27a6] (rev 03)

I think that kernel mode setting may be responsible (I found similar bugs in other distribution). Can someone advice how to disable it in Fedora so I can test?
Comment 1 Matthias Runge 2009-09-07 06:51:37 EDT
I'm sure, this is X-related. Switching back to an older xorg-x11-server version fixes the issue. 

Here on 
00:02.0 VGA compatible controller: Intel Corporation 82Q963/Q965 Integrated Graphics Controller (rev 02)
00:02.1 Display controller: Intel Corporation 82Q963/Q965 Integrated Graphics Controller (rev 02)
Comment 2 Vincenzo Ciancia 2009-09-09 08:00:24 EDT
The upgrade in question is https://admin.fedoraproject.org/updates/F11/FEDORA-2009-8766 which has now been pushed to stable. Please take a look to what's going on, the update will break the login process of people with intel cards and compiz enabled (by default in fedora).
Comment 3 Matěj Cepl 2009-09-09 10:19:40 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available), output of dmesg command, /var/log/messags, and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 4 Peter Hutterer 2009-09-09 18:25:02 EDT
Backtrace:
0: /usr/bin/Xorg(xorg_backtrace+0x39) [0x8155cc5]
1: /usr/bin/Xorg(xf86SigHandler+0x9e) [0x80c875a]
2: [0x276400]
3: /usr/lib/dri/i965_dri.so(intelDestroyContext+0x104) [0x6212d4]
4: /usr/lib/dri/i965_dri.so [0x619a66]
5: /usr/lib/xorg/modules/extensions//libglx.so [0x5e46c4]
6: /usr/lib/xorg/modules/extensions//libglx.so(__glXFreeContext+0xa2) [0x5d4a5a]
7: /usr/lib/xorg/modules/extensions//libglx.so [0x5d4c40]
8: /usr/bin/Xorg [0x809223f]
9: /usr/bin/Xorg(CallCallbacks+0x27) [0x80925a4]
10: /usr/bin/Xorg(CloseDownClient+0x1f5) [0x808c36c]
11: /usr/bin/Xorg(Dispatch+0x1ac) [0x8084c14]
12: /usr/bin/Xorg(main+0x52a) [0x806b44e]
13: /lib/libc.so.6(__libc_start_main+0xe6) [0x992a66]
14: /usr/bin/Xorg [0x806ae51]

Fatal server error:
Caught signal 11.  Server aborting
Comment 5 xavier.loup 2009-09-10 09:00:47 EDT
Created attachment 360488 [details]
Xorg log file
Comment 6 Peter Gordon 2009-09-10 17:04:39 EDT
I experience the same problem. Also, attempting to enable Compiz after logging in successfully also causes Xorg to cras back to GDM.
Comment 7 Marek Mahut 2009-09-10 17:53:14 EDT
I had several people reported this same issue to me.
Comment 8 Jud Craft 2009-09-10 18:00:58 EDT
I might have a workaround.  Guys, I'm on an Intel 965 and nothing's wrong.

I've got F11, Xorg 1.6.3, I'm running Compiz, and everything's just fine.

I can log in and out (repeatedly, done it four times already) and I can also do virtual terminal switching like nobody's business.  Hasn't frozen once or dumped me to the login screen.

However, I've got one change.

I have line 19 in /usr/bin/compiz-gtk commented out:

# export LIBGL_ALWAYS_INDIRECT=1

I noticed that opacify has horrible glitches when indirect rendering is enabled.  Everything seems to work just fine without it, so I commented this off.

---

I just tried uncommenting it and restarting.  Now whenever I login, everything crashes to black and I get dumped back to the login screen.

I think this is your culprit.  Something's gone wrong with indirect rendering.

Why does Compiz still use Indirect rendering by default?  Doesn't X support DRI2 and redirected-direct rendering now?
Comment 9 Jud Craft 2009-09-10 18:13:15 EDT
Also, for those of you who run Compiz-Fusion-icon, if you disable loose binding and Indirect Rendering, compiz works just fine.

You may need to edit your ~/.config/compiz/fusion-icon to set indirect rendering and loose binding to false.  (Using a console -- obviously if Compiz is set to start up this way, you won't be able to get in to the graphical Terminal).

When done, Compiz works just fine for me.  If I ever enable them both, I immediately crash out to the login screen.
Comment 10 Vincenzo Ciancia 2009-09-10 20:06:08 EDT
Thanks Jud, compiz works for me after following your advice.
Comment 11 Malte P. 2009-09-11 04:01:42 EDT
after some updates yesterday i was not able to use gnome because x crashed after logging in with compiz enabled. switching from metacity to compiz manually also crashed x with a segfault.
commenting out the export LIBGL_ALWAYS_INDIRECT=1 line like jud fixed the problem for me on two intel atom machines. 
now it works fine again ;-)
Comment 12 Chris Ricker 2009-09-11 09:03:48 EDT
*** Bug 522713 has been marked as a duplicate of this bug. ***
Comment 13 Panos Kavalagios 2009-09-11 09:17:46 EDT
I don't use compiz, but I have faced exactly the same behaviour. X server crashes with the update of xorg server to 1.6.3. My workaround to be able to log in was to simply switch the graphics driver from "intel" to "vesa".
Comment 14 Jason Farrell 2009-09-11 11:19:01 EDT
After this update, my aceraspireone netbook was crashing back to gdm as well. Thanks, Jud, for the hint to disable INDIRECT rendering - works:

To comment out indirect rendering, if set, do:

# sed -i -re 's/(export.*INDIRECT=1)/#\1/' /usr/bin/compiz-gtk

(The next compiz-gnome update will overwrite that temporary fix)
Comment 15 Jud Craft 2009-09-11 11:22:25 EDT
Panos:  Do you run Metacity with compositing?  I have no idea how metacity chooses its rendering mode.
Comment 16 Scott R. Godin 2009-09-11 13:40:23 EDT
confirming that commenting out export LIBGL_ALWAYS_INDIRECT=1 from /usr/bin/compiz-gtk resolved the issue, Gateway laptop MT6705 with Intel 945GM chipset

00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)

compiz-gnome-0.7.8-19.fc11.i586
xorg-x11-server-Xorg-1.6.3-4.fc11.i586
kernel-2.6.30.5-43.fc11.i586

After changing that line, I was able to start up compiz within gnome without crashing, and log out and back in again with no further repetition of the issue.
Comment 17 Vincenzo Ciancia 2009-09-11 18:57:06 EDT
While using the workaround and the newer Xorg, I noticed that my laptop fan was going crazy. The process "kerneloops" was taking around 100% cpu and in dmesg I could see tons of

"Sep 12 00:54:18 frattaglia kernel: [drm:drm_wait_vblank] *ERROR* failed to acquire vblank counter, -22"

I then killed kerneloops, and discovered that enabling the "sync to vblank" option in compiz causes the above message to be logged continuously. This seems a regression, I never noticed this behaviour with the previous package; may it be due to the workaround?
Comment 18 nawbi 2009-09-13 12:25:17 EDT
Dell 1525

00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 0c)
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 0c)

Confirming the workaround works here.
Comment 19 Panos Kavalagios 2009-09-14 01:58:03 EDT
Negative! I'm running kwin only!

The same behaviour observed on my old laptop having an ATI graphics card. After the upgrade KDM couldn't start.

Any workarounds for KDM?
Comment 20 Carlo de Wolf 2009-09-14 02:28:33 EDT
(In reply to comment #8)
> ...
> I have line 19 in /usr/bin/compiz-gtk commented out:
> 
> # export LIBGL_ALWAYS_INDIRECT=1
> ...

Works for me, although my system exhibits the problem described in https://bugzilla.redhat.com/show_bug.cgi?id=522713 ;-)

Sep 14 07:51:13 nymph kernel: Xorg[7808]: segfault at 0 ip 0812d5b6 sp bf9663b8 error 4 in Xorg[8047000+1b8000]
Comment 21 Vincenzo Ciancia 2009-09-14 03:32:56 EDT
Panos, if kdm crashes that shouldn't be the same bug, unless kdm uses composite by default.
Comment 22 Panos Kavalagios 2009-09-14 04:13:40 EDT
Sorry, I meant a workaround for kwin. I was able to start kdm without crashing on a clean xorg.conf.

> grep GLDirect .kde/share/config/kwinrc
GLDirect=false

However, KDE could only start if you have configured it to have no effects at all with the "intel" driver. "Enable Direct Rendering" for OpenGL compositing type does nothing to the crash that occurs with that driver. I rolled back to "vesa" driver to at least have some basic effects.
Comment 23 Jud Craft 2009-09-14 08:02:02 EDT
I don't think it's just indirect rendering that's the problem.  Enabling indirect rendering alone in Compiz-Fusion-Icon doesn't crash the system.  Something called "loose binding" must also be enabled.

Did you try setting GLDirect to -true-?  The workaround is to make sure that *indirect* rendering is not used.
Comment 24 Jonathan Evans 2009-09-14 12:27:19 EDT
I have this problem too. Kicks me back out to the GDM login window. Disabling compiz fixes the problem, but that breaks the Avant window navigator. I am using Intel 915 graphics on x86_64.
Comment 25 Michal Schmidt 2009-09-14 16:52:09 EDT
This bug affects my wife's Fujitsu Siemens ESPRIMO Mobile laptop with
Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03)
as well as my brother's Macbook 4.1.

In both cases upgrading to xorg-x11-server-Xorg-1.6.4-0.1.fc11.x86_64 from Koji helped. I hope we can get another update soon.
Comment 26 Michal Schmidt 2009-09-14 16:59:33 EDT
Created attachment 361005 [details]
Xorg full backtrace using gdb

Here's a full backtrace in case the short one is not detailed enough.
Comment 29 Brandon Gardner 2009-09-14 22:33:25 EDT
I have tried both parts of work around to no avail.  How did you get the Koji file, Michal?  Did you just add the the Koji repo?
Comment 30 Brandon Gardner 2009-09-14 23:07:57 EDT
also have this problem. Please CHECK /var/log/yum.log, if you have UPDATE xorg-x11-server-Xorg, maybe you need to DOWNGRADE it.

On gdm login window, press 'Ctrl+Alt+F2', and login with root
1) yum install yum-plugin-allowdowngrade
2) yum downgrade xorg-x11-server-Xorg

Notice: First need to configure your local network card in order to guarantee access to the Internet

http://forums.fedoraforum.org/showthread.php?t=229898

Worked for me.
Comment 31 Hervé Rilos 2009-09-15 01:21:26 EDT
Same issue here on my Eee PC 901 laptop. But I can log in with compiz if I unplug the power cable !
Comment 32 Michal Schmidt 2009-09-15 03:04:49 EDT
Brandon,
re comment #29: I found it using Koji web interface: http://koji.fedoraproject.org/koji/packageinfo?packageID=63
re comment #30: You do not need to install yum-plugin-allowdowngrade in orded to use yum downgrade. The downgrade command is a part of the core yum nowadays.
Yes, downgrading the X server works too, but I wanted to emphasise the fact that the bug is already fixed in current 1.6.x branch.
Comment 33 Panos Kavalagios 2009-09-15 03:35:26 EDT
(In reply to comment #23)
> Did you try setting GLDirect to -true-?  The workaround is to make sure that
> *indirect* rendering is not used.  

Yeap! It didn't work either. The only think that works is to disable the all effects. New packages from koji xorg-x11-server-Xorg-1.6.4-0.1.fc11.x86_64 and xorg-x11-server-common-1.6.4-0.1.fc11.x86_64 don't fix the problem too.
Comment 34 udo 2009-09-15 09:59:00 EDT
It is not just compiz related.
Here I do not use compiz.
Xorg crashes on startup.
Updating to http://koji.fedoraproject.org/koji/buildinfo?buildID=131217 does not help.
I use radeonhd on x86_64.
It is not just compiz related.
Comment 35 Anthony Horton 2009-09-15 10:13:23 EDT
udo, is is possible that you're being effected instead by this separate bug: https://bugzilla.redhat.com/show_bug.cgi?id=521574 ?

I know there's been some confusion on the forums because the xorg-x11-server updates which cause problems with Intel + compiz were pushed to stable at the same time as the kernel updates which cause Xorg crashes with a range of graphics hardware.

We also have https://bugzilla.redhat.com/show_bug.cgi?id=522742, which may be a duplicate of this one.
Comment 36 udo 2009-09-15 10:22:02 EDT
Dunno for sure.
Xorg starts with:

[drm] Resetting GPU
Xorg[19838]: segfault at 7fff40c60000 ip 000000000047805e sp 00007fff40c5e670 error 4 in Xorg[400000+1b5000]
Xorg[19840]: segfault at 7ffff1713000 ip 000000000047805e sp 00007ffff17122a0 error 4 in Xorg[400000+1b5000]
Xorg[19842]: segfault at 7fff0e595000 ip 000000000047805e sp 00007fff0e5935e0 error 4 in Xorg[400000+1b5000]
Xorg[19844]: segfault at 7fff92bbe000 ip 000000000047805e sp 00007fff92bbd650 error 4 in Xorg[400000+1b5000]
Xorg[19846]: segfault at 7fffe3b28000 ip 000000000047805e sp 00007fffe3b25df0 error 4 in Xorg[400000+1b5000]
Xorg[19848]: segfault at 7fff3c1f5000 ip 000000000047805e sp 00007fff3c1f2ff0 error 4 in Xorg[400000+1b5000]
Xorg[19903]: segfault at 7fff3b660000 ip 000000000047805e sp 00007fff3b65ec60 error 4 in Xorg[400000+1b5000]
Xorg[19905]: segfault at 7fff79564000 ip 000000000047805e sp 00007fff795636d0 error 4 in Xorg[400000+1b5000]
Xorg[19907]: segfault at 7fffd7bca000 ip 000000000047805e sp 00007fffd7bc9510 error 4 in Xorg[400000+1b5000]
Xorg[19909]: segfault at 7fffacf0b000 ip 000000000047805e sp 00007fffacf095c0 error 4 in Xorg[400000+1b5000]
Comment 37 Panos Kavalagios 2009-09-15 10:42:41 EDT
I've seen such kind of messages about segfault of X too. I don't think it's kernel related, since I have installed my kernel on Sep 7 and I had rebooted my system without problems. The updates of Sep 11 caused the problem:

Sep  7 08:38:51 bb229 yum: Installed: kernel-2.6.30.5-43.fc11.x86_64       
...
Sep 11 08:49:41 bb229 yum: Updated: libdrm-2.4.11-2.fc11.x86_64
Sep 11 08:49:41 bb229 yum: Updated: libXext-1.0.99.1-3.fc11.x86_64
Sep 11 08:49:42 bb229 yum: Updated: xorg-x11-server-common-1.6.3-4.fc11.x86_64
Sep 11 08:49:42 bb229 yum: Updated: alsa-lib-1.0.21-3.fc11.x86_64
Sep 11 08:49:43 bb229 yum: Updated: xorg-x11-server-utils-7.4-7.1.fc11.x86_64
Sep 11 08:49:43 bb229 yum: Updated: info-4.13a-4.fc11.x86_64
Sep 11 08:49:44 bb229 yum: Updated: libdrm-devel-2.4.11-2.fc11.x86_64
Sep 11 08:49:47 bb229 yum: Updated: seamonkey-1.1.18-1.fc11.x86_64
Sep 11 08:49:48 bb229 yum: Updated: libXext-1.0.99.1-3.fc11.i586
Sep 11 08:49:49 bb229 yum: Updated: alsa-lib-1.0.21-3.fc11.i586
Sep 11 08:49:49 bb229 yum: Updated: libdrm-2.4.11-2.fc11.i586
Sep 11 08:49:49 bb229 yum: Updated: libXext-devel-1.0.99.1-3.fc11.x86_64
Sep 11 08:49:49 bb229 yum: Updated: xorg-x11-drv-evdev-2.2.5-1.fc11.x86_64
Sep 11 08:49:50 bb229 yum: Updated: xorg-x11-server-Xorg-1.6.3-4.fc11.x86_64
Comment 38 Michal Schmidt 2009-09-15 11:30:44 EDT
So for some people the workaround from comment #8 helps, and so does upgrading to xorg-x11-server-1.6.4-0.1.fc11 from Koji.

The people for which neither of these suggestions helped are probably seeing a different bug. In these cases, the backtrace would also probably be different. Please try to follow upstream's instruction on getting Xorg backtraces using gdb:
http://wiki.x.org/wiki/Development/Documentation/ServerDebugging
Then try to find if it's already been reported, and if not, file another bug.
Comment 39 Matěj Cepl 2009-09-15 11:32:00 EDT
*** Bug 523060 has been marked as a duplicate of this bug. ***
Comment 40 Giuseppe Castagna 2009-09-15 12:35:43 EDT
Hi confirm that for me upgrading to xorg-x11-server-1.6.4-0.1.fc11 from Koji solves all problems. I have a thinkpad X40 with an Intel 82852/855GM Integrated Graphics Device
Comment 41 Joel Uckelman 2009-09-15 13:40:18 EDT
I confirm that upgrading to xorg-x11-server-1.6.4-0.1.fc11 from Koji solves the problem for me on a Thinkpad T61 with Intel GM965/GL960 graphics. Prior to that, X was crashing for me immediately on enabling compiz (or, just immediately, if compiz was started on login).
Comment 42 Damon Stewart 2009-09-15 14:35:16 EDT
I also confirm upgrading to xorg-x11-server-1.6.4-0.1.fc11 as per Michal's comments (see https://bugzilla.redhat.com/show_bug.cgi?id=518748#c32) resolves X from crashing at the gdm login with desktop effects enabled using an Intel IGP.
Comment 43 Magnus Glantz 2009-09-15 17:05:42 EDT
(In reply to comment #8)
> I might have a workaround.  Guys, I'm on an Intel 965 and nothing's wrong.
> 
> I have line 19 in /usr/bin/compiz-gtk commented out:
> 
> # export LIBGL_ALWAYS_INDIRECT=1
> 
I can confirm that this solves the issue for me running FC11 on a ThinPad T400 with Mobile Intel GM45.
Comment 44 udo 2009-09-16 10:13:22 EDT
(In reply to comment #38)
> Then try to find if it's already been reported, and if not, file another bug.  

Is there already another bug reported?
Al bugs I see are evetually compiz related where I even cannot use compiz yet.
Comment 45 Michal Schmidt 2009-09-16 10:40:28 EDT
udo, I don't know if your bug is already reported or not, because that segfault line does not contain enough information. That's also the reason I asked for the backtrace. If for some reason you can't get the full backtrace using gdb, at least look into /var/log/Xorg.0.log to see if there's a short backtrace logged there.
Comment 46 Panos Kavalagios 2009-09-16 10:50:19 EDT
Michal, can you check mine?

https://bugzilla.redhat.com/attachment.cgi?id=361195

At least to conclude if it is about the same problem or not.
Comment 47 udo 2009-09-16 10:59:03 EDT
My xorg logs don't have backtraces.
I try to reserve this report: https://bugzilla.redhat.com/show_bug.cgi?id=522936
 for non-compiz cases.
Comment 48 Michal Schmidt 2009-09-16 11:11:04 EDT
Panos, your backtrace definitely looks quite different from the one attached to this bug. I guess it's because you use "nomodeset", so the driver goes through different paths than with modesetting enabled.
Comment 49 Panos Kavalagios 2009-09-16 11:52:15 EDT
Michal, you're my hero! I've removed "nomodeset" and "vga" parameters from my kernel's boot command line and it works fine with the koji updates. I've also checked the problem with my old xorg.conf and I've seen that I have to remove:

Option          "AutoAddDevices" "off"

from my ServerLayout section, otherwise X couldn't start at all and displayed a black screen.

To conclude, having updated to xorg-x11-server-Xorg-1.6.4-0.1.fc11.x86_64, removed "nomodeset" from grub.conf and "AutoAddDevices" from xorg.conf I am able again to login to my DE with the "intel" driver. Thank you very much!
Comment 50 Michal Schmidt 2009-09-16 12:24:41 EDT
The updated X server is on the way to updates-testing: https://admin.fedoraproject.org/updates/xorg-x11-server-1.6.4-0.1.fc11
Comment 51 Magnus Glantz 2009-09-16 17:37:23 EDT
(In reply to comment #50)
> The updated X server is on the way to updates-testing:
> https://admin.fedoraproject.org/updates/xorg-x11-server-1.6.4-0.1.fc11
Thanks!

Verifying that upgrading to 1.6.4-0.1.fc11.i586 from http://koji.fedoraproject.org/koji/buildinfo?buildID=131217 solved the issue for me.
Comment 52 Jonathan Dieter 2009-09-17 08:17:21 EDT
*** Bug 522742 has been marked as a duplicate of this bug. ***
Comment 53 Christopher A. Williams 2009-09-17 10:16:54 EDT
Was originally following Bug 522742 (duplicate of this bug). Confirmed that upgrading to 1.6.4-0.1.fc11 (x86_64 version) fixes the problem on my ThinkPad T400 using Intel graphics.
Comment 54 Paolo Bonzini 2009-09-21 10:16:22 EDT
*** Bug 522959 has been marked as a duplicate of this bug. ***
Comment 55 Michal Schmidt 2009-09-21 10:27:27 EDT
xorg-x11-server-1.6.4-0.1.fc11 went to stable updates on 2009-09-19. Closing this bug.
Comment 56 Adam Jackson 2009-09-23 09:45:51 EDT
*** Bug 524701 has been marked as a duplicate of this bug. ***
Comment 57 Michal Schmidt 2009-09-30 11:04:36 EDT
*** Bug 523157 has been marked as a duplicate of this bug. ***
Comment 58 Daniel Mircea 2009-10-02 14:44:05 EDT
*** Bug 522906 has been marked as a duplicate of this bug. ***
Comment 59 Michal Schmidt 2009-10-04 13:17:45 EDT
*** Bug 512693 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.