Bug 518203 - No line breaks in the command sequence given in the example for 'exportfs' in Chapter 'Network File System (NFS)'
Summary: No line breaks in the command sequence given in the example for 'exportfs' in...
Keywords:
Status: CLOSED DUPLICATE of bug 453071
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: Deployment_Guide
Version: 5.3
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Douglas Silas
QA Contact: Content Services Development
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-19 13:35 UTC by Runa Bhattacharjee
Modified: 2013-03-04 02:21 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-19 14:22:06 UTC


Attachments (Terms of Use)

Description Runa Bhattacharjee 2009-08-19 13:35:24 UTC
Description of problem:

In the example, showing the commands to be used for 'exportfs with NFSv4' in the Red Hat Enterprise Linux 5.3 Deployment Guide , the line breaks are not present . All the commands are being shown in the same line.

Version-Release number of selected component (if applicable):

Red Hat Enterprise Linux 5 Deployment Guide, Edition 3

How reproducible:


Steps to Reproduce:

1. Visit the link at: http://www.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5/html/Deployment_Guide/s1-nfs-server-config-exports.html#s1-nfs-server-config-exportfs
2. Scroll down to section '19.7.1.1. Using exportfs with NFSv4'
3. The example is shown below the line ' For example, the following commands could be executed on an NFSv4 server:'
  
Actual results:

The entire command sequence shown in a single line

Expected results:

A line break inserted between each commands. Probably in the following format:

mkdir /exports
mkdir /exports/opt
mkdir /exports/etc
mount --bind /usr/local/opt /exports/opt
mount --bind /usr/local/etc /exports/etc 
exportfs -o fsid=0,insecure,no_subtree_check gss/krb5p:/exports
exportfs -o rw,nohide,insecure,no_subtree_check gss/krb5p:/exports/opt
exportfs -o rw,nohide,insecure,no_subtree_check gss/krb5p:/exports/etc

Additional Information:

Nearly all the other examples in this chapter lack line breaks, including command and output examples. For instance, the following:

' $ cat /etc/auto.master /home /etc/auto.misc'

to be found at:

http://www.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5/html/Deployment_Guide/s2-nfs-config-autofs.html

However, none are as massive as the one mentioned earlier for the 'exportfs' example.

Thanks

Comment 1 Douglas Silas 2009-08-19 14:22:06 UTC
Thanks for the report. This is a duplicate of bug 453071; I'm working on solving that one now.

The problem is actually that the computeroutput tag has been used in 837 places in the DocBook source, but that tag does not preserve line breaks in the source. That's what the DocBook manual means when it notes, in the description for computeroutput, that:

"Note that computeroutput is not a verbatim environment, but an inline."

Agreed that "verbatim environment" could have a secondary, more-explicit warning regarding line breaks...

These will all need to be replaced with screen elements.

*** This bug has been marked as a duplicate of bug 453071 ***


Note You need to log in before you can comment on or make changes to this bug.