Bug 453071 - Config files displayed on single line
Config files displayed on single line
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: Deployment_Guide (Show other bugs)
5.2
All Linux
high Severity high
: rc
: ---
Assigned To: Douglas Silas
Content Services Development
: Documentation
: 438823 452065 514410 518203 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-27 00:01 EDT by Jonathan Boulle
Modified: 2016-06-17 17:06 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-03 12:15:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Boulle 2008-06-27 00:01:51 EDT
Description of problem:
In various parts of the RHEL5.2 deployment guide, example configuration files
are displayed (in a yellow box) with all the text compressed to a single line.
This is misleading, confusing and just wrong.

Version-Release number of selected component (if applicable):


How reproducible:
- Look at the Deployment Guide

Steps to Reproduce:
1. Visit, e.g.
http://www.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5.2/html/Deployment_Guide/s2-networkscripts-interfaces-chan.html
http://www.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5.2/html/Deployment_Guide/s2-networkscripts-interfaces-alias.html
http://www.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5.2/html/Deployment_Guide/s2-networkscripts-interfaces-ppp0.html
2. Observe configuration files butchered to a single line
3. Cry
  
Actual results:
- Entire configuration file mashed to a single line

Expected results:
- Config file listed with proper newlines. One example can be found at
http://kbase.redhat.com/faq/FAQ_85_6313.shtm 

Additional info:
- This probably applies to many other parts of the deployment guide; here I've
only listed the three which I stumbled across.
Comment 1 Murray McAllister 2008-06-27 00:04:13 EDT
Mike: customers are copying some of these and saving them, resulting in broken
systems.

Did anything come of the discussion last year about resolving all of these?

Thanks,

Murray.
Comment 3 Jonathan Boulle 2008-06-27 00:09:11 EDT
Reference to the problem on 5.1
https://bugzilla.redhat.com/show_bug.cgi?id=426309
Comment 4 Jonathan Boulle 2008-06-27 00:10:06 EDT
And again
https://bugzilla.redhat.com/show_bug.cgi?id=438823
Comment 5 Murray McAllister 2008-06-27 01:26:43 EDT
I have committed changes to resolve /s2-networkscripts-interfaces-chan.html
(Channel Bonding Interfaces).

Cheers.
Comment 6 Murray McAllister 2008-06-27 01:29:40 EDT
This issue seems to occur if command tags are in screen tags:

<screen>
<command>
blah
blah
blah
</command>
</screen>
Comment 7 blbooth 2008-07-23 22:53:06 EDT
A specific occurrence of the same problem found in the Installation Guide.
https://bugzilla.redhat.com/show_bug.cgi?id=420911
Comment 10 Douglas Silas 2009-08-04 17:06:25 EDT
*** Bug 514410 has been marked as a duplicate of this bug. ***
Comment 11 Douglas Silas 2009-08-19 10:22:06 EDT
*** Bug 518203 has been marked as a duplicate of this bug. ***
Comment 12 Douglas Silas 2009-08-19 10:23:24 EDT
The problem is actually that the computeroutput tag has been used in 837 places in the DocBook source, but that tag does not preserve line breaks in the source. That's what the DocBook manual means when it notes, in the description for computeroutput, that:

"Note that computeroutput is not a verbatim environment, but an inline."

Agreed that "verbatim environment" could have a secondary, more-explicit warning regarding line breaks...

These will all need to be replaced with screen elements.
Comment 13 Douglas Silas 2009-08-20 19:17:18 EDT
Hopefully all fixed in 5.4 branch -r21220 with Java 1.6 regex library, ~115 modifications to 25 files:

<\s*?screen(\s+?moreinfo="none")?\s*?>\s*?<\s*?computeroutput(\s+?moreinfo="none")?\s*?>((\s|\S)*?)<\s*?/computeroutput\s*?>\s*?<\s*?/screen\s*?>

replace with:

<screen>$3</screen>

Visual diff shows line breaks are now correct in all examples I looked at. <command> els inside <screen> els were preserved (as well as inline <computeroutput> els).

Committed. Now going to fix bug 241314 and then to upload corrected books.
Comment 15 Douglas Silas 2009-09-03 14:30:20 EDT
*** Bug 438823 has been marked as a duplicate of this bug. ***
Comment 16 Douglas Silas 2009-09-03 14:32:19 EDT
*** Bug 452065 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.