Bug 51833 - ctrl-o in mc 4.5.51-35 hangs
ctrl-o in mc 4.5.51-35 hangs
Status: CLOSED WORKSFORME
Product: Red Hat Raw Hide
Classification: Retired
Component: mc (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
Aaron Brown
:
: 55273 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-15 13:16 EDT by CoreDump
Modified: 2013-04-02 00:15 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-15 14:50:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description CoreDump 2001-08-15 13:16:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.2-2 i586)

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. start mc in a virtual terminal (not xterm)
2. press ctrl-o
3.
	

Actual Results:  MC stops receiving input, a kill successfully terminates
it, whatever i typed will appear.


Expected Results:  It should give me a shell access.

Additional info:
Comment 1 Mike A. Harris 2001-10-23 08:53:54 EDT
I just tested this in:

[root@rawhide# rpm -q mc
mc-4.5.51-36

and it works fine on s390, x86, alpha, ia64 for me.  Whatever the
problem was, it is either fixed now, or was some temporary glitch.

I use CTRL-O all the time in mc, and have not encountered such a
problem.  The only possible thing I can think of is if you were
possibly using Ximian GNOME, which replaces mc with their own
version.

Closing bug as unable to reproduce in above release.
Comment 2 CoreDump 2001-10-23 15:10:11 EDT
I don't know what causes it, right now i use the downloaded source from
www.gnome.org/mc (version 4.5.55) which doesn't hang up. Some of their previous
releases hung too, but i didn't find anything important in the changelog.
If mine is the only case then *shrug*.
Comment 3 Dominik Mierzejewski 2001-11-10 20:49:53 EST
More people have reported the same bug, including me. I filed it under #55273,
which I'm now marking as duplicate of this one. And yes, upgrading to latest
4.5.55 from gnome.org does solve this, although we no longer get cons.saver,
which is a pity.
Comment 4 Dominik Mierzejewski 2001-11-10 20:50:49 EST
*** Bug 55273 has been marked as a duplicate of this bug. ***
Comment 5 Dominik Mierzejewski 2001-11-10 20:54:03 EST
*** Bug 55273 has been marked as a duplicate of this bug. ***
Comment 6 Dominik Mierzejewski 2001-11-10 20:56:45 EST
*** Bug 55273 has been marked as a duplicate of this bug. ***
Comment 7 Miloslav Trmac 2001-12-05 11:13:25 EST
The reason it fails is that the kernel no longer supports needed TIOCLINUX 
ioctls (grep cons.saver.c for TIOCLINUX) and cons.saver dies when asked to send 
screen contents. The SIGCHLD handler restarts cons.saver, but the new copy 
doesn't know about the request to send screen contents and the processes are 
waiting for each other.
Comment 8 Miloslav Trmac 2001-12-06 07:42:11 EST
Huh? the 7.1 kernel doesn't support the IOCTLs either and I can't remember
these hangs on 7.1
Comment 9 Stas Sergeev 2002-02-04 14:39:18 EST
Will this help if I tell that mc hangs because /bin/login (util-linux) no longer
chowns /dev/vcs and /dev/vcsa?
Changelog of util-linux indicates that this was done intentionally, but why???

Note You need to log in before you can comment on or make changes to this bug.