Bug 518340 - Ks profiles of newly sat-synced trees, don't show up on provisioning list until tomcat is restarted
Summary: Ks profiles of newly sat-synced trees, don't show up on provisioning list unt...
Keywords:
Status: CLOSED DUPLICATE of bug 643905
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning
Version: 530
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Tomas Lestach
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: 462714
TreeView+ depends on / blocked
 
Reported: 2009-08-19 23:05 UTC by Justin Sherrill
Modified: 2012-08-13 16:21 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-13 16:21:05 UTC


Attachments (Terms of Use)

Description Justin Sherrill 2009-08-19 23:05:39 UTC
Steps to Reproduce:
1. run satellite-sync and have it pull down a new kickstart tree
2. create a new kickstart profile associated with the new tree
3. try to provision the machine with the new kickstart profile
  
Actual results:
new profile doesn't show up in the list

Expected results:
new profile does show up in the list

Additional info:

restarting tomcat fixes the issue


Just need to change the hibernate query in KickstartFactory.lookupAccessibleTreesByOrg(org) to not be cacheable .

Comment 1 Tomas Lestach 2012-08-13 16:21:05 UTC
This shall already be resolved. Closing as duplicate.

*** This bug has been marked as a duplicate of bug 643905 ***


Note You need to log in before you can comment on or make changes to this bug.