Bug 643905 - Kickstart profile - hibernate issue : KS profile for Workstation not listed
Kickstart profile - hibernate issue : KS profile for Workstation not listed
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
540
All Linux
high Severity high
: ---
: ---
Assigned To: Tomas Lestach
Lukas Pramuk
:
: 518340 (view as bug list)
Depends On:
Blocks: sat550-blockers sat550-post-ga/sat550-test-blockers
  Show dependency treegraph
 
Reported: 2010-10-18 09:43 EDT by Alexander Todorov
Modified: 2012-10-09 05:19 EDT (History)
7 users (show)

See Also:
Fixed In Version: spacewalk-java-1.7.54-38
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-09 05:19:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2010-10-18 09:43:13 EDT
Description of problem:
The ks profile for RHEL6 Workstation variant is not listed under System -> Provisioning tab. See steps to reproduce for detailed description.

Version-Release number of selected component (if applicable):
5.4.0

How reproducible:
Always

Steps to Reproduce:
1. Register a 5.5 Server system to the Satellite.
2. Enable provisioning. 
3. Create a ks profile that will install the RHEL6.0 Workstation variant (x86_64 arch). 
4. Select the system and then the Provisioning tab.
  
Actual results:
Existing i386/x86_64 profiles for RHEL5, 4 and 6 server are listed. The KS profile for 6.0 Workstation is not.

Expected results:
KS profile for RHEL6.0 Workstation is listed and can be used to re-provision the system.

Additional info:
Comment 6 Tomas Lestach 2011-04-06 10:30:43 EDT
Hello, what is the reproducer for this BZ?
I've followed the one in #Description and I see also the RHEL6 Workstation ks profile offered for the Provisioning tab.
Comment 7 Clifford Perry 2011-04-26 14:07:18 EDT
Tomas - I'm pretty sure the reproducer will be the following:

Sync RHEL 5 Server channel 
 - Create kickstart profile based on this channel
<Do not restart tomcat or any services from this point>
 - sync and import say rhel 5 desktop
 - Go back to the kickstart profile page and try to create a new kickstart profile based on newly imported channel - Notice it is missing 
 - Restart tomcat
 - Refresh page - see option now listed

Smells a lot like a hibernate cache issue on the page. 
As per comment #0 - "The ks profile for RHEL6 Workstation variant is not listed under System -> Provisioning tab."

Cliff
Comment 8 Tomas Lestach 2011-05-05 10:18:09 EDT
Hey Cliff,

this is not about creating new profiles, but about not offering the right profiles for system provisioning.
Anyway, I've tried your scenario with rhel-x86_64-workstation-6 sync. I hit BZ#702274, but after setting selinux to Permissive, cobbler sync task succeeded and 'Red Hat Enterprise Linux Workstation (v. 6 for x86_64)' was offered as Base channel, when creating new ks profile (tomcat wasn't touched).

This ks profile is also offered, when a rhel5 server is set to be provisioned.

I'd pass this BZ to QA, if they will be able to reproduce the problem.

To QA: Make sure you test it, after BZ#702274 is fixed.
Comment 11 Jan Pazdziora 2011-05-16 04:29:34 EDT
Restarting the tomcat6 service makes the kickstart profiles appear at

   /rhn/systems/details/kickstart/ScheduleWizard.do?sid=1000010040

So it's some kind of caching in tomcat/hibernate ruining our queries.
Comment 12 Jan Pazdziora 2011-05-16 04:33:17 EDT
(In reply to comment #11)
> Restarting the tomcat6 service makes the kickstart profiles appear at
> 
>    /rhn/systems/details/kickstart/ScheduleWizard.do?sid=1000010040
> 
> So it's some kind of caching in tomcat/hibernate ruining our queries.

And when I create new kickstart profile now (for the same channel), it adds it to the list on that ScheduleWizard.do page just fine. So I ruined the reproducer machine.
Comment 14 Tomas Lestach 2011-05-17 10:11:41 EDT
According to the previous comment I commit following fix:
spacewalk.git: 96f0e4c685d5de25fb9b7718f680805fbef2f47d

I wasn't able to reproduce the problem and test my fix, even if Dimi is able to reproduce the problem on his satellite.
Comment 16 Dimitar Yordanov 2011-05-19 11:20:23 EDT
VERIFIED.

Note: I managed to reproduce the problem only on RHEL6.
      I did not face the problem on RHEL5.
Comment 18 Jan Pazdziora 2011-06-08 04:29:46 EDT
(In reply to comment #14)
> According to the previous comment I commit following fix:
> spacewalk.git: 96f0e4c685d5de25fb9b7718f680805fbef2f47d
> 
> I wasn't able to reproduce the problem and test my fix, even if Dimi is able to
> reproduce the problem on his satellite.

The commit in SATELLITE-5.4 is 8d3dc3a11f73791053f5bc8bda77f3d4ccf4497c.
Comment 21 Tomas Lestach 2012-05-10 10:20:29 EDT
Rewriting KickstartFactory.lookupAccessibleTreesByOrg ...

spacewalk.git: cd9f7d6f8598d74b32d4d52a7ab4806ea6bb9de5
Comment 24 Lukas Pramuk 2012-08-07 05:32:02 EDT
Verified 
in spacewalk-java-1.7.54-84.el5sat
by running procedure described in Comment#17
Comment 25 Tomas Lestach 2012-08-13 12:21:05 EDT
*** Bug 518340 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.