Bug 518384 - anaconda doesn't put initrd line in grub.conf
Summary: anaconda doesn't put initrd line in grub.conf
Keywords:
Status: CLOSED DUPLICATE of bug 519185
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Hans de Goede
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-20 07:46 UTC by J. Randall Owens
Modified: 2009-08-26 07:13 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-26 07:13:23 UTC


Attachments (Terms of Use)
tarball of anaconda logfiles and grub.conf (47.28 KB, application/gzip)
2009-08-26 01:06 UTC, J. Randall Owens
no flags Details

Description J. Randall Owens 2009-08-20 07:46:39 UTC
Description of problem:
Installing from http://alt.fedoraproject.org/pub/alt/stage/12-Alpha-RC2/Fedora/x86_64/iso/Fedora-12-Alpha-x86_64-netinst.iso, I couldn't boot after a couple of installations.  Checked contents of /boot and /boot/grub/grub.conf from a LiveCD, compared to standard Fedora installation, and realized that those had initrd lines that were missing from the Alpha RC2 grub.conf.  When I inserted a suitable initrd line, it boots up fine (although now, the mouse isn't working, I don't think the keyboard is doing anything, and I'm wondering how to get through setup like this!).

For the sake of others searching on the phrase, the exact message that popped up was "kernel panic - not syncing : VFS: unable to mount root FS on unknown-block(0,0)".

Version-Release number of selected component (if applicable):
I'll let you know when I can boot the system.  Whatever's on the disk I mentioned above.

How reproducible:
Seems easy enough, so far.

Steps to Reproduce:
1. install from netinstall image
2. reboot
3. watch
  
Actual results:
kernel panic - not syncing : VFS: unable to mount root FS on unknown-block(0,0)
frozen, w/ flashing caps lock LED (on a laptop)

Expected results:
At least get to the setup screen, THEN worry about the mouse & keyboard. ;)

Additional info:
My first tries were using LVM & LUKS; I thought those seemed likely culprits, so tried fresh install with plain partitions & no encryption before I found the grub.conf missing line.

Comment 1 Hans de Goede 2009-08-24 11:02:55 UTC
Hmm,

The only way this can happen is if the mkinitrd command has failed to create an initrd. But it hasn't according to you, as adding the initrd line manually fixes things, right?

Can you please attach anaconda.log, storage.log and program.log from /var/log of the installed system ?

Also what does the suitable initrd line you added look like ?

Comment 2 J. Randall Owens 2009-08-26 01:06:28 UTC
Created attachment 358654 [details]
tarball of anaconda logfiles and grub.conf

Here are those log files in a tarball.  I threw in anacond.*log and grub.conf, too, for good measure.  The initrd line I added (the grub.conf in the tarball is the modified one) was just:
        initrd /initrd-generic-2.6.31-0.162.rc6.git2.fc12.x86_64.img

I might have also changed the title to be more descriptive, but in the end, didn't make any other changes there.

Comment 3 Hans de Goede 2009-08-26 07:13:23 UTC
Ah, so while you did use an F-12 *alpha* netinst.iso, you did not point the installer to an F-12 *alpha* repository, but instead to a rawhide repository
(the alpha has kernel-2.6.31-0.125.rc5.git2.fc12, where as you have 2.6.31-0.162.rc6.git2.fc12)

Yes rawhide has been switched over to use dracut, but anaconda does not take this into account while writing grub.conf. This is a known issue which I'm working on fixing, see bug 519185 .

*** This bug has been marked as a duplicate of bug 519185 ***


Note You need to log in before you can comment on or make changes to this bug.