This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 519185 - rawhide install creates grub.conf with no initrd
rawhide install creates grub.conf with no initrd
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
: 518384 519424 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-25 11:09 EDT by James Laska
Modified: 2013-09-02 02:39 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-28 03:34:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda-logs.tgz (34.90 KB, application/octet-stream)
2009-08-25 11:09 EDT, James Laska
no flags Details

  None (edit)
Description James Laska 2009-08-25 11:09:38 EDT
Created attachment 358581 [details]
anaconda-logs.tgz

Description of problem:

I suspect this might not be anaconda's fault, perhaps booty (or dracut)?  The grub.conf created does not contain an initrd-generic line.  The installed system is unbootable.

Version-Release number of selected component (if applicable):
 * anaconda version 12.16
 * kernel-2.6.31-0.167.rc6.git6.fc12.x86_64

How reproducible:
 * seems to be every rawhide install so far

Steps to Reproduce:
1. Perform an installation of rawhide ... accepting all defaults

The *exact* test case to discover this failure was https://fedoraproject.org/wiki/QA/TestCases/PartitioningExt3OnNativeDevice.  However, I don't think that is specific ot the problem yet
  
Actual results:

sh-4.0# cat /mnt/sysimage/boot/grub/grub.conf 
...
title Fedora (2.6.31-0.167.rc6.git6.fc12.x86_64)
	root (hd0,0)
	kernel /vmlinuz-2.6.31-0.167.rc6.git6.fc12.x86_64 ro root=UUID=9a561585-82e3-46a2-8415-033132c1b139 console=ttyS0 rhgb quiet LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us

Expected results:


Additional info:

 * attaching log files:

-rw-r--r-- root/root         0 2009-08-25 11:06 tmp/anaconda-logs.tgz
-rw-r--r-- root/root     53442 2009-08-25 11:00 tmp/anaconda.log
-rw-r--r-- root/root      1271 2009-08-25 10:52 tmp/ks-pre.log
-rw------- root/root        35 2009-08-25 10:51 tmp/ks-script-LJXAFF.log
-rw-r--r-- root/root      9463 2009-08-25 11:00 tmp/program.log
-rw-r--r-- root/root     96791 2009-08-25 11:00 tmp/storage.log
-rw-r--r-- root/root     30601 2009-08-25 10:59 tmp/syslog
-rwxr-xr-x root/root       860 2009-08-25 10:54 tmp/vncserver.log
-rw-r--r-- root/root     68599 2009-08-25 10:52 tmp/yum.log
-rw------- root/root       710 2009-08-25 11:00 mnt/sysimage/boot/grub/grub.conf
Comment 1 James Laska 2009-08-25 11:11:50 EDT
= Workaround =

When I chroot and run new-kernel-pkg by hand ... it creates the expected grub.conf entry.

sh-4.0# chroot /mnt/sysimage /bin/su -
[root@test1222 ~]# /sbin/new-kernel-pkg --package kernel --depmod --add-dracut-args --initrdfile=/boot/initrd-generic-2.6.31-0.167.rc6.git6.fc12.x86_64.img --install 2.6.31-0.167.rc6.git6.fc12.x86_64
[root@test1222 ~]# cat /boot/grub/grub.conf 
...
title Fedora (2.6.31-0.167.rc6.git6.fc12.x86_64)
	root (hd0,0)
	kernel /vmlinuz-2.6.31-0.167.rc6.git6.fc12.x86_64 ro root=UUID=9a561585-82e3-46a2-8415-033132c1b139 console=ttyS0 rhgb quiet LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us rd_plytheme=text
	initrd /initrd-generic-2.6.31-0.167.rc6.git6.fc12.x86_64.img
Comment 2 Hans de Goede 2009-08-26 03:13:23 EDT
*** Bug 518384 has been marked as a duplicate of this bug. ***
Comment 3 Hans de Goede 2009-08-26 11:22:26 EDT
*** Bug 519424 has been marked as a duplicate of this bug. ***
Comment 4 Hans de Goede 2009-08-28 03:34:37 EDT
This is fixed in anaconda-12.17-1, which is in rawhide now, closing.
Comment 5 Richard W.M. Jones 2009-09-17 08:47:41 EDT
Would this bug still be present in Fedora 12 alpha?

I did an install just now (in a VM) of
http://www.mirrorservice.org/sites/download.fedora.redhat.com/pub/fedora/linux/releases/test/12-Alpha/Fedora/x86_64/iso/Fedora-12-Alpha-x86_64-netinst.iso
and grub.conf doesn't have an initrd line:

# guestfish --ro -i /dev/vg_trick/F12Alphax64 

Welcome to guestfish, the libguestfs filesystem interactive shell for
editing virtual machine filesystems.

Type: 'help' for help with commands
      'quit' to quit the shell

><fs> cat /boot/grub/grub.conf 
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,0)
#          kernel /vmlinuz-version ro root=/dev/mapper/vg_f12alphax64-lv_root
#          initrd /initrd-version.img
#boot=/dev/sda
default=0
timeout=0
splashimage=(hd0,0)/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.31-14.fc12.x86_64)
	root (hd0,0)
	kernel /vmlinuz-2.6.31-14.fc12.x86_64 ro root=/dev/mapper/vg_f12alphax64-lv_root rhgb quiet LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us
Comment 6 Richard W.M. Jones 2009-09-17 08:53:47 EDT
Ignore that, what I'm seeing seems to be
bug 519350.

Note You need to log in before you can comment on or make changes to this bug.