Bug 518563 - ibus-anthy doesn't learn candidates when converting plural segments
Summary: ibus-anthy doesn't learn candidates when converting plural segments
Keywords:
Status: CLOSED DUPLICATE of bug 508358
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus-anthy
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-20 22:25 UTC by Masami Hiramatsu
Modified: 2009-08-24 00:50 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-24 00:50:17 UTC


Attachments (Terms of Use)

Description Masami Hiramatsu 2009-08-20 22:25:50 UTC
Description of problem:
ibus-anthy doesn't learn Kanji candidates when converting plural segments. However, it learns candidates when converting single segment.

Version-Release number of selected component (if applicable):
ibus-anthy-1.1.0.20090603-1.fc11.i586

How reproducible:
See, below.

Steps to Reproduce:
1. input single segment
こうそくで -> 高速で

2. convert single segment to another Kanji for learning
こうそくで -> 光速で

3. input single segment again for checking
こうそくで -> 光速で

4. input plural segments (use learned Kanji)
こうそくでいどうする -> 光速で移動する

5. convert plural segments to another Kanji for leaning
こうそくでいどうする -> 高速で移動する

6. input plural segments again (don't use learned Kanji)
こうそくでいどうする -> 光速で移動する


Expected results:
In step 6. it should use learned Kanji. (use same Kanji in step 5.)
こうそくでいどうする -> 高速で移動する

Additional info:
Originally, this problem was reported on a Japanese blog.
http://fun.poosan.net/sawa/index.php?UID=1248624046

On the blog entry, he said that SCIM-anthy can learn the first candidate even if converting plural segments. I checked that was true by using SCIM-anthy.

Comment 1 fujiwara 2009-08-21 03:10:56 UTC
Could you try the nightly RPM if you see your problem?
https://admin.fedoraproject.org/updates/F11/FEDORA-2009-8610

I cannot reproduce your problem with the latest.

Comment 2 Masami Hiramatsu 2009-08-21 16:55:25 UTC
Thanks! The latest package(ibus-anthy-1.1.0.20090814-1.fc11.i586) works perfect!

Comment 3 fujiwara 2009-08-24 00:50:17 UTC
Closing this bug with the submitter's comment.

*** This bug has been marked as a duplicate of bug 508358 ***


Note You need to log in before you can comment on or make changes to this bug.