Bug 518577 - Error: Missing Dependency: kdelibs4(x86-64) >= 4.3.00 is needed by package ktorrent-3.2.3-1.fc11.x86_64 (updates)
Summary: Error: Missing Dependency: kdelibs4(x86-64) >= 4.3.00 is needed by package kt...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ktorrent
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Roland Wolters
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 518579 518963 (view as bug list)
Depends On: kde-4.3.0
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-21 02:38 UTC by Andre Robatino
Modified: 2009-08-25 06:46 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-25 06:46:21 UTC


Attachments (Terms of Use)

Description Andre Robatino 2009-08-21 02:38:38 UTC
Description of problem:
[root@compaq-pc ~]# yum update
Loaded plugins: presto, refresh-packagekit, security
Skipping security plugin, no data
Setting up Update Process
Resolving Dependencies
Skipping security plugin, no data
--> Running transaction check
---> Package ktorrent.x86_64 0:3.2.3-1.fc11 set to be updated
--> Processing Dependency: kdelibs4(x86-64) >= 4.3.00 for package: ktorrent-3.2.3-1.fc11.x86_64
--> Finished Dependency Resolution
ktorrent-3.2.3-1.fc11.x86_64 from updates has depsolving problems
  --> Missing Dependency: kdelibs4(x86-64) >= 4.3.00 is needed by package ktorrent-3.2.3-1.fc11.x86_64 (updates)
Error: Missing Dependency: kdelibs4(x86-64) >= 4.3.00 is needed by package ktorrent-3.2.3-1.fc11.x86_64 (updates)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
[root@compaq-pc ~]#

Additional info:
Fully updated F11 box (except for ktorrent).

Comment 1 Amit Shah 2009-08-21 04:20:16 UTC
*** Bug 518579 has been marked as a duplicate of this bug. ***

Comment 2 Rex Dieter 2009-08-21 12:32:51 UTC
Oops, got inadvertantly pushed to stable prior to kde-4.3.0.

We're currently considering when/how to push kde-4.3.0 stable, stay tuned.

Comment 3 Michal Jaegermann 2009-08-21 16:48:15 UTC
BTW - Fedora 10 got hit in the same manner too.

Comment 4 Sergei LITVINENKO 2009-08-22 17:14:51 UTC
I have the same problem.

ktorrent have to be in updates-testing repository (together with kde-4.3)

Comment 5 Kevin Kofler 2009-08-24 12:31:01 UTC
Consistently setting the status of everything blocked by KDE 4.3.0 to ON_QA. I'll mass-change them to CLOSED ERRATA once the update hits stable.

Comment 6 Rex Dieter 2009-08-24 12:46:02 UTC
*** Bug 518963 has been marked as a duplicate of this bug. ***

Comment 7 Kevin Kofler 2009-08-25 06:46:21 UTC
This issue should be resolved in Fedora 10 and 11 with the KDE 4.3.0 update, which just got pushed to stable. If the issue persists after upgrading to KDE 4.3.0, please report that fact in this bug report.


Note You need to log in before you can comment on or make changes to this bug.