Bug 518631 - "Unable to mount filesystem" error
Summary: "Unable to mount filesystem" error
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
high
urgent
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 518628 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-21 11:18 UTC by Daniel Mach
Modified: 2009-09-22 02:48 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-22 02:48:58 UTC


Attachments (Terms of Use)

Description Daniel Mach 2009-08-21 11:18:47 UTC
Description of problem:
Installation fails with an error related to partitioning.


Version-Release number of selected component (if applicable):
Latest anaconda in rawhide (2009-08-21).


Steps to Reproduce:
80G HDD
3 primary partitions (15000M each, ext3, force primary)
set first one as /
create 4th partition as LVM2 pvm, force primary, fill rest space
create 4096M vg0-swap
  
Actual results:
"Unable to mount filesystem" error with following text:
An error occurred mounting device /dev/sda1 as /:
mount failed: (2, None). This is a fatal error...

Expected results:
should work :)


Additional information:
# fdisk /dev/sda -l
Disk /dev/sda: 80.0 GB, 80000000000 bytes
255 heads, 63 sectors/track, 9726 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x000b1e68

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1        1913    15360000   83  Linux
/dev/sda2            1913        3825    15360000   83  Linux
/dev/sda3            3825        5737    15360000   83  Linux
/dev/sda4            5737        9726    32044063+  8e  Linux LVM


# lvm pvs
  PV         VG   Fmt  Attr PSize  PFree
  /dev/sda4  vg0  lvm2 a-   30.56G 26.56G


# lvm vgs
  VG   #PV #LV #SN Attr   VSize  VFree
  vg0    1   1   0 wz--n- 30.56G 26.56G


# lvm lvs
  LV   VG   Attr   LSize Origin Snap%  Move Log Copy%  Convert
  swap vg0  -wi-ao 4.00G


/tmp/syslog contains this message:
<6>Adding 4194296k swap on /dev/mapper/vg0-swap.  Priority:-1 extents:1 across:4194296k
<6>attempt to access beyond end of device


I can attach additional logs, if needed, let me know if you want any.

Comment 1 Daniel Mach 2009-08-21 11:19:39 UTC
*** Bug 518628 has been marked as a duplicate of this bug. ***

Comment 2 Chris Lumens 2009-08-21 14:22:42 UTC
Can you switch over to tty2 and attempt to mount / using various filesystem types?  In particular, I'm curious if it mounts as ext2.

Comment 3 Daniel Mach 2009-08-23 19:24:03 UTC
The first partition was broken, I suppose it was overwritten by the last one when it "attempted to access beyond the end of device" (see end of the first comment).
When I removed the last partition and reformatted / as ext3, everything worked.


Note You need to log in before you can comment on or make changes to this bug.