This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 518792 - GDM hangs up after few tries to switch user
GDM hangs up after few tries to switch user
Status: CLOSED DUPLICATE of bug 512944
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
11
i686 Linux
low Severity medium
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
: 522197 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-22 17:48 EDT by Tomasz Sałaciński
Modified: 2015-01-14 18:23 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-21 13:35:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Photo of the screen showing the problem (71.03 KB, image/jpeg)
2009-08-22 17:50 EDT, Tomasz Sałaciński
no flags Details

  None (edit)
Description Tomasz Sałaciński 2009-08-22 17:48:01 EDT
Description of problem:

When user fast-user-switch-applet to switch users (I am doing it frequently) GDM hangs completely. The only way to log in is to do ctrl+alt+f9 etc to switch to another users's session. When GDM hangs, I can only see a background, GDM's window (all in gray, no widgets with a white box inside - gtktreeview). Cursor when over this windows shows "busy" state.

The only difference is, when switching users if the background will pop up immediately it will hang, if it will start loading it will pop up correctly after few secs. I can't find anything unusual in GDM logs.


Version-Release number of selected component (if applicable):


How reproducible:
Always.

Steps to Reproduce:
1. Switch users few times in a row
2. Watch GDM hang
3.
  
Actual results:
GDM hangs.

Expected results:
GDM should work.

Additional info:
You can switch user by using ctrl+alt+f[x], or you can go to the console and type killall gdm-binary and it will work properly. I've tested this on two computers (a desktop and a laptop). If this matters, both are using NVIDIA properitary driver (8600GT for desktop and 9800M for laptop). Both systems are up-to-date.

One time I've noticed that this window contains the grayed out login (when user logs in then the widgets gray out, window disappears and user gets logged in). It seems it just doesn't refresh anymore or jump back to the user selection screen.
Comment 1 Tomasz Sałaciński 2009-08-22 17:50:25 EDT
Created attachment 358331 [details]
Photo of the screen showing the problem

This is what shows up after switching users. Sorry for the quality, but I don't know how to make screenshots in such situations so I've made a photo with my camera.
Comment 2 jmccann 2009-08-23 11:04:55 EDT
Yup.  I've seen this too.
Comment 3 Theodore Lee 2009-08-24 07:54:52 EDT
I've also been able to reproduce this problem on a system using Intel 82852/855GM Integrated Graphics. It seems to be rather intermittent - sometimes it will crop up on the first attempted switch, other times it won't show its face at all. I find that manually (Ctrl + Alt + F[#]) switching to the currently logged in users and logging them out seems to get things working again, at least temporarily.
Comment 4 Tomasz Sałaciński 2009-08-25 19:40:23 EDT
Why this bug is marked as low priority? This makes Fedora unusable for multi-user environments.
Comment 5 Stefan Becker 2009-09-12 03:01:49 EDT
Seen by many testers during Fedora 12 Radeon/Nouveau/Intel test days, bug #522197. Duplicate?
Comment 6 Tomasz Sałaciński 2009-09-12 07:52:26 EDT
From reading the users's comments - yes, I think it's a duplicate. Too bad it hasn't been fixed in Fedora 12 yet:( If someone cares Ubuntu 9.10 uses the same GDM and it works fine there.
Comment 7 Sergey Rudchenko 2009-09-15 04:06:51 EDT
*** Bug 522197 has been marked as a duplicate of this bug. ***
Comment 8 nate 2009-10-17 22:18:20 EDT
FWIW I have this issue on Dell Inspiron Intel Quadcore with AMD video card (opensource) drivers running F11 i386 installed from DVD, but not on a Dell latitude D610 running a Intel Pentium M with onboard intel graphics.
Comment 9 Adam Williamson 2009-10-21 13:35:50 EDT
we've been investigating this in the blocker bug review meeting this morning. it seems there are many reports of this type across multiple types of video hardware. closing all reports as dupes of 512944, which is the earliest report. 512944 will be marked as a release blocker.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 512944 ***

Note You need to log in before you can comment on or make changes to this bug.