Bug 522197 - gdm blocked with busy pointer after a few user switches
Summary: gdm blocked with busy pointer after a few user switches
Keywords:
Status: CLOSED DUPLICATE of bug 518792
Alias: None
Product: Fedora
Classification: Fedora
Component: gdm
Version: rawhide
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: jmccann
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 522398 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-09 18:22 UTC by Stefan Becker
Modified: 2015-01-14 23:23 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-15 08:06:51 UTC


Attachments (Terms of Use)
the last log messages (3.44 KB, text/plain)
2009-09-15 07:48 UTC, Sergey Rudchenko
no flags Details

Description Stefan Becker 2009-09-09 18:22:21 UTC
Description of problem:

Fedora 12 Radeon Test Day 2009-09-09 with i686 LiveCD
Fast User Switch Test: works OK, but after a few switches gdm shows up blocked (window not redrawn) and busy pointer

Version-Release number of selected component (if applicable):
kernel-2.6.31-0.212.rc9.git1.fc12.i686
xorg-x11-drv-ati-6.13.0-0.3.20090908git651fe5a47.fc12.i686
libdrm-2.4.12-0.9.fc12.i686
mesa-libGL-7.6-0.9.fc12.i686
gdm-2.27.90-2.fc1.i686

How reproducible:
reproduced at least on two different ATI HWs

Additional info:
Smolt HW1: http://www.smolts.org/client/show/pub_2f56c9e2-bad1-462e-b877-6491a917db79
Smolt HW2: http://www.smolts.org/client/show/pub_aca10945-08f6-4f63-8b44-3a4892d089fa
No xorg.conf in use.

Comment 1 Peter Bloomfield 2009-09-09 23:17:02 UTC
Sounds like what I saw, also with the testday liveCD:
- create second user;
- switch to, and login, second user;
- switch back to liveuser;
- try to switch back to second user.
Gdm shows a white block where the users should be listed, and a busy pointer.

Select VT1 goes back to the liveuser session, but trying to switch again leads to the same busy state.

http://www.smolts.org/client/show/pub_750c4697-63ae-4224-8dd7-0b1274a4978f

Comment 2 Stefan Becker 2009-09-10 17:16:41 UTC
This is not radeon specific. Just happened during my nouveau testing with

http://www.smolts.org/client/show/pub_0f1188c8-b2ed-454d-8eb2-e821375598b6

Must be a gdm problem.

Comment 3 Ben Skeggs 2009-09-10 20:17:02 UTC
(In reply to comment #2)
> This is not radeon specific. Just happened during my nouveau testing with
> 
> http://www.smolts.org/client/show/pub_0f1188c8-b2ed-454d-8eb2-e821375598b6
> 
> Must be a gdm problem.  
Did you see a complete hang by any chance?  There was a nouveau bug I fixed yesterday that could have been responsible in that case: 
http://koji.fedoraproject.org/koji/buildinfo?buildID=131379 is available as a fix however.

Comment 4 Michael Ploujnikov 2009-09-10 20:29:48 UTC
I'm also experiencing this with nouveau on this hardware: http://www.smolts.org/client/show/pub_37498363-965b-4ca7-838d-05e9beb2ec8b

I noticed that clicking on the "Boot messages" and the "Universal Access Preferences" button brings up the relevant windows. Also, the mouse shows a busy animation only when I roll it over the window in the middle which should show a list of users, but is currently blank.

versions of related components:
kernel-2.6.31-0.219.rc9.git2.fc12.x86_64
xorg-x11-drv-nouveau-0.0.15-8.20090904git2b5ec6a.fc12.x86_64
libdrm-2.4.12-0.9.fc12.x86_64
mesa-libGL-7.6-0.11.fc12.x86_64
gdm-2.27.90-2.fc12.x86_64
These came on the nouveau test day LiveCD: http://adamwill.fedorapeople.org/20090909_test_day_images/testday-20090909-x86_64.iso

Comment 5 Ben Skeggs 2009-09-11 04:51:22 UTC
*** Bug 522398 has been marked as a duplicate of this bug. ***

Comment 6 Stefan Becker 2009-09-11 07:40:33 UTC
It is not a complete hang. Just the "login window" of gdm is blank and shows a busy cursor. As Michael already wrote all other items on the gdm screen still work.

Comment 8 A.C.Heron 2009-09-11 10:15:11 UTC
Happens to me as well. Hardware: http://www.smolts.org/show?uuid=pub_2ae59c17-1d75-474d-81db-a034c4a1ad20

Comment 9 Ivan Mironov 2009-09-11 14:25:44 UTC
Same problem with nouveau driver. Smolt profile: http://www.smolts.org/client/show/pub_f9cd3ba0-d620-45df-94f8-b60b8ee220ad

Software versions:
kernel-2.6.31-0.219.rc9.git2.fc12
xorg-x11-server-Xorg-1.6.99.900-1.fc12
xorg-x11-drv-nouveau-0.0.15-8.20090904git2b5ec6a.fc12
firefox-3.5.2-3.fc12
TestDay LiveCD (20090909-x86_64) without any changes.

Comment 10 Walter Francis 2009-09-11 18:17:13 UTC
Same here on Intel Test Day image, testday-20090909-i686.iso on a Dell Latitude X1.

http://www.smolts.org/client/show/pub_99359cea-215f-4505-98a8-c86ba9e3fa18

Comment 11 Tomasz Chrzczonowicz 2009-09-11 23:17:09 UTC
Same here with both Intel i945 and ATI (r300)

Also testday-20090909-i686.iso

Comment 12 Walter Francis 2009-09-14 15:13:57 UTC
My previous Smolt profile is now accidentally a Dell 1150 but the results were the same.  Updated Latitude X1 smolt is now:  http://www.smolts.org/client/show/pub_3c125281-78f5-4b36-bdd1-9f339dcf9ae8

Comment 13 Sergey Rudchenko 2009-09-15 07:48:10 UTC
Created attachment 361045 [details]
the last log messages

Comment 14 Sergey Rudchenko 2009-09-15 07:53:21 UTC
Thank you for the bug report.

---

Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 15 Sergey Rudchenko 2009-09-15 08:06:51 UTC
Thank you for the bug report. This particular bug has already been reported into our bug tracking system, but please feel free to report any further bugs you find.

*** This bug has been marked as a duplicate of bug 518792 ***


Note You need to log in before you can comment on or make changes to this bug.