Bug 518807 - drop eel dependency
drop eel dependency
Status: CLOSED DUPLICATE of bug 477286
Product: Fedora
Classification: Fedora
Component: nautilus-python (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Orphan Owner
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12Target
  Show dependency treegraph
 
Reported: 2009-08-23 02:22 EDT by Matthias Clasen
Modified: 2010-01-27 15:16 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-27 15:16:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Clasen 2009-08-23 02:22:49 EDT
Please drop the eel dependency from nautilus-python.
It should not be needed at all. eel has been incorporated into nautilus itself, and nothing should be using it. From a brief look into the code, just dropping the eel reqs in configure should be enough.
Comment 1 Matthias Clasen 2009-08-23 02:24:05 EDT
I'm asking this, because I'm considering pulling postr onto the live cd, and I don't want to pull in more than necessary for size reasons.
Comment 2 Matthias Clasen 2009-08-23 21:05:41 EDT
This patch is enough to get rid of the eel and gnome-vfs dependencies, along with a bunch of other unneeded library deps.


diff -u -r1.9 nautilus-python.spec
--- nautilus-python.spec	25 Jul 2009 15:47:40 -0000	1.9
+++ nautilus-python.spec	24 Aug 2009 01:04:55 -0000
@@ -44,6 +44,10 @@
 
 %build
 %configure
+
+# fight unused direct deps
+sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+
 make %{?_smp_mflags}
Comment 3 Toshio Ernie Kuratomi 2010-01-27 15:16:42 EST
nautilus-python is currently orphaned.

Note that an update to the current nautilus-python (0.6.1) will fix this.

*** This bug has been marked as a duplicate of bug 477286 ***

Note You need to log in before you can comment on or make changes to this bug.