Bug 518861 - SELinux prevented kde4-config from writing ./.kde
Summary: SELinux prevented kde4-config from writing ./.kde
Keywords:
Status: CLOSED DUPLICATE of bug 498809
Alias: None
Product: Fedora
Classification: Fedora
Component: kdelibs
Version: 11
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-23 15:52 UTC by faith
Modified: 2009-08-23 20:33 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-23 20:33:06 UTC


Attachments (Terms of Use)

Description faith 2009-08-23 15:52:44 UTC
Description of problem:  SELinux prevented kde4-config from writing ./.kde


Version-Release number of selected component (if applicable):


How reproducible:  I have no clue.  I have not used kde since reloading Fc10 (I have Fc11 now).  I use the supposedly more stable Gnome now only.


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Summary:

SELinux prevented kde4-config from writing ./.kde.

Detailed Description:

SELinux prevented kde4-config from writing ./.kde. If ./.kde is a core file, you
may want to allow this. If ./.kde is not a core file, this could signal a
intrusion attempt.

Allowing Access:

Changing the "allow_daemons_dump_core" boolean to true will allow this access:
"setsebool -P allow_daemons_dump_core=1."

Fix Command:

setsebool -P allow_daemons_dump_core=1

Additional Information:

Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:root_t:s0
Target Objects                ./.kde [ dir ]
Source                        kde4-config
Source Path                   /usr/bin/kde4-config
Port                          <Unknown>
Host                          localhost.localdomain
Source RPM Packages           kdelibs-4.2.3-2.fc10
Target RPM Packages           
Policy RPM                    selinux-policy-3.5.13-61.fc10
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   allow_daemons_dump_core
Host Name                     localhost.localdomain
Platform                      Linux localhost.localdomain
                              2.6.27.24-170.2.68.fc10.i686 #1 SMP Wed May 20
                              23:10:16 EDT 2009 i686 i686
Alert Count                   3
First Seen                    Sun 21 Jun 2009 12:38:02 PM EDT
Last Seen                     Sun 21 Jun 2009 01:34:48 PM EDT
Local ID                      8d70bfb1-ba92-4955-ad6f-ba3080ff42e4
Line Numbers                  

Raw Audit Messages            

node=localhost.localdomain type=AVC msg=audit(1245605688.262:6): avc:  denied  { create } for  pid=3092 comm="kde4-config" name=".kde" scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:root_t:s0 tclass=dir

node=localhost.localdomain type=SYSCALL msg=audit(1245605688.262:6): arch=40000003 syscall=39 success=no exit=-13 a0=9d22df8 a1=1c0 a2=23ad950 a3=1 items=0 ppid=3091 pid=3092 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="kde4-config" exe="/usr/bin/kde4-config" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)

Comment 1 Kevin Kofler 2009-08-23 20:33:06 UTC
This is bug 504209, which has the same cause as bug 498809 and thus got closed as a duplicate of that one. Those got fixed on June 15, 2009 in both Fedora 10 and 11. It is no use reporting bugs months after you saw them, without any clue as to whether they even still apply. And if that bug is the reason for you calling KDE "unstable", well it is fixed now (and it was always harmless).

*** This bug has been marked as a duplicate of bug 498809 ***


Note You need to log in before you can comment on or make changes to this bug.